diff mbox series

[4/4] ixp4xx: Add back support for D-Link DSM G600 A

Message ID 20240521-ixp4xx-iomega-nas100d-v1-4-2da1ac27ab9a@linaro.org
State Accepted, archived
Delegated to: Linus Walleij
Headers show
Series ixp4xx: Add upstream supported devices | expand

Commit Message

Linus Walleij May 21, 2024, 7:50 a.m. UTC
OpenWrt supported the D-Link DSM G600 A in the past. It has
64 MB of RAM and 16 MB of flash so it will run just fine,
and should be quite usable with a rootfs on an external
harddrive.

Signed-off-by: Linus Walleij <linus.walleij@linaro.org>
---
 target/linux/ixp4xx/base-files/etc/board.d/02_network |  1 +
 target/linux/ixp4xx/image/Makefile                    | 12 ++++++++++++
 2 files changed, 13 insertions(+)
diff mbox series

Patch

diff --git a/target/linux/ixp4xx/base-files/etc/board.d/02_network b/target/linux/ixp4xx/base-files/etc/board.d/02_network
index 7f75a2e20d33..6a361d4f533e 100644
--- a/target/linux/ixp4xx/base-files/etc/board.d/02_network
+++ b/target/linux/ixp4xx/base-files/etc/board.d/02_network
@@ -9,6 +9,7 @@  gateworks,gw2348|\
 gateworks,gw2358)
 	ucidef_set_interfaces_lan_wan "eth0" "eth1"
 	;;
+dlink,dsm-g600-a|\
 iom,nas-100d|\
 linksys,nslu2)
 	ucidef_set_interface_lan "eth0" "dhcp"
diff --git a/target/linux/ixp4xx/image/Makefile b/target/linux/ixp4xx/image/Makefile
index 15f40821eb21..ace533e50f06 100644
--- a/target/linux/ixp4xx/image/Makefile
+++ b/target/linux/ixp4xx/image/Makefile
@@ -46,6 +46,18 @@  define Device/Default
 	BLOCKSIZE := 128k
 endef
 
+define Device/dlink_dsm_g600_a
+	DEVICE_VENDOR := D-Link
+	DEVICE_MODEL := DSM G600 A
+	DEVICE_PACKAGES := ixp4xx-microcode-ethernet kmod-rtc-pcf8563 kmod-via-velocity kmod-ata-artop kmod-ath5k wpad-basic-mbedtls
+	DEVICE_DTS := intel-ixp42x-dlink-dsm-g600
+	KERNEL := kernel-bin | append-dtb
+	IMAGES := kernel.bin rootfs.bin
+	IMAGE/kernel.bin := append-kernel
+	IMAGE/rootfs.bin := append-rootfs | pad-rootfs | pad-to 128k
+endef
+TARGET_DEVICES += dlink_dsm_g600_a
+
 define Device/freecom_fsg_3
 	DEVICE_VENDOR := Freecom
 	DEVICE_MODEL := FSG-3