diff mbox series

[v2,4/9] kernel: netdevices: Package AMD PHY

Message ID 20230928-ixp4xx-v2-4-ce011eef8239@linaro.org
State Superseded
Headers show
Series Resurrect OpenWrt IXP4xx support | expand

Commit Message

Linus Walleij Sept. 28, 2023, 1:28 p.m. UTC
This adds a package for the AMD and Altima PHY, found in some
odd devices.

Signed-off-by: Linus Walleij <linus.walleij@linaro.org>
---
 package/kernel/linux/modules/netdevices.mk | 16 ++++++++++++++++
 1 file changed, 16 insertions(+)

Comments

Robert Marko Oct. 4, 2023, 12:46 p.m. UTC | #1
On Thu, 28 Sept 2023 at 15:29, Linus Walleij <linus.walleij@linaro.org> wrote:
>
> This adds a package for the AMD and Altima PHY, found in some
> odd devices.
>
> Signed-off-by: Linus Walleij <linus.walleij@linaro.org>
> ---
>  package/kernel/linux/modules/netdevices.mk | 16 ++++++++++++++++
>  1 file changed, 16 insertions(+)
>
> diff --git a/package/kernel/linux/modules/netdevices.mk b/package/kernel/linux/modules/netdevices.mk
> index b0d69e022069..392bc176f491 100644
> --- a/package/kernel/linux/modules/netdevices.mk
> +++ b/package/kernel/linux/modules/netdevices.mk
> @@ -224,6 +224,22 @@ endef
>  $(eval $(call KernelPackage,phylib-broadcom))
>
>
> +define KernelPackage/phy-amd
> +   SUBMENU:=$(NETWORK_DEVICES_MENU)
> +   TITLE:=AMD PHY driver
> +   KCONFIG:=CONFIG_AMD_PHY
> +   DEPENDS:=+kmod-libphy
> +   FILES:=$(LINUX_DIR)/drivers/net/phy/amd.ko
> +   AUTOLOAD:=$(call AutoProbe,and)

Is this PHY used on the only networking interface on any board?
Cause if so, then it would make sense to include it in preinit so that
failsafe will also work.

Regards,
Robert

> +endef
> +
> +define KernelPackage/phy-amd/description
> +   Currently supports the AMD and Altima PHYs.
> +endef
> +
> +$(eval $(call KernelPackage,phy-amd))
> +
> +
>  define KernelPackage/phy-ax88796b
>     SUBMENU:=$(NETWORK_DEVICES_MENU)
>     TITLE:=Asix PHY driver
>
> --
> 2.34.1
>
>
> _______________________________________________
> openwrt-devel mailing list
> openwrt-devel@lists.openwrt.org
> https://lists.openwrt.org/mailman/listinfo/openwrt-devel
diff mbox series

Patch

diff --git a/package/kernel/linux/modules/netdevices.mk b/package/kernel/linux/modules/netdevices.mk
index b0d69e022069..392bc176f491 100644
--- a/package/kernel/linux/modules/netdevices.mk
+++ b/package/kernel/linux/modules/netdevices.mk
@@ -224,6 +224,22 @@  endef
 $(eval $(call KernelPackage,phylib-broadcom))
 
 
+define KernelPackage/phy-amd
+   SUBMENU:=$(NETWORK_DEVICES_MENU)
+   TITLE:=AMD PHY driver
+   KCONFIG:=CONFIG_AMD_PHY
+   DEPENDS:=+kmod-libphy
+   FILES:=$(LINUX_DIR)/drivers/net/phy/amd.ko
+   AUTOLOAD:=$(call AutoProbe,amd)
+endef
+
+define KernelPackage/phy-amd/description
+   Currently supports the AMD and Altima PHYs.
+endef
+
+$(eval $(call KernelPackage,phy-amd))
+
+
 define KernelPackage/phy-ax88796b
    SUBMENU:=$(NETWORK_DEVICES_MENU)
    TITLE:=Asix PHY driver