diff mbox series

[3/4] kernel: Package the new FOTG210 module properly

Message ID 20230531212108.3252356-3-linus.walleij@linaro.org
State Accepted, archived
Headers show
Series None | expand

Commit Message

Linus Walleij May 31, 2023, 9:21 p.m. UTC
When using the Gemini, we apply patches that create a single
module that support both host and device mode these days.

Signed-off-by: Linus Walleij <linus.walleij@linaro.org>
---
 package/kernel/linux/modules/usb.mk | 8 ++++----
 1 file changed, 4 insertions(+), 4 deletions(-)
diff mbox series

Patch

diff --git a/package/kernel/linux/modules/usb.mk b/package/kernel/linux/modules/usb.mk
index 721e17f97087..287a48212153 100644
--- a/package/kernel/linux/modules/usb.mk
+++ b/package/kernel/linux/modules/usb.mk
@@ -332,12 +332,12 @@  endef
 $(eval $(call KernelPackage,usb-bcma))
 
 define KernelPackage/usb-fotg210
-  TITLE:=Support for FOTG210 USB host controllers
+  TITLE:=Support for FOTG210 USB host and device controllers
   DEPENDS:=@USB_SUPPORT @TARGET_gemini
-  KCONFIG:=CONFIG_USB_FOTG210_HCD
+  KCONFIG:=CONFIG_USB_FOTG210
   FILES:= \
-	$(if $(CONFIG_USB_FOTG210_HCD),$(LINUX_DIR)/drivers/usb/host/fotg210-hcd.ko)
-  AUTOLOAD:=$(call AutoLoad,50,fotg210-hcd,1)
+	$(if $(CONFIG_USB_FOTG210),$(LINUX_DIR)/drivers/usb/fotg210/fotg210.ko)
+  AUTOLOAD:=$(call AutoLoad,50,fotg210,1)
   $(call AddDepends/usb)
 endef
 $(eval $(call KernelPackage,usb-fotg210))