diff mbox series

octeontx: add f2fs and ext4 support

Message ID 20230221230829.3825868-1-tharvey@gateworks.com
State Accepted
Delegated to: Hauke Mehrtens
Headers show
Series octeontx: add f2fs and ext4 support | expand

Commit Message

Tim Harvey Feb. 21, 2023, 11:08 p.m. UTC
Add both ext4 and f2fs support for overlayfs. The fstools mount_root
application will choose f2fs if the overlay volume space available
exceeds 100MB, otherwise ext4 is used.

Signed-off-by: Tim Harvey <tharvey@gateworks.com>
---
 target/linux/octeontx/Makefile    | 3 ++-
 target/linux/octeontx/config-5.15 | 2 ++
 2 files changed, 4 insertions(+), 1 deletion(-)

Comments

Hauke Mehrtens Feb. 26, 2023, 5:26 p.m. UTC | #1
On 2/22/23 00:08, Tim Harvey wrote:
> Add both ext4 and f2fs support for overlayfs. The fstools mount_root
> application will choose f2fs if the overlay volume space available
> exceeds 100MB, otherwise ext4 is used.
> 
> Signed-off-by: Tim Harvey <tharvey@gateworks.com>
> ---
>   target/linux/octeontx/Makefile    | 3 ++-
>   target/linux/octeontx/config-5.15 | 2 ++
>   2 files changed, 4 insertions(+), 1 deletion(-)
> 
> diff --git a/target/linux/octeontx/Makefile b/target/linux/octeontx/Makefile
> index 25096c90ba96..57250a5e01ca 100644
> --- a/target/linux/octeontx/Makefile
> +++ b/target/linux/octeontx/Makefile
> @@ -20,7 +20,8 @@ include $(INCLUDE_DIR)/target.mk
>   
>   KERNELNAME:=Image
>   
> -DEFAULT_PACKAGES += kmod-hwmon-gsc kmod-leds-gpio kmod-pps-gpio \
> +DEFAULT_PACKAGES += uboot-envtools mkf2fs e2fsprogs blkid \
> +		    kmod-hwmon-gsc kmod-leds-gpio kmod-pps-gpio \
>   		    kmod-gpio-button-hotplug kmod-input-evdev kmod-rtc-ds1672 \
>   		    kmod-can kmod-can-mcp251x
>   

This patch is not applying for me:
-----
Applying: octeontx: add f2fs and ext4 support
error: sha1 information is lacking or useless 
(target/linux/octeontx/Makefile).
error: could not build fake ancestor
Patch failed at 0001 octeontx: add f2fs and ext4 support
-----



Why do you add uboot-envtools?
Hauke Mehrtens Feb. 26, 2023, 11:54 p.m. UTC | #2
On 2/26/23 18:26, Hauke Mehrtens wrote:
> On 2/22/23 00:08, Tim Harvey wrote:
>> Add both ext4 and f2fs support for overlayfs. The fstools mount_root
>> application will choose f2fs if the overlay volume space available
>> exceeds 100MB, otherwise ext4 is used.
>>
>> Signed-off-by: Tim Harvey <tharvey@gateworks.com>
>> ---
>>   target/linux/octeontx/Makefile    | 3 ++-
>>   target/linux/octeontx/config-5.15 | 2 ++
>>   2 files changed, 4 insertions(+), 1 deletion(-)
>>
>> diff --git a/target/linux/octeontx/Makefile 
>> b/target/linux/octeontx/Makefile
>> index 25096c90ba96..57250a5e01ca 100644
>> --- a/target/linux/octeontx/Makefile
>> +++ b/target/linux/octeontx/Makefile
>> @@ -20,7 +20,8 @@ include $(INCLUDE_DIR)/target.mk
>>   KERNELNAME:=Image
>> -DEFAULT_PACKAGES += kmod-hwmon-gsc kmod-leds-gpio kmod-pps-gpio \
>> +DEFAULT_PACKAGES += uboot-envtools mkf2fs e2fsprogs blkid \
>> +            kmod-hwmon-gsc kmod-leds-gpio kmod-pps-gpio \
>>               kmod-gpio-button-hotplug kmod-input-evdev kmod-rtc-ds1672 \
>>               kmod-can kmod-can-mcp251x
> 
> This patch is not applying for me:
> -----
> Applying: octeontx: add f2fs and ext4 support
> error: sha1 information is lacking or useless 
> (target/linux/octeontx/Makefile).
> error: could not build fake ancestor
> Patch failed at 0001 octeontx: add f2fs and ext4 support
> -----

I saw that this depends on the other patch you send. I applied both of 
them now.

> 
> Why do you add uboot-envtools?
Hauke
diff mbox series

Patch

diff --git a/target/linux/octeontx/Makefile b/target/linux/octeontx/Makefile
index 25096c90ba96..57250a5e01ca 100644
--- a/target/linux/octeontx/Makefile
+++ b/target/linux/octeontx/Makefile
@@ -20,7 +20,8 @@  include $(INCLUDE_DIR)/target.mk
 
 KERNELNAME:=Image
 
-DEFAULT_PACKAGES += kmod-hwmon-gsc kmod-leds-gpio kmod-pps-gpio \
+DEFAULT_PACKAGES += uboot-envtools mkf2fs e2fsprogs blkid \
+		    kmod-hwmon-gsc kmod-leds-gpio kmod-pps-gpio \
 		    kmod-gpio-button-hotplug kmod-input-evdev kmod-rtc-ds1672 \
 		    kmod-can kmod-can-mcp251x
 
diff --git a/target/linux/octeontx/config-5.15 b/target/linux/octeontx/config-5.15
index 36402b70ebfe..40cab28f60a0 100644
--- a/target/linux/octeontx/config-5.15
+++ b/target/linux/octeontx/config-5.15
@@ -145,6 +145,8 @@  CONFIG_EDAC_SUPPORT=y
 CONFIG_EDAC_THUNDERX=y
 # CONFIG_EDAC_XGENE is not set
 CONFIG_EEPROM_AT24=y
+CONFIG_EXT4_FS=y
+CONFIG_F2FS_FS=y
 CONFIG_FAT_FS=y
 CONFIG_FIXED_PHY=y
 CONFIG_FIX_EARLYCON_MEM=y