diff mbox series

bcm47xx: relocate LZMA loader #2

Message ID 20230207140650.24032-1-zajec5@gmail.com
State Changes Requested
Delegated to: Rafał Miłecki
Headers show
Series bcm47xx: relocate LZMA loader #2 | expand

Commit Message

Rafał Miłecki Feb. 7, 2023, 2:06 p.m. UTC
From: Rafał Miłecki <rafal@milecki.pl>

Increased size of the 5.15 kernel requires bumping BZ_TEXT_START again.
Without this CFE hangs at the:
Starting program at 0x80001000

This fixes booting 5.15 based mips74k images on:
1. BCM4706 (Luxul XWR-1750)
2. BCM5357B0 (Linksys E1000 V2.1)
3. BCM47186B0 (Luxul XWR-600)

It isn't needed but also doesn't break:
1. BCM5354 (Asus WL-500gP V2)

Ref: 4cd97e476089 ("bcm47xx: relocate LZMA loader")
Cc: Hauke Mehrtens <hauke@hauke-m.de>
Signed-off-by: Rafał Miłecki <rafal@milecki.pl>
---
 target/linux/bcm47xx/image/lzma-loader/src/Makefile | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

Comments

Rafał Miłecki Feb. 8, 2023, 6:39 a.m. UTC | #1
On 7.02.2023 15:06, Rafał Miłecki wrote:
> From: Rafał Miłecki <rafal@milecki.pl>
> 
> Increased size of the 5.15 kernel requires bumping BZ_TEXT_START again.
> Without this CFE hangs at the:
> Starting program at 0x80001000
> 
> This fixes booting 5.15 based mips74k images on:
> 1. BCM4706 (Luxul XWR-1750)
> 2. BCM5357B0 (Linksys E1000 V2.1)
> 3. BCM47186B0 (Luxul XWR-600)

4. BCM5358 (Linksys E2500 V3)


> It isn't needed but also doesn't break:
> 1. BCM5354 (Asus WL-500gP V2)
> 
> Ref: 4cd97e476089 ("bcm47xx: relocate LZMA loader")
> Cc: Hauke Mehrtens <hauke@hauke-m.de>
> Signed-off-by: Rafał Miłecki <rafal@milecki.pl>
Hauke Mehrtens Feb. 8, 2023, 10:29 p.m. UTC | #2
On 2/7/23 15:06, Rafał Miłecki wrote:
> From: Rafał Miłecki <rafal@milecki.pl>
> 
> Increased size of the 5.15 kernel requires bumping BZ_TEXT_START again.
> Without this CFE hangs at the:
> Starting program at 0x80001000
> 
> This fixes booting 5.15 based mips74k images on:
> 1. BCM4706 (Luxul XWR-1750)
> 2. BCM5357B0 (Linksys E1000 V2.1)
> 3. BCM47186B0 (Luxul XWR-600)
> 
> It isn't needed but also doesn't break:
> 1. BCM5354 (Asus WL-500gP V2)
> 
> Ref: 4cd97e476089 ("bcm47xx: relocate LZMA loader")
> Cc: Hauke Mehrtens <hauke@hauke-m.de>
> Signed-off-by: Rafał Miłecki <rafal@milecki.pl>

Acked-by: Hauke Mehrtens <hauke@hauke-m.de>

Maybe we should increase this even more, then we do not have to change 
this again next year.
Does setting BZ_TEXT_START to 0x80D00000 also work?
I do not think this has any disadvantages.


> ---
>   target/linux/bcm47xx/image/lzma-loader/src/Makefile | 4 ++--
>   1 file changed, 2 insertions(+), 2 deletions(-)
> 
> diff --git a/target/linux/bcm47xx/image/lzma-loader/src/Makefile b/target/linux/bcm47xx/image/lzma-loader/src/Makefile
> index a3e7ae1c92..44891a7ab0 100644
> --- a/target/linux/bcm47xx/image/lzma-loader/src/Makefile
> +++ b/target/linux/bcm47xx/image/lzma-loader/src/Makefile
> @@ -18,8 +18,8 @@
>   #
>   
>   TEXT_START	:= 0x80001000
> -BZ_TEXT_START	:= 0x80700000
> -BZ_STACK_START	:= 0x80800000
> +BZ_TEXT_START	:= 0x80800000
> +BZ_STACK_START	:= 0x80900000
>   
>   OBJCOPY		:= $(CROSS_COMPILE)objcopy -O binary -R .reginfo -R .note -R .comment -R .mdebug -S
>
diff mbox series

Patch

diff --git a/target/linux/bcm47xx/image/lzma-loader/src/Makefile b/target/linux/bcm47xx/image/lzma-loader/src/Makefile
index a3e7ae1c92..44891a7ab0 100644
--- a/target/linux/bcm47xx/image/lzma-loader/src/Makefile
+++ b/target/linux/bcm47xx/image/lzma-loader/src/Makefile
@@ -18,8 +18,8 @@ 
 #
 
 TEXT_START	:= 0x80001000
-BZ_TEXT_START	:= 0x80700000
-BZ_STACK_START	:= 0x80800000
+BZ_TEXT_START	:= 0x80800000
+BZ_STACK_START	:= 0x80900000
 
 OBJCOPY		:= $(CROSS_COMPILE)objcopy -O binary -R .reginfo -R .note -R .comment -R .mdebug -S