diff mbox series

ath79/nand: fix factory image generation for Netgear boards

Message ID 20210211211051.3686-1-fercerpav@gmail.com
State Changes Requested
Delegated to: Adrian Schmutzler
Headers show
Series ath79/nand: fix factory image generation for Netgear boards | expand

Commit Message

Paul Fertser Feb. 11, 2021, 9:10 p.m. UTC
The factory images need to embed specific IDs to pass verification with
the OEM firmware (including TFTP recovery), so they need to be
per-device variables.

Fixes: ab1584a797 ("ath79: netgear: trim down uImage customisations")
Acked-By: Marcin Juszkiewicz <marcin-openwrt@juszkiewicz.com.pl>
Signed-off-by: Paul Fertser <fercerpav@gmail.com>
---
 target/linux/ath79/image/nand.mk | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Adrian Schmutzler Feb. 11, 2021, 10:55 p.m. UTC | #1
Hi,

> -----Original Message-----
> From: openwrt-devel [mailto:openwrt-devel-bounces@lists.openwrt.org]
> On Behalf Of Paul Fertser
> Sent: Donnerstag, 11. Februar 2021 22:11
> To: openwrt-devel@lists.openwrt.org
> Cc: Paul Fertser <fercerpav@gmail.com>; Marcin Juszkiewicz <marcin-
> openwrt@juszkiewicz.com.pl>
> Subject: [PATCH] ath79/nand: fix factory image generation for Netgear
> boards
> 
> The factory images need to embed specific IDs to pass verification with the
> OEM firmware (including TFTP recovery), so they need to be per-device
> variables.
> 
> Fixes: ab1584a797 ("ath79: netgear: trim down uImage customisations")
> Acked-By: Marcin Juszkiewicz <marcin-openwrt@juszkiewicz.com.pl>
> Signed-off-by: Paul Fertser <fercerpav@gmail.com>
> ---
>  target/linux/ath79/image/nand.mk | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
> 
> diff --git a/target/linux/ath79/image/nand.mk
> b/target/linux/ath79/image/nand.mk
> index 37fcb36937..351239e2b3 100644
> --- a/target/linux/ath79/image/nand.mk
> +++ b/target/linux/ath79/image/nand.mk
> @@ -1,4 +1,4 @@
> -DEVICE_VARS += RAS_ROOTFS_SIZE RAS_BOARD RAS_VERSION
> +DEVICE_VARS += RAS_ROOTFS_SIZE RAS_BOARD RAS_VERSION
> NETGEAR_BOARD_ID
> +NETGEAR_HW_ID

These are in common-netgear.mk. I'd say either just include that file here (like done in generic.mk) or move just the DEVICE_VARS addition to image/Makefile.

Best

Adrian

> 
>  # attention: only zlib compression is allowed for the boot fs  define
> Build/zyxel-buildkerneljffs
> --
> 2.20.1
> 
> 
> _______________________________________________
> openwrt-devel mailing list
> openwrt-devel@lists.openwrt.org
> https://lists.openwrt.org/mailman/listinfo/openwrt-devel
diff mbox series

Patch

diff --git a/target/linux/ath79/image/nand.mk b/target/linux/ath79/image/nand.mk
index 37fcb36937..351239e2b3 100644
--- a/target/linux/ath79/image/nand.mk
+++ b/target/linux/ath79/image/nand.mk
@@ -1,4 +1,4 @@ 
-DEVICE_VARS += RAS_ROOTFS_SIZE RAS_BOARD RAS_VERSION
+DEVICE_VARS += RAS_ROOTFS_SIZE RAS_BOARD RAS_VERSION NETGEAR_BOARD_ID NETGEAR_HW_ID
 
 # attention: only zlib compression is allowed for the boot fs
 define Build/zyxel-buildkerneljffs