diff mbox series

link libvalidate to uci

Message ID 20210107011431.1412261-1-rosenp@gmail.com
State Superseded
Headers show
Series link libvalidate to uci | expand

Commit Message

Rosen Penev Jan. 7, 2021, 1:14 a.m. UTC
Fixes ldd error:

Error relocating /lib/libvalidate.so: uci_free_context: symbol not found
Error relocating /lib/libvalidate.so: uci_lookup_ptr: symbol not found
Error relocating /lib/libvalidate.so: uci_alloc_context: symbol not found

Signed-off-by: Rosen Penev <rosenp@gmail.com>
---
 CMakeLists.txt | 1 +
 1 file changed, 1 insertion(+)
diff mbox series

Patch

diff --git a/CMakeLists.txt b/CMakeLists.txt
index 62de1d4..f25fc93 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -43,6 +43,7 @@  INSTALL(TARGETS lsbloader
 )
 
 ADD_LIBRARY(validate SHARED validate/validate.c)
+TARGET_LINK_LIBRARIES(validate uci)
 INSTALL(TARGETS validate
 	LIBRARY DESTINATION lib
 )