diff mbox series

hostapd: add a hostapd-basic-wolfssl variant

Message ID 20201103200803.605462-1-rsalvaterra@gmail.com
State Accepted
Delegated to: Daniel Golle
Headers show
Series hostapd: add a hostapd-basic-wolfssl variant | expand

Commit Message

Rui Salvaterra Nov. 3, 2020, 8:08 p.m. UTC
If only AP mode is needed, this is currently the most space-efficient way to
provide support for WPA{2,3}-PSK, 802.11w and 802.11r.

openwrt-ath79-generic-ubnt_nanostation-loco-m-squashfs-sysupgrade.bin sizes:

4719426 bytes (with wpad-basic-wolfssl)
4457282 bytes (with hostapd-basic-wolfssl)

Signed-off-by: Rui Salvaterra <rsalvaterra@gmail.com>
---
 package/network/services/hostapd/Makefile | 13 +++++++++++++
 1 file changed, 13 insertions(+)

Comments

Adrian Schmutzler Nov. 3, 2020, 8:17 p.m. UTC | #1
> -----Original Message-----
> From: openwrt-devel [mailto:openwrt-devel-bounces@lists.openwrt.org]
> On Behalf Of Rui Salvaterra
> Sent: Dienstag, 3. November 2020 21:08
> To: openwrt-devel@lists.openwrt.org
> Cc: Rui Salvaterra <rsalvaterra@gmail.com>
> Subject: [PATCH] hostapd: add a hostapd-basic-wolfssl variant
> 
> If only AP mode is needed, this is currently the most space-efficient way to
> provide support for WPA{2,3}-PSK, 802.11w and 802.11r.
> 
> openwrt-ath79-generic-ubnt_nanostation-loco-m-squashfs-sysupgrade.bin
> sizes:
> 
> 4719426 bytes (with wpad-basic-wolfssl)
> 4457282 bytes (with hostapd-basic-wolfssl)
> 
> Signed-off-by: Rui Salvaterra <rsalvaterra@gmail.com>

Acked-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>

> ---
>  package/network/services/hostapd/Makefile | 13 +++++++++++++
>  1 file changed, 13 insertions(+)
> 
> diff --git a/package/network/services/hostapd/Makefile
> b/package/network/services/hostapd/Makefile
> index f076eba88f..8c884386f2 100644
> --- a/package/network/services/hostapd/Makefile
> +++ b/package/network/services/hostapd/Makefile
> @@ -204,6 +204,17 @@ define Package/hostapd-basic-openssl/description
>   This package contains a basic IEEE 802.1x/WPA Authenticator with WPA-PSK,
> 802.11r and 802.11w support.
>  endef
> 
> +define Package/hostapd-basic-wolfssl
> +$(call Package/hostapd/Default,$(1))
> +  TITLE+= (WPA-PSK, 11r and 11w)
> +  VARIANT:=basic-wolfssl
> +  DEPENDS+=+libwolfssl
> +endef
> +
> +define Package/hostapd-basic-wolfssl/description
> + This package contains a basic IEEE 802.1x/WPA Authenticator with WPA-
> PSK, 802.11r and 802.11w support.
> +endef
> +
>  define Package/hostapd-mini
>  $(call Package/hostapd/Default,$(1))
>    TITLE+= (WPA-PSK only)
> @@ -598,6 +609,7 @@ define Package/hostapd/install  endef
> Package/hostapd-basic/install = $(Package/hostapd/install)
> Package/hostapd-basic-openssl/install = $(Package/hostapd/install)
> +Package/hostapd-basic-wolfssl/install = $(Package/hostapd/install)
>  Package/hostapd-mini/install = $(Package/hostapd/install)
> Package/hostapd-openssl/install = $(Package/hostapd/install)
> Package/hostapd-wolfssl/install = $(Package/hostapd/install) @@ -668,6
> +680,7 @@ endif  $(eval $(call BuildPackage,hostapd))  $(eval $(call
> BuildPackage,hostapd-basic))  $(eval $(call BuildPackage,hostapd-basic-
> openssl))
> +$(eval $(call BuildPackage,hostapd-basic-wolfssl))
>  $(eval $(call BuildPackage,hostapd-mini))  $(eval $(call
> BuildPackage,hostapd-openssl))  $(eval $(call BuildPackage,hostapd-wolfssl))
> --
> 2.29.1
> 
> 
> _______________________________________________
> openwrt-devel mailing list
> openwrt-devel@lists.openwrt.org
> https://lists.openwrt.org/mailman/listinfo/openwrt-devel
diff mbox series

Patch

diff --git a/package/network/services/hostapd/Makefile b/package/network/services/hostapd/Makefile
index f076eba88f..8c884386f2 100644
--- a/package/network/services/hostapd/Makefile
+++ b/package/network/services/hostapd/Makefile
@@ -204,6 +204,17 @@  define Package/hostapd-basic-openssl/description
  This package contains a basic IEEE 802.1x/WPA Authenticator with WPA-PSK, 802.11r and 802.11w support.
 endef
 
+define Package/hostapd-basic-wolfssl
+$(call Package/hostapd/Default,$(1))
+  TITLE+= (WPA-PSK, 11r and 11w)
+  VARIANT:=basic-wolfssl
+  DEPENDS+=+libwolfssl
+endef
+
+define Package/hostapd-basic-wolfssl/description
+ This package contains a basic IEEE 802.1x/WPA Authenticator with WPA-PSK, 802.11r and 802.11w support.
+endef
+
 define Package/hostapd-mini
 $(call Package/hostapd/Default,$(1))
   TITLE+= (WPA-PSK only)
@@ -598,6 +609,7 @@  define Package/hostapd/install
 endef
 Package/hostapd-basic/install = $(Package/hostapd/install)
 Package/hostapd-basic-openssl/install = $(Package/hostapd/install)
+Package/hostapd-basic-wolfssl/install = $(Package/hostapd/install)
 Package/hostapd-mini/install = $(Package/hostapd/install)
 Package/hostapd-openssl/install = $(Package/hostapd/install)
 Package/hostapd-wolfssl/install = $(Package/hostapd/install)
@@ -668,6 +680,7 @@  endif
 $(eval $(call BuildPackage,hostapd))
 $(eval $(call BuildPackage,hostapd-basic))
 $(eval $(call BuildPackage,hostapd-basic-openssl))
+$(eval $(call BuildPackage,hostapd-basic-wolfssl))
 $(eval $(call BuildPackage,hostapd-mini))
 $(eval $(call BuildPackage,hostapd-openssl))
 $(eval $(call BuildPackage,hostapd-wolfssl))