diff mbox series

util-linux: fix build when libmagic is present

Message ID 20200901223703.785743-1-rosenp@gmail.com
State Changes Requested
Delegated to: Petr Štetiar
Headers show
Series util-linux: fix build when libmagic is present | expand

Commit Message

Rosen Penev Sept. 1, 2020, 10:37 p.m. UTC
Signed-off-by: Rosen Penev <rosenp@gmail.com>
---
 package/utils/util-linux/Makefile | 3 ++-
 1 file changed, 2 insertions(+), 1 deletion(-)

Comments

Sebastian Kemper Sept. 3, 2020, 7:26 p.m. UTC | #1
On Tue, Sep 01, 2020 at 03:37:03PM -0700, Rosen Penev wrote:
> Signed-off-by: Rosen Penev <rosenp@gmail.com>
> ---

Acked-by: Sebastian Kemper <sebastian_ml@gmx.net>

Please apply to get util-linux building. We need libuuid for telephony
and others :-)

Regards,
Seb

>  package/utils/util-linux/Makefile | 3 ++-
>  1 file changed, 2 insertions(+), 1 deletion(-)
>
> diff --git a/package/utils/util-linux/Makefile b/package/utils/util-linux/Makefile
> index 0fc9819c58..05ceaa413e 100644
> --- a/package/utils/util-linux/Makefile
> +++ b/package/utils/util-linux/Makefile
> @@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
>
>  PKG_NAME:=util-linux
>  PKG_VERSION:=2.36
> -PKG_RELEASE:=1
> +PKG_RELEASE:=2
>
>  PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
>  PKG_SOURCE_URL:=@KERNEL/linux/utils/$(PKG_NAME)/v2.36
> @@ -526,6 +526,7 @@ CONFIGURE_ARGS += \
>  	--without-python		\
>  	--without-udev			\
>  	--without-readline		\
> +	--without-libmagic		\
>  	--with-ncursesw
>
>  TARGET_CFLAGS += $(FPIC) -std=gnu99
Petr Štetiar Sept. 4, 2020, 6:29 a.m. UTC | #2
Rosen Penev <rosenp@gmail.com> [2020-09-01 15:37:03]:

From https://openwrt.org/submitting-patches, section about commit description:

 "it will be committed to the source changelog, so it should explain to a
  competent reader why you made this commit.  Include symptoms of the failure
  you are fixing (log messages, error messages, etc.), it will be useful for
  people searching the commit logs looking for a fix for their issue.  If a
  patch fixes a compile failure, include only the most relevant part of the
  failure log"

Thanks.

> Signed-off-by: Rosen Penev <rosenp@gmail.com>
> ---
>  package/utils/util-linux/Makefile | 3 ++-
>  1 file changed, 2 insertions(+), 1 deletion(-)
> 
> diff --git a/package/utils/util-linux/Makefile b/package/utils/util-linux/Makefile
> index 0fc9819c58..05ceaa413e 100644
> --- a/package/utils/util-linux/Makefile
> +++ b/package/utils/util-linux/Makefile
> @@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
>  
>  PKG_NAME:=util-linux
>  PKG_VERSION:=2.36
> -PKG_RELEASE:=1
> +PKG_RELEASE:=2
>  
>  PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
>  PKG_SOURCE_URL:=@KERNEL/linux/utils/$(PKG_NAME)/v2.36
> @@ -526,6 +526,7 @@ CONFIGURE_ARGS += \
>  	--without-python		\
>  	--without-udev			\
>  	--without-readline		\
> +	--without-libmagic		\
>  	--with-ncursesw
>  
>  TARGET_CFLAGS += $(FPIC) -std=gnu99
> -- 
> 2.26.2
> 
> 
> _______________________________________________
> openwrt-devel mailing list
> openwrt-devel@lists.openwrt.org
> https://lists.openwrt.org/mailman/listinfo/openwrt-devel
>
Rosen Penev Sept. 4, 2020, 7:03 a.m. UTC | #3
On Thu, Sep 3, 2020 at 11:29 PM Petr Štetiar <ynezz@true.cz> wrote:
>
> Rosen Penev <rosenp@gmail.com> [2020-09-01 15:37:03]:
>
> From https://openwrt.org/submitting-patches, section about commit description:
>
>  "it will be committed to the source changelog, so it should explain to a
>   competent reader why you made this commit.  Include symptoms of the failure
>   you are fixing (log messages, error messages, etc.), it will be useful for
>   people searching the commit logs looking for a fix for their issue.  If a
>   patch fixes a compile failure, include only the most relevant part of the
>   failure log"
Hahaha I don't think so.
>
> Thanks.
>
> > Signed-off-by: Rosen Penev <rosenp@gmail.com>
> > ---
> >  package/utils/util-linux/Makefile | 3 ++-
> >  1 file changed, 2 insertions(+), 1 deletion(-)
> >
> > diff --git a/package/utils/util-linux/Makefile b/package/utils/util-linux/Makefile
> > index 0fc9819c58..05ceaa413e 100644
> > --- a/package/utils/util-linux/Makefile
> > +++ b/package/utils/util-linux/Makefile
> > @@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
> >
> >  PKG_NAME:=util-linux
> >  PKG_VERSION:=2.36
> > -PKG_RELEASE:=1
> > +PKG_RELEASE:=2
> >
> >  PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
> >  PKG_SOURCE_URL:=@KERNEL/linux/utils/$(PKG_NAME)/v2.36
> > @@ -526,6 +526,7 @@ CONFIGURE_ARGS += \
> >       --without-python                \
> >       --without-udev                  \
> >       --without-readline              \
> > +     --without-libmagic              \
> >       --with-ncursesw
> >
> >  TARGET_CFLAGS += $(FPIC) -std=gnu99
> > --
> > 2.26.2
> >
> >
> > _______________________________________________
> > openwrt-devel mailing list
> > openwrt-devel@lists.openwrt.org
> > https://lists.openwrt.org/mailman/listinfo/openwrt-devel
> >
>
> --
> ynezz
Paul Oranje Sept. 5, 2020, 6:14 p.m. UTC | #4
Op 4 sep. 2020, om 09:03 heeft Rosen Penev <rosenp@gmail.com> het volgende geschreven:
> 
> On Thu, Sep 3, 2020 at 11:29 PM Petr Štetiar <ynezz@true.cz> wrote:
>> 
>> Rosen Penev <rosenp@gmail.com> [2020-09-01 15:37:03]:
>> 
>> From https://openwrt.org/submitting-patches, section about commit description:
>> 
>> "it will be committed to the source changelog, so it should explain to a
>>  competent reader why you made this commit.  Include symptoms of the failure
>>  you are fixing (log messages, error messages, etc.), it will be useful for
>>  people searching the commit logs looking for a fix for their issue.  If a
>>  patch fixes a compile failure, include only the most relevant part of the
>>  failure log"
> Hahaha I don't think so.
This is truly provocative.
As you produce astounding amounts of patches - so many it becomes almost inconceivable that one person only can produce that many - some polite criticism must be taken seriously. This does not feel right.

Regards from a bystander,
Paul

>> 
>> Thanks.
>> 
>>> Signed-off-by: Rosen Penev <rosenp@gmail.com>
>>> ---
>>> package/utils/util-linux/Makefile | 3 ++-
>>> 1 file changed, 2 insertions(+), 1 deletion(-)
>>> 
>>> diff --git a/package/utils/util-linux/Makefile b/package/utils/util-linux/Makefile
>>> index 0fc9819c58..05ceaa413e 100644
>>> --- a/package/utils/util-linux/Makefile
>>> +++ b/package/utils/util-linux/Makefile
>>> @@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
>>> 
>>> PKG_NAME:=util-linux
>>> PKG_VERSION:=2.36
>>> -PKG_RELEASE:=1
>>> +PKG_RELEASE:=2
>>> 
>>> PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
>>> PKG_SOURCE_URL:=@KERNEL/linux/utils/$(PKG_NAME)/v2.36
>>> @@ -526,6 +526,7 @@ CONFIGURE_ARGS += \
>>>      --without-python                \
>>>      --without-udev                  \
>>>      --without-readline              \
>>> +     --without-libmagic              \
>>>      --with-ncursesw
>>> 
>>> TARGET_CFLAGS += $(FPIC) -std=gnu99
>>> --
>>> 2.26.2
>>> 
>>> 
>>> _______________________________________________
>>> openwrt-devel mailing list
>>> openwrt-devel@lists.openwrt.org
>>> https://lists.openwrt.org/mailman/listinfo/openwrt-devel
>>> 
>> 
>> --
>> ynezz
> 
> _______________________________________________
> openwrt-devel mailing list
> openwrt-devel@lists.openwrt.org
> https://lists.openwrt.org/mailman/listinfo/openwrt-devel
diff mbox series

Patch

diff --git a/package/utils/util-linux/Makefile b/package/utils/util-linux/Makefile
index 0fc9819c58..05ceaa413e 100644
--- a/package/utils/util-linux/Makefile
+++ b/package/utils/util-linux/Makefile
@@ -9,7 +9,7 @@  include $(TOPDIR)/rules.mk
 
 PKG_NAME:=util-linux
 PKG_VERSION:=2.36
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=@KERNEL/linux/utils/$(PKG_NAME)/v2.36
@@ -526,6 +526,7 @@  CONFIGURE_ARGS += \
 	--without-python		\
 	--without-udev			\
 	--without-readline		\
+	--without-libmagic		\
 	--with-ncursesw
 
 TARGET_CFLAGS += $(FPIC) -std=gnu99