diff mbox series

libroxml: switch to CMake

Message ID 20200711182015.26400-1-rosenp@gmail.com
State Superseded
Delegated to: Petr Štetiar
Headers show
Series libroxml: switch to CMake | expand

Commit Message

Rosen Penev July 11, 2020, 6:20 p.m. UTC
Added patch to fix compilation with gcc10.

Fixed license information.

Fix ABI_VERSION.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
---
 package/libs/libroxml/Makefile                | 26 +++++++++----------
 package/libs/libroxml/patches/010-gcc10.patch | 11 ++++++++
 2 files changed, 24 insertions(+), 13 deletions(-)
 create mode 100644 package/libs/libroxml/patches/010-gcc10.patch

Comments

Petr Štetiar Nov. 26, 2020, 8:19 a.m. UTC | #1
Rosen Penev <rosenp@gmail.com> [2020-07-11 11:20:15]:

Hi,

> Added patch to fix compilation with gcc10.
> 
> Fixed license information.
> 
> Fix ABI_VERSION.

possibly another candidate for move into packages feed? Thanks!

Cheers,

Petr
Rosen Penev Nov. 26, 2020, 9:29 a.m. UTC | #2
On Thu, Nov 26, 2020 at 12:19 AM Petr Štetiar <ynezz@true.cz> wrote:
>
> Rosen Penev <rosenp@gmail.com> [2020-07-11 11:20:15]:
>
> Hi,
>
> > Added patch to fix compilation with gcc10.
> >
> > Fixed license information.
> >
> > Fix ABI_VERSION.
>
> possibly another candidate for move into packages feed? Thanks!
Yeah I don't know why this package is even here. I don't think
anything uses it. Not even in the packages feed.
>
> Cheers,
>
> Petr
diff mbox series

Patch

diff --git a/package/libs/libroxml/Makefile b/package/libs/libroxml/Makefile
index f60312b1ed..0fb1e3e71f 100644
--- a/package/libs/libroxml/Makefile
+++ b/package/libs/libroxml/Makefile
@@ -9,36 +9,36 @@  include $(TOPDIR)/rules.mk
 
 PKG_NAME:=libroxml
 PKG_VERSION:=3.0.2
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://download.libroxml.net/pool/v3.x
 PKG_HASH:=ed6d68d1bceabf98e5e76907411e2e4d93b2dbd48479ab41dede851f59dad6a3
+
 PKG_MAINTAINER:=Felix Fietkau <nbd@nbd.name>
+PKG_LICENSE:=LGPL-2.1-or-later
+PKG_LICENSE_FILES:=License.txt
 
-PKG_INSTALL:=1
+CMAKE_INSTALL:=1
 PKG_BUILD_PARALLEL:=1
-PKG_LICENSE:=LGPL-2.1+
 
 include $(INCLUDE_DIR)/package.mk
+include $(INCLUDE_DIR)/cmake.mk
 
 define Package/libroxml
   SECTION:=libs
   CATEGORY:=Libraries
   TITLE:=Minimum, easy-to-use, C implementation for xml file parsing
   URL:=http://www.libroxml.net/
-  ABI_VERSION:=3.0.2
+  ABI_VERSION:=2
 endef
 
-CONFIGURE_ARGS += \
-	--enable-shared \
-	--enable-static \
-	--disable-roxml
-
-define Build/InstallDev
-	$(INSTALL_DIR) $(1)
-	$(CP) $(PKG_INSTALL_DIR)/* $(1)/
-endef
+CMAKE_OPTIONS += \
+	-DBUILD_TESTING=OFF \
+	-DCONFIG_XML_FILE=OFF \
+	-DCONFIG_XML_EDIT=OFF \
+	-DCONFIG_XML_COMMIT=OFF \
+	-DCONFIG_XML_XPATH=OFF
 
 define Package/libroxml/install
 	$(INSTALL_DIR) $(1)/usr/lib
diff --git a/package/libs/libroxml/patches/010-gcc10.patch b/package/libs/libroxml/patches/010-gcc10.patch
new file mode 100644
index 0000000000..3c4fee6533
--- /dev/null
+++ b/package/libs/libroxml/patches/010-gcc10.patch
@@ -0,0 +1,11 @@ 
+--- a/src/roxml_mem.h
++++ b/src/roxml_mem.h
+@@ -14,7 +14,7 @@
+ 
+ #include "roxml_internal.h"
+ 
+-memory_cell_t head_cell;
++extern memory_cell_t head_cell;
+ 
+ /** \brief alloc memory function
+  *