diff mbox series

[OpenWrt-Devel,v3,3/3] build: have config-clean deal with old temp files

Message ID 20200419231252.19853-4-cotequeiroz@gmail.com
State Accepted
Delegated to: Petr Štetiar
Headers show
Series build: update scripts/config to kconfig-v5.6 | expand

Commit Message

Eneas U de Queiroz April 19, 2020, 11:12 p.m. UTC
This is a temporary commit to have 'make config-clean' remove
temporary files from the previous scripts/config version.

The .gitignore file is updated to deal with the old files as well.

Cc: Kevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk>
Signed-off-by: Eneas U de Queiroz <cotequeiroz@gmail.com>
diff mbox series

Patch

diff --git a/scripts/config/.gitignore b/scripts/config/.gitignore
index b5bf92f66d..737c5b7953 100644
--- a/scripts/config/.gitignore
+++ b/scripts/config/.gitignore
@@ -12,3 +12,10 @@  mconf
 nconf
 qconf
 gconf
+
+#
+# temporary files from older version.  Should be removed
+#
+zconf.???.c
+zconf.hash.c
+.tmp_qtcheck
diff --git a/scripts/config/Makefile b/scripts/config/Makefile
index eb55b759a8..d98f15c393 100644
--- a/scripts/config/Makefile
+++ b/scripts/config/Makefile
@@ -7,7 +7,10 @@  all: conf mconf
 clean:
 	rm -f *.o lxdialog/*.o *.moc $(clean-files) conf mconf qconf
 
-clean-files	:=
+# This clean-files definition is here to ensure that temporary files from the
+# previous version are removed by make config-clean.
+# It should be removed or emptied when this Makefile get updated again.
+clean-files	:= zconf.tab.c zconf.lex.c zconf.hash.c .tmp_qtcheck
 
 # ===========================================================================
 # Variables needed by the upstream Makefile