diff mbox series

[OpenWrt-Devel] gemini: Add StorLink SL93512r images

Message ID 20190630150756.12439-1-linus.walleij@linaro.org
State Accepted
Delegated to: John Crispin
Headers show
Series [OpenWrt-Devel] gemini: Add StorLink SL93512r images | expand

Commit Message

Linus Walleij June 30, 2019, 3:07 p.m. UTC
This adds image generation for the StorLink reference design
SL93512r. This board is now supported upstream in kernel
v4.19.

As this image structure is identical to SQ201 and Raidsonic,
we simply refer to this as "storlink-reference" from now on.

Signed-off-by: Linus Walleij <linus.walleij@linaro.org>
---
 target/linux/gemini/image/Makefile | 24 +++++++++++++++++-------
 1 file changed, 17 insertions(+), 7 deletions(-)

Comments

Christian Lamparter July 6, 2019, 3:45 p.m. UTC | #1
On Sunday, June 30, 2019 5:07:56 PM CEST Linus Walleij wrote:
> This adds image generation for the StorLink reference design
> SL93512r. This board is now supported upstream in kernel
> v4.19.
> 
> As this image structure is identical to SQ201 and Raidsonic,
> we simply refer to this as "storlink-reference" from now on.
> 
> Signed-off-by: Linus Walleij <linus.walleij@linaro.org>

The buildbots are currently in a bit of a pickle:
<http://phase1.builds.lede-project.org/builders/gemini%2Fgeneric>

The gemini-target is failing for some time now.

This is due to this error (see patch):
https://patchwork.ozlabs.org/patch/1128185/

but also:

cp ./ImageInfo-storlink_sl93512r /home/luser/owrt/test-chunkeey-20190705-170344/gemini-generic/build_dir/target-arm_fa526_musl_eabi/linux-gemini/tmp/openwrt-gemini-storlink_sl93512r-squashfs-factory.bin.tmp/ImageInfo
cp: cannot stat './ImageInfo-storlink_sl93512r': No such file or directory

This is because the script "Build/storlink-default-images" expects to have
a "target/linux/gemini/image/ImageInfo-storlink_sl93512r".

@Linus: Can you please make a patch that adds the missing file?

Regards,
Christian

> ---
>  target/linux/gemini/image/Makefile | 24 +++++++++++++++++-------
>  1 file changed, 17 insertions(+), 7 deletions(-)
> 
> diff --git a/target/linux/gemini/image/Makefile b/target/linux/gemini/image/Makefile
> index 5901bbf0c9b2..7b5faa04fd0e 100644
> --- a/target/linux/gemini/image/Makefile
> +++ b/target/linux/gemini/image/Makefile
> @@ -74,14 +74,15 @@ define Build/wiligear-image
>  	mv $@.new $@
>  endef
>  
> -# Create the special NAS4220B and Itian Square One SQ201 image
> -# format with the squashfs and overlay inside the "rd.gz" file.
> +# Create the default image format used by the StorLink reference design
> +# SL93512r, Raidsonic NAS4220B and Itian Square One SQ201
> +# with the squashfs and overlay inside the "rd.gz" file.
>  # We pad it out to 6144K which is the size of the initramfs partition.
>  #
>  # The "application" partition is just blank. You can put anything
>  # there when using OpenWRT. We just use that to create the
>  # "sysupgrade" firmware image.
> -define Build/nas4220b-sq201-images
> +define Build/storlink-default-images
>  	mkdir -p $@.tmp
>  
>  	mv $@ $@.tmp/rd.gz
> @@ -162,15 +163,16 @@ define Device/dlink_dns-313
>  endef
>  TARGET_DEVICES += dlink_dns-313
>  
> -define Device/itian-raidsonic
> +# Default images setup used by the StorLink reference designs
> +define Device/storlink-reference
>  	IMAGES := factory.bin
>  	IMAGE/factory.bin := append-rootfs | pad-rootfs | pad-to 6144k | \
> -		nas4220b-sq201-images $(1)
> +		storlink-default-images $(1)
>  	DEVICE_PACKAGES := $(GEMINI_NAS_PACKAGES)
>  endef
>  
>  define Device/itian_sq201
> -	$(Device/itian-raidsonic)
> +	$(Device/storlink-reference)
>  	DEVICE_TITLE := ITian Square One SQ201
>  	DEVICE_DTS := gemini-sq201
>  	DEVICE_PACKAGES += kmod-rt61-pci kmod-usb2-pci
> @@ -178,13 +180,21 @@ endef
>  TARGET_DEVICES += itian_sq201
>  
>  define Device/raidsonic_ib-4220-b
> -	$(Device/itian-raidsonic)
> +	$(Device/storlink-reference)
>  	DEVICE_TITLE := Raidsonic NAS IB-4220-B
>  	DEVICE_DTS := gemini-nas4220b
>  	DEVICE_TYPE := nas
>  endef
>  TARGET_DEVICES += raidsonic_ib-4220-b
>  
> +define Device/storlink-sl93512r
> +	$(Device/storlink-reference)
> +	DEVICE_TITLE := StorLink SL93512r
> +	DEVICE_DTS := gemini-sl93512r
> +endef
> +TARGET_DEVICES += storlink_sl93512r
> +
> +
>  # The wiliboard images need some changes to be functional and buildable.
>  #
>  # The dts would need to use the ecoscentric,redboot-fis-partitions partition
>
Linus Walleij July 6, 2019, 11:56 p.m. UTC | #2
On Sat, Jul 6, 2019 at 5:45 PM Christian Lamparter <chunkeey@gmail.com> wrote:

> The buildbots are currently in a bit of a pickle:
> <http://phase1.builds.lede-project.org/builders/gemini%2Fgeneric>
>
> The gemini-target is failing for some time now.
>
> This is due to this error (see patch):
> https://patchwork.ozlabs.org/patch/1128185/

Thanks to Adrian for fixing this part.

> but also:
>
> cp ./ImageInfo-storlink_sl93512r /home/luser/owrt/test-chunkeey-20190705-170344/gemini-generic/build_dir/target-arm_fa526_musl_eabi/linux-gemini/tmp/openwrt-gemini-storlink_sl93512r-squashfs-factory.bin.tmp/ImageInfo
> cp: cannot stat './ImageInfo-storlink_sl93512r': No such file or directory
>
> This is because the script "Build/storlink-default-images" expects to have
> a "target/linux/gemini/image/ImageInfo-storlink_sl93512r".
>
> @Linus: Can you please make a patch that adds the missing file?

Yep I made a patch, testing it as we speak.

Sorry for stupid mistakes, I guess I forgot some git add and
then rebased and lost the file.

Yours,
Linus Walleij
diff mbox series

Patch

diff --git a/target/linux/gemini/image/Makefile b/target/linux/gemini/image/Makefile
index 5901bbf0c9b2..7b5faa04fd0e 100644
--- a/target/linux/gemini/image/Makefile
+++ b/target/linux/gemini/image/Makefile
@@ -74,14 +74,15 @@  define Build/wiligear-image
 	mv $@.new $@
 endef
 
-# Create the special NAS4220B and Itian Square One SQ201 image
-# format with the squashfs and overlay inside the "rd.gz" file.
+# Create the default image format used by the StorLink reference design
+# SL93512r, Raidsonic NAS4220B and Itian Square One SQ201
+# with the squashfs and overlay inside the "rd.gz" file.
 # We pad it out to 6144K which is the size of the initramfs partition.
 #
 # The "application" partition is just blank. You can put anything
 # there when using OpenWRT. We just use that to create the
 # "sysupgrade" firmware image.
-define Build/nas4220b-sq201-images
+define Build/storlink-default-images
 	mkdir -p $@.tmp
 
 	mv $@ $@.tmp/rd.gz
@@ -162,15 +163,16 @@  define Device/dlink_dns-313
 endef
 TARGET_DEVICES += dlink_dns-313
 
-define Device/itian-raidsonic
+# Default images setup used by the StorLink reference designs
+define Device/storlink-reference
 	IMAGES := factory.bin
 	IMAGE/factory.bin := append-rootfs | pad-rootfs | pad-to 6144k | \
-		nas4220b-sq201-images $(1)
+		storlink-default-images $(1)
 	DEVICE_PACKAGES := $(GEMINI_NAS_PACKAGES)
 endef
 
 define Device/itian_sq201
-	$(Device/itian-raidsonic)
+	$(Device/storlink-reference)
 	DEVICE_TITLE := ITian Square One SQ201
 	DEVICE_DTS := gemini-sq201
 	DEVICE_PACKAGES += kmod-rt61-pci kmod-usb2-pci
@@ -178,13 +180,21 @@  endef
 TARGET_DEVICES += itian_sq201
 
 define Device/raidsonic_ib-4220-b
-	$(Device/itian-raidsonic)
+	$(Device/storlink-reference)
 	DEVICE_TITLE := Raidsonic NAS IB-4220-B
 	DEVICE_DTS := gemini-nas4220b
 	DEVICE_TYPE := nas
 endef
 TARGET_DEVICES += raidsonic_ib-4220-b
 
+define Device/storlink-sl93512r
+	$(Device/storlink-reference)
+	DEVICE_TITLE := StorLink SL93512r
+	DEVICE_DTS := gemini-sl93512r
+endef
+TARGET_DEVICES += storlink_sl93512r
+
+
 # The wiliboard images need some changes to be functional and buildable.
 #
 # The dts would need to use the ecoscentric,redboot-fis-partitions partition