diff mbox series

[OpenWrt-Devel,2/2] mvebu: remove default profile

Message ID 20190113202923.13481-2-tomek_n@o2.pl
State Superseded
Headers show
Series [OpenWrt-Devel,1/2] mvebu: move HARDEN_BRANCH_PREDICTOR to common config | expand

Commit Message

Tomasz Maciej Nowak Jan. 13, 2019, 8:29 p.m. UTC
When using Image Builder and building image for Cortex A53 or
A72 subtargets, it'll fail with following message:

Collected errors:
 * opkg_install_cmd: Cannot install package mwlwifi-firmware-88w8864.
 * opkg_install_cmd: Cannot install package mwlwifi-firmware-88w8964.
make[2]: *** [Makefile:153: package_install] Error 255
make[1]: *** [Makefile:114: _call_image] Error 2

This is beacuse both packages are available only for Cortex A9 subtarget
and are included in PACKAGES array in default profile. Instead patching
this, let's remove profiles completely, since all necessary packages are
specified in DEVICE_PACKAGES array for each device.

Signed-off-by: Tomasz Maciej Nowak <tomek_n@o2.pl>
---
 target/linux/mvebu/image/Makefile          |  1 -
 target/linux/mvebu/profiles/000-Default.mk | 18 ------------------
 2 files changed, 19 deletions(-)
 delete mode 100644 target/linux/mvebu/profiles/000-Default.mk

Comments

Rosen Penev Jan. 17, 2019, 4:38 a.m. UTC | #1
On Sun, Jan 13, 2019 at 12:28 PM Tomasz Maciej Nowak <tomek_n@o2.pl> wrote:
>
> When using Image Builder and building image for Cortex A53 or
> A72 subtargets, it'll fail with following message:
>
> Collected errors:
>  * opkg_install_cmd: Cannot install package mwlwifi-firmware-88w8864.
>  * opkg_install_cmd: Cannot install package mwlwifi-firmware-88w8964.
> make[2]: *** [Makefile:153: package_install] Error 255
> make[1]: *** [Makefile:114: _call_image] Error 2
>
> This is beacuse both packages are available only for Cortex A9 subtarget
> and are included in PACKAGES array in default profile. Instead patching
> this, let's remove profiles completely, since all necessary packages are
> specified in DEVICE_PACKAGES array for each device.
NACK. This breaks Turris Omnia compilation. Something about a clearfog
bootloader.
>
> Signed-off-by: Tomasz Maciej Nowak <tomek_n@o2.pl>
> ---
>  target/linux/mvebu/image/Makefile          |  1 -
>  target/linux/mvebu/profiles/000-Default.mk | 18 ------------------
>  2 files changed, 19 deletions(-)
>  delete mode 100644 target/linux/mvebu/profiles/000-Default.mk
>
> diff --git a/target/linux/mvebu/image/Makefile b/target/linux/mvebu/image/Makefile
> index be01623e86..22519bd9d0 100644
> --- a/target/linux/mvebu/image/Makefile
> +++ b/target/linux/mvebu/image/Makefile
> @@ -81,7 +81,6 @@ define Build/omnia-medkit-initramfs
>  endef
>
>  define Device/Default
> -  PROFILES := Default
>    DEVICE_DTS := $(1)
>    BOARD_NAME = $$(DEVICE_DTS)
>    KERNEL_NAME := zImage
> diff --git a/target/linux/mvebu/profiles/000-Default.mk b/target/linux/mvebu/profiles/000-Default.mk
> deleted file mode 100644
> index 8690dd8da5..0000000000
> --- a/target/linux/mvebu/profiles/000-Default.mk
> +++ /dev/null
> @@ -1,18 +0,0 @@
> -#
> -# Copyright (C) 2015 OpenWrt.org
> -#
> -# This is free software, licensed under the GNU General Public License v2.
> -# See /LICENSE for more information.
> -#
> -
> -define Profile/Default
> -       NAME:=Default Profile (all drivers)
> -       PACKAGES:= kmod-mwlwifi wpad-basic swconfig mkf2fs e2fsprogs \
> -                  mwlwifi-firmware-88w8864 mwlwifi-firmware-88w8964
> -endef
> -
> -define Profile/Default/Description
> -       Default package set compatible with most boards.
> -endef
> -
> -$(eval $(call Profile,Default))
> --
> 2.20.1
>
>
> _______________________________________________
> openwrt-devel mailing list
> openwrt-devel@lists.openwrt.org
> https://lists.openwrt.org/mailman/listinfo/openwrt-devel
Mathias Kresin Jan. 17, 2019, 7:51 a.m. UTC | #2
17/01/2019 05:38, Rosen Penev:
> On Sun, Jan 13, 2019 at 12:28 PM Tomasz Maciej Nowak <tomek_n@o2.pl> wrote:
>>
>> When using Image Builder and building image for Cortex A53 or
>> A72 subtargets, it'll fail with following message:
>>
>> Collected errors:
>>   * opkg_install_cmd: Cannot install package mwlwifi-firmware-88w8864.
>>   * opkg_install_cmd: Cannot install package mwlwifi-firmware-88w8964.
>> make[2]: *** [Makefile:153: package_install] Error 255
>> make[1]: *** [Makefile:114: _call_image] Error 2
>>
>> This is beacuse both packages are available only for Cortex A9 subtarget
>> and are included in PACKAGES array in default profile. Instead patching
>> this, let's remove profiles completely, since all necessary packages are
>> specified in DEVICE_PACKAGES array for each device.
> NACK. This breaks Turris Omnia compilation. Something about a clearfog
> bootloader.

Would you please try to add the "PROFILES := Default" again to the 
"define Device/Default" section and check if it fixes your build error?

On gemini, I noticed that due to the missing PROFILES all images are 
build, regardless of the selected (or currently processed in case of a 
multi profile build).

It causes race conditions on gemini and is most likely the reason why 
the buildbot fails to create the images for the last weeks.

I'm not yet sure where the real bug is.

Mathias

>>
>> Signed-off-by: Tomasz Maciej Nowak <tomek_n@o2.pl>
>> ---
>>   target/linux/mvebu/image/Makefile          |  1 -
>>   target/linux/mvebu/profiles/000-Default.mk | 18 ------------------
>>   2 files changed, 19 deletions(-)
>>   delete mode 100644 target/linux/mvebu/profiles/000-Default.mk
>>
>> diff --git a/target/linux/mvebu/image/Makefile b/target/linux/mvebu/image/Makefile
>> index be01623e86..22519bd9d0 100644
>> --- a/target/linux/mvebu/image/Makefile
>> +++ b/target/linux/mvebu/image/Makefile
>> @@ -81,7 +81,6 @@ define Build/omnia-medkit-initramfs
>>   endef
>>
>>   define Device/Default
>> -  PROFILES := Default
>>     DEVICE_DTS := $(1)
>>     BOARD_NAME = $$(DEVICE_DTS)
>>     KERNEL_NAME := zImage
>> diff --git a/target/linux/mvebu/profiles/000-Default.mk b/target/linux/mvebu/profiles/000-Default.mk
>> deleted file mode 100644
>> index 8690dd8da5..0000000000
>> --- a/target/linux/mvebu/profiles/000-Default.mk
>> +++ /dev/null
>> @@ -1,18 +0,0 @@
>> -#
>> -# Copyright (C) 2015 OpenWrt.org
>> -#
>> -# This is free software, licensed under the GNU General Public License v2.
>> -# See /LICENSE for more information.
>> -#
>> -
>> -define Profile/Default
>> -       NAME:=Default Profile (all drivers)
>> -       PACKAGES:= kmod-mwlwifi wpad-basic swconfig mkf2fs e2fsprogs \
>> -                  mwlwifi-firmware-88w8864 mwlwifi-firmware-88w8964
>> -endef
>> -
>> -define Profile/Default/Description
>> -       Default package set compatible with most boards.
>> -endef
>> -
>> -$(eval $(call Profile,Default))
>> --
>> 2.20.1
>>
>>
>> _______________________________________________
>> openwrt-devel mailing list
>> openwrt-devel@lists.openwrt.org
>> https://lists.openwrt.org/mailman/listinfo/openwrt-devel
> 
> _______________________________________________
> openwrt-devel mailing list
> openwrt-devel@lists.openwrt.org
> https://lists.openwrt.org/mailman/listinfo/openwrt-devel
>
Rosen Penev Jan. 17, 2019, 8:08 a.m. UTC | #3
On Wed, Jan 16, 2019 at 11:51 PM Mathias Kresin <dev@kresin.me> wrote:
>
> 17/01/2019 05:38, Rosen Penev:
> > On Sun, Jan 13, 2019 at 12:28 PM Tomasz Maciej Nowak <tomek_n@o2.pl> wrote:
> >>
> >> When using Image Builder and building image for Cortex A53 or
> >> A72 subtargets, it'll fail with following message:
> >>
> >> Collected errors:
> >>   * opkg_install_cmd: Cannot install package mwlwifi-firmware-88w8864.
> >>   * opkg_install_cmd: Cannot install package mwlwifi-firmware-88w8964.
> >> make[2]: *** [Makefile:153: package_install] Error 255
> >> make[1]: *** [Makefile:114: _call_image] Error 2
> >>
> >> This is beacuse both packages are available only for Cortex A9 subtarget
> >> and are included in PACKAGES array in default profile. Instead patching
> >> this, let's remove profiles completely, since all necessary packages are
> >> specified in DEVICE_PACKAGES array for each device.
> > NACK. This breaks Turris Omnia compilation. Something about a clearfog
> > bootloader.
>
> Would you please try to add the "PROFILES := Default" again to the
> "define Device/Default" section and check if it fixes your build error?
That fixes it.
>
> On gemini, I noticed that due to the missing PROFILES all images are
> build, regardless of the selected (or currently processed in case of a
> multi profile build).
>
> It causes race conditions on gemini and is most likely the reason why
> the buildbot fails to create the images for the last weeks.
>
> I'm not yet sure where the real bug is.
>
> Mathias
>
> >>
> >> Signed-off-by: Tomasz Maciej Nowak <tomek_n@o2.pl>
> >> ---
> >>   target/linux/mvebu/image/Makefile          |  1 -
> >>   target/linux/mvebu/profiles/000-Default.mk | 18 ------------------
> >>   2 files changed, 19 deletions(-)
> >>   delete mode 100644 target/linux/mvebu/profiles/000-Default.mk
> >>
> >> diff --git a/target/linux/mvebu/image/Makefile b/target/linux/mvebu/image/Makefile
> >> index be01623e86..22519bd9d0 100644
> >> --- a/target/linux/mvebu/image/Makefile
> >> +++ b/target/linux/mvebu/image/Makefile
> >> @@ -81,7 +81,6 @@ define Build/omnia-medkit-initramfs
> >>   endef
> >>
> >>   define Device/Default
> >> -  PROFILES := Default
> >>     DEVICE_DTS := $(1)
> >>     BOARD_NAME = $$(DEVICE_DTS)
> >>     KERNEL_NAME := zImage
> >> diff --git a/target/linux/mvebu/profiles/000-Default.mk b/target/linux/mvebu/profiles/000-Default.mk
> >> deleted file mode 100644
> >> index 8690dd8da5..0000000000
> >> --- a/target/linux/mvebu/profiles/000-Default.mk
> >> +++ /dev/null
> >> @@ -1,18 +0,0 @@
> >> -#
> >> -# Copyright (C) 2015 OpenWrt.org
> >> -#
> >> -# This is free software, licensed under the GNU General Public License v2.
> >> -# See /LICENSE for more information.
> >> -#
> >> -
> >> -define Profile/Default
> >> -       NAME:=Default Profile (all drivers)
> >> -       PACKAGES:= kmod-mwlwifi wpad-basic swconfig mkf2fs e2fsprogs \
> >> -                  mwlwifi-firmware-88w8864 mwlwifi-firmware-88w8964
> >> -endef
> >> -
> >> -define Profile/Default/Description
> >> -       Default package set compatible with most boards.
> >> -endef
> >> -
> >> -$(eval $(call Profile,Default))
> >> --
> >> 2.20.1
> >>
> >>
> >> _______________________________________________
> >> openwrt-devel mailing list
> >> openwrt-devel@lists.openwrt.org
> >> https://lists.openwrt.org/mailman/listinfo/openwrt-devel
> >
> > _______________________________________________
> > openwrt-devel mailing list
> > openwrt-devel@lists.openwrt.org
> > https://lists.openwrt.org/mailman/listinfo/openwrt-devel
> >
>
Tomasz Maciej Nowak Jan. 17, 2019, 1:50 p.m. UTC | #4
W dniu 17.01.2019 o 09:08, Rosen Penev pisze:
> On Wed, Jan 16, 2019 at 11:51 PM Mathias Kresin <dev@kresin.me> wrote:
>>
>> 17/01/2019 05:38, Rosen Penev:
>>> On Sun, Jan 13, 2019 at 12:28 PM Tomasz Maciej Nowak <tomek_n@o2.pl> wrote:
>>>>
>>>> When using Image Builder and building image for Cortex A53 or
>>>> A72 subtargets, it'll fail with following message:
>>>>
>>>> Collected errors:
>>>>   * opkg_install_cmd: Cannot install package mwlwifi-firmware-88w8864.
>>>>   * opkg_install_cmd: Cannot install package mwlwifi-firmware-88w8964.
>>>> make[2]: *** [Makefile:153: package_install] Error 255
>>>> make[1]: *** [Makefile:114: _call_image] Error 2
>>>>
>>>> This is beacuse both packages are available only for Cortex A9 subtarget
>>>> and are included in PACKAGES array in default profile. Instead patching
>>>> this, let's remove profiles completely, since all necessary packages are
>>>> specified in DEVICE_PACKAGES array for each device.
>>> NACK. This breaks Turris Omnia compilation. Something about a clearfog
>>> bootloader.
>>
>> Would you please try to add the "PROFILES := Default" again to the

Thanks for finding the cause. After restoring that, it works as intended. I should have tested building for single device.

>> "define Device/Default" section and check if it fixes your build error?
> That fixes it.

Thank You for reporting and testing.

>>
>> On gemini, I noticed that due to the missing PROFILES all images are
>> build, regardless of the selected (or currently processed in case of a
>> multi profile build).
>>
>> It causes race conditions on gemini and is most likely the reason why
>> the buildbot fails to create the images for the last weeks.
>>
>> I'm not yet sure where the real bug is.
>>
>> Mathias
>>
>>>>
>>>> Signed-off-by: Tomasz Maciej Nowak <tomek_n@o2.pl>
>>>> ---
>>>>   target/linux/mvebu/image/Makefile          |  1 -
>>>>   target/linux/mvebu/profiles/000-Default.mk | 18 ------------------
>>>>   2 files changed, 19 deletions(-)
>>>>   delete mode 100644 target/linux/mvebu/profiles/000-Default.mk
>>>>
>>>> diff --git a/target/linux/mvebu/image/Makefile b/target/linux/mvebu/image/Makefile
>>>> index be01623e86..22519bd9d0 100644
>>>> --- a/target/linux/mvebu/image/Makefile
>>>> +++ b/target/linux/mvebu/image/Makefile
>>>> @@ -81,7 +81,6 @@ define Build/omnia-medkit-initramfs
>>>>   endef
>>>>
>>>>   define Device/Default
>>>> -  PROFILES := Default
>>>>     DEVICE_DTS := $(1)
>>>>     BOARD_NAME = $$(DEVICE_DTS)
>>>>     KERNEL_NAME := zImage
>>>> diff --git a/target/linux/mvebu/profiles/000-Default.mk b/target/linux/mvebu/profiles/000-Default.mk
>>>> deleted file mode 100644
>>>> index 8690dd8da5..0000000000
>>>> --- a/target/linux/mvebu/profiles/000-Default.mk
>>>> +++ /dev/null
>>>> @@ -1,18 +0,0 @@
>>>> -#
>>>> -# Copyright (C) 2015 OpenWrt.org
>>>> -#
>>>> -# This is free software, licensed under the GNU General Public License v2.
>>>> -# See /LICENSE for more information.
>>>> -#
>>>> -
>>>> -define Profile/Default
>>>> -       NAME:=Default Profile (all drivers)
>>>> -       PACKAGES:= kmod-mwlwifi wpad-basic swconfig mkf2fs e2fsprogs \
>>>> -                  mwlwifi-firmware-88w8864 mwlwifi-firmware-88w8964
>>>> -endef
>>>> -
>>>> -define Profile/Default/Description
>>>> -       Default package set compatible with most boards.
>>>> -endef
>>>> -
>>>> -$(eval $(call Profile,Default))
>>>> --
>>>> 2.20.1
>>>>
>>>>
>>>> _______________________________________________
>>>> openwrt-devel mailing list
>>>> openwrt-devel@lists.openwrt.org
>>>> https://lists.openwrt.org/mailman/listinfo/openwrt-devel
>>>
>>> _______________________________________________
>>> openwrt-devel mailing list
>>> openwrt-devel@lists.openwrt.org
>>> https://lists.openwrt.org/mailman/listinfo/openwrt-devel
>>>
>>
diff mbox series

Patch

diff --git a/target/linux/mvebu/image/Makefile b/target/linux/mvebu/image/Makefile
index be01623e86..22519bd9d0 100644
--- a/target/linux/mvebu/image/Makefile
+++ b/target/linux/mvebu/image/Makefile
@@ -81,7 +81,6 @@  define Build/omnia-medkit-initramfs
 endef
 
 define Device/Default
-  PROFILES := Default
   DEVICE_DTS := $(1)
   BOARD_NAME = $$(DEVICE_DTS)
   KERNEL_NAME := zImage
diff --git a/target/linux/mvebu/profiles/000-Default.mk b/target/linux/mvebu/profiles/000-Default.mk
deleted file mode 100644
index 8690dd8da5..0000000000
--- a/target/linux/mvebu/profiles/000-Default.mk
+++ /dev/null
@@ -1,18 +0,0 @@ 
-#
-# Copyright (C) 2015 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Profile/Default
-	NAME:=Default Profile (all drivers)
-	PACKAGES:= kmod-mwlwifi wpad-basic swconfig mkf2fs e2fsprogs \
-		   mwlwifi-firmware-88w8864 mwlwifi-firmware-88w8964
-endef
-
-define Profile/Default/Description
-	Default package set compatible with most boards.
-endef
-
-$(eval $(call Profile,Default))