diff mbox series

[OpenWrt-Devel] kernel: Add AEAD and RNG support to kmod-crypto-user

Message ID 20180922004659.2638-1-rosenp@gmail.com
State Changes Requested
Delegated to: John Crispin
Headers show
Series [OpenWrt-Devel] kernel: Add AEAD and RNG support to kmod-crypto-user | expand

Commit Message

Rosen Penev Sept. 22, 2018, 12:46 a.m. UTC
This breaks compatibility with kernel 3.18, but as that is more or less
abandoned at this point, it should be fine.

Tested on Turris Omnia.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
---
 package/kernel/linux/modules/crypto.mk | 4 ++++
 1 file changed, 4 insertions(+)
diff mbox series

Patch

diff --git a/package/kernel/linux/modules/crypto.mk b/package/kernel/linux/modules/crypto.mk
index 235e6dadac..613059f823 100644
--- a/package/kernel/linux/modules/crypto.mk
+++ b/package/kernel/linux/modules/crypto.mk
@@ -709,11 +709,15 @@  define KernelPackage/crypto-user
   DEPENDS:=+kmod-crypto-hash +kmod-crypto-manager
   KCONFIG:= \
 	CONFIG_CRYPTO_USER_API \
+	CONFIG_CRYPTO_USER_API_AEAD \
 	CONFIG_CRYPTO_USER_API_HASH \
+	CONFIG_CRYPTO_USER_API_RNG \
 	CONFIG_CRYPTO_USER_API_SKCIPHER
   FILES:= \
 	$(LINUX_DIR)/crypto/af_alg.ko \
+	$(LINUX_DIR)/crypto/algif_aead.ko \
 	$(LINUX_DIR)/crypto/algif_hash.ko \
+	$(LINUX_DIR)/crypto/algif_rng.ko \
 	$(LINUX_DIR)/crypto/algif_skcipher.ko
   AUTOLOAD:=$(call AutoLoad,09,af_alg algif_hash algif_skcipher)
   $(call AddDepends/crypto)