diff mbox series

[OpenWrt-Devel] mvebu: fix the cortex-a9 fpu configure

Message ID 20180830023117.5397-1-ayaka@soulik.info
State Rejected
Headers show
Series [OpenWrt-Devel] mvebu: fix the cortex-a9 fpu configure | expand

Commit Message

Randy Li Aug. 30, 2018, 2:31 a.m. UTC
Both Marvell Armada 37x and 38x support NEON and VFPv3,
so we enable the NEON FPU with the SIMD aliases.

Signed-off-by: ayaka <ayaka@soulik.info>
---
 include/target.mk                     | 1 +
 target/linux/mvebu/cortexa9/target.mk | 2 +-
 2 files changed, 2 insertions(+), 1 deletion(-)

Comments

Jonas Gorski Aug. 30, 2018, 6:26 a.m. UTC | #1
On 30 August 2018 at 04:31, ayaka <ayaka@soulik.info> wrote:
> Both Marvell Armada 37x and 38x support NEON and VFPv3,
> so we enable the NEON FPU with the SIMD aliases.

But the Armada XP doesn't, so this would break devices based on it
(like the WRT1900AC v1).


Regards
Jonas

>
> Signed-off-by: ayaka <ayaka@soulik.info>
> ---
>  include/target.mk                     | 1 +
>  target/linux/mvebu/cortexa9/target.mk | 2 +-
>  2 files changed, 2 insertions(+), 1 deletion(-)
>
> diff --git a/include/target.mk b/include/target.mk
> index 53d7436311..330eb175cc 100644
> --- a/include/target.mk
> +++ b/include/target.mk
> @@ -201,6 +201,7 @@ ifeq ($(DUMP),1)
>        CPU_CFLAGS_neon = -mfpu=neon
>        CPU_CFLAGS_vfp = -mfpu=vfp
>        CPU_CFLAGS_vfpv3 = -mfpu=vfpv3-d16
> +      CPU_CFLAGS_simd = -mfpu=neon-vfpv3
>        CPU_CFLAGS_neon-vfpv4 = -mfpu=neon-vfpv4
>      endif
>    endif
> diff --git a/target/linux/mvebu/cortexa9/target.mk b/target/linux/mvebu/cortexa9/target.mk
> index 2a75599bc9..9e6119bf6b 100644
> --- a/target/linux/mvebu/cortexa9/target.mk
> +++ b/target/linux/mvebu/cortexa9/target.mk
> @@ -10,5 +10,5 @@ include $(TOPDIR)/rules.mk
>  ARCH:=arm
>  BOARDNAME:=Marvell Armada 37x/38x/XP
>  CPU_TYPE:=cortex-a9
> -CPU_SUBTYPE:=vfpv3
> +CPU_SUBTYPE:=simd
>  KERNELNAME:=zImage dtbs
> --
> 2.14.4
>
>
> _______________________________________________
> openwrt-devel mailing list
> openwrt-devel@lists.openwrt.org
> https://lists.openwrt.org/mailman/listinfo/openwrt-devel
Randy Li Aug. 30, 2018, 7:29 a.m. UTC | #2
Sent from my iPad

>> On Aug 30, 2018, at 2:26 PM, Jonas Gorski <jonas.gorski@gmail.com> wrote:
>> 
>> On 30 August 2018 at 04:31, ayaka <ayaka@soulik.info> wrote:
>> Both Marvell Armada 37x and 38x support NEON and VFPv3,
>> so we enable the NEON FPU with the SIMD aliases.
> 
> But the Armada XP doesn't, so this would break devices based on it
> (like the WRT1900AC v1).
I was wonder whether Armada XP supports NEON. I am glad to know it doesn't.
Anyway advice on separate the configure for WRT1900AC?
With the help of neon I think we can get a better performance on crypt app
locations such as OpenSSL and OpenVPN. It takes more benefit from the  compatible.
> 
> Regards
> Jonas
> 
>> 
>> Signed-off-by: ayaka <ayaka@soulik.info>
>> ---
>> include/target.mk                     | 1 +
>> target/linux/mvebu/cortexa9/target.mk | 2 +-
>> 2 files changed, 2 insertions(+), 1 deletion(-)
>> 
>> diff --git a/include/target.mk b/include/target.mk
>> index 53d7436311..330eb175cc 100644
>> --- a/include/target.mk
>> +++ b/include/target.mk
>> @@ -201,6 +201,7 @@ ifeq ($(DUMP),1)
>>       CPU_CFLAGS_neon = -mfpu=neon
>>       CPU_CFLAGS_vfp = -mfpu=vfp
>>       CPU_CFLAGS_vfpv3 = -mfpu=vfpv3-d16
>> +      CPU_CFLAGS_simd = -mfpu=neon-vfpv3
>>       CPU_CFLAGS_neon-vfpv4 = -mfpu=neon-vfpv4
>>     endif
>>   endif
>> diff --git a/target/linux/mvebu/cortexa9/target.mk b/target/linux/mvebu/cortexa9/target.mk
>> index 2a75599bc9..9e6119bf6b 100644
>> --- a/target/linux/mvebu/cortexa9/target.mk
>> +++ b/target/linux/mvebu/cortexa9/target.mk
>> @@ -10,5 +10,5 @@ include $(TOPDIR)/rules.mk
>> ARCH:=arm
>> BOARDNAME:=Marvell Armada 37x/38x/XP
>> CPU_TYPE:=cortex-a9
>> -CPU_SUBTYPE:=vfpv3
>> +CPU_SUBTYPE:=simd
>> KERNELNAME:=zImage dtbs
>> --
>> 2.14.4
>> 
>> 
>> _______________________________________________
>> openwrt-devel mailing list
>> openwrt-devel@lists.openwrt.org
>> https://lists.openwrt.org/mailman/listinfo/openwrt-devel
Hauke Mehrtens Aug. 30, 2018, 10:11 a.m. UTC | #3
Hi,

On 08/30/2018 09:29 AM, Ayaka wrote:
> 
> 
> Sent from my iPad
> 
>>> On Aug 30, 2018, at 2:26 PM, Jonas Gorski <jonas.gorski@gmail.com> wrote:
>>>
>>> On 30 August 2018 at 04:31, ayaka <ayaka@soulik.info> wrote:
>>> Both Marvell Armada 37x and 38x support NEON and VFPv3,
>>> so we enable the NEON FPU with the SIMD aliases.
>>
>> But the Armada XP doesn't, so this would break devices based on it
>> (like the WRT1900AC v1).
> I was wonder whether Armada XP supports NEON. I am glad to know it doesn't.
> Anyway advice on separate the configure for WRT1900AC?
> With the help of neon I think we can get a better performance on crypt app
> locations such as OpenSSL and OpenVPN. It takes more benefit from the  compatible.

We can split this into two sub targets, but this needs additional
computation resources for our build bots.
Could you do some benchmarks on the performance differences with and
without this specific compiler optimization and share your results
please. This will allow us to judge if these performance improvements
are worth the extra load on the build bots.

You could try OpenSSL, OpenVPN and so on with the current build and then
with a build which activates ARM NEON and whatever this CPU supports in
addition.

Hauke

>>
>> Regards
>> Jonas
>>
>>>
>>> Signed-off-by: ayaka <ayaka@soulik.info>
>>> ---
>>> include/target.mk                     | 1 +
>>> target/linux/mvebu/cortexa9/target.mk | 2 +-
>>> 2 files changed, 2 insertions(+), 1 deletion(-)
>>>
>>> diff --git a/include/target.mk b/include/target.mk
>>> index 53d7436311..330eb175cc 100644
>>> --- a/include/target.mk
>>> +++ b/include/target.mk
>>> @@ -201,6 +201,7 @@ ifeq ($(DUMP),1)
>>>       CPU_CFLAGS_neon = -mfpu=neon
>>>       CPU_CFLAGS_vfp = -mfpu=vfp
>>>       CPU_CFLAGS_vfpv3 = -mfpu=vfpv3-d16
>>> +      CPU_CFLAGS_simd = -mfpu=neon-vfpv3
>>>       CPU_CFLAGS_neon-vfpv4 = -mfpu=neon-vfpv4
>>>     endif
>>>   endif
>>> diff --git a/target/linux/mvebu/cortexa9/target.mk b/target/linux/mvebu/cortexa9/target.mk
>>> index 2a75599bc9..9e6119bf6b 100644
>>> --- a/target/linux/mvebu/cortexa9/target.mk
>>> +++ b/target/linux/mvebu/cortexa9/target.mk
>>> @@ -10,5 +10,5 @@ include $(TOPDIR)/rules.mk
>>> ARCH:=arm
>>> BOARDNAME:=Marvell Armada 37x/38x/XP
>>> CPU_TYPE:=cortex-a9
>>> -CPU_SUBTYPE:=vfpv3
>>> +CPU_SUBTYPE:=simd
>>> KERNELNAME:=zImage dtbs
>>> --
>>> 2.14.4
>>>
>>>
>>> _______________________________________________
>>> openwrt-devel mailing list
>>> openwrt-devel@lists.openwrt.org
>>> https://lists.openwrt.org/mailman/listinfo/openwrt-devel
> 
> 
> _______________________________________________
> openwrt-devel mailing list
> openwrt-devel@lists.openwrt.org
> https://lists.openwrt.org/mailman/listinfo/openwrt-devel
>
Randy Li Aug. 31, 2018, 3:45 a.m. UTC | #4
Sent from my iPad

> On Aug 30, 2018, at 6:11 PM, Hauke Mehrtens <hauke@hauke-m.de> wrote:
> 
> Hi,
> 
>> On 08/30/2018 09:29 AM, Ayaka wrote:
>> 
>> 
>> Sent from my iPad
>> 
>>>> On Aug 30, 2018, at 2:26 PM, Jonas Gorski <jonas.gorski@gmail.com> wrote:
>>>> 
>>>> On 30 August 2018 at 04:31, ayaka <ayaka@soulik.info> wrote:
>>>> Both Marvell Armada 37x and 38x support NEON and VFPv3,
>>>> so we enable the NEON FPU with the SIMD aliases.
>>> 
>>> But the Armada XP doesn't, so this would break devices based on it
>>> (like the WRT1900AC v1).
>> I was wonder whether Armada XP supports NEON. I am glad to know it doesn't.
>> Anyway advice on separate the configure for WRT1900AC?
>> With the help of neon I think we can get a better performance on crypt app
>> locations such as OpenSSL and OpenVPN. It takes more benefit from the  compatible.
> 
> We can split this into two sub targets, but this needs additional
> computation resources for our build bots.
Maybe there would be three sub targets
I found ARMADA 370 only supports vfp-d16, but ARMADA 375 supports neon, I am not sure about VPS part. And the ARMADA 38x supports both neon and vfpv3 which we can use simd aliases simply.
The commit in the below links is not correct.
https://github.com/lede-project/source/pull/1211#issuecomment-319286867
> Could you do some benchmarks on the performance differences with and
> without this specific compiler optimization and share your results
> please. This will allow us to judge if these performance improvements
> are worth the extra load on the build bots.
> 
But I think you can still use the performance benchmark in the above links as an evidence.
I will try to write a simple make rules in the weekend.
> You could try OpenSSL, OpenVPN and so on with the current build and then
> with a build which activates ARM NEON and whatever this CPU supports in
> addition.
> 
> Hauke
> 
>>> 
>>> Regards
>>> Jonas
>>> 
>>>> 
>>>> Signed-off-by: ayaka <ayaka@soulik.info>
>>>> ---
>>>> include/target.mk                     | 1 +
>>>> target/linux/mvebu/cortexa9/target.mk | 2 +-
>>>> 2 files changed, 2 insertions(+), 1 deletion(-)
>>>> 
>>>> diff --git a/include/target.mk b/include/target.mk
>>>> index 53d7436311..330eb175cc 100644
>>>> --- a/include/target.mk
>>>> +++ b/include/target.mk
>>>> @@ -201,6 +201,7 @@ ifeq ($(DUMP),1)
>>>>      CPU_CFLAGS_neon = -mfpu=neon
>>>>      CPU_CFLAGS_vfp = -mfpu=vfp
>>>>      CPU_CFLAGS_vfpv3 = -mfpu=vfpv3-d16
>>>> +      CPU_CFLAGS_simd = -mfpu=neon-vfpv3
>>>>      CPU_CFLAGS_neon-vfpv4 = -mfpu=neon-vfpv4
>>>>    endif
>>>>  endif
>>>> diff --git a/target/linux/mvebu/cortexa9/target.mk b/target/linux/mvebu/cortexa9/target.mk
>>>> index 2a75599bc9..9e6119bf6b 100644
>>>> --- a/target/linux/mvebu/cortexa9/target.mk
>>>> +++ b/target/linux/mvebu/cortexa9/target.mk
>>>> @@ -10,5 +10,5 @@ include $(TOPDIR)/rules.mk
>>>> ARCH:=arm
>>>> BOARDNAME:=Marvell Armada 37x/38x/XP
>>>> CPU_TYPE:=cortex-a9
>>>> -CPU_SUBTYPE:=vfpv3
>>>> +CPU_SUBTYPE:=simd
>>>> KERNELNAME:=zImage dtbs
>>>> --
>>>> 2.14.4
>>>> 
>>>> 
>>>> _______________________________________________
>>>> openwrt-devel mailing list
>>>> openwrt-devel@lists.openwrt.org
>>>> https://lists.openwrt.org/mailman/listinfo/openwrt-devel
>> 
>> 
>> _______________________________________________
>> openwrt-devel mailing list
>> openwrt-devel@lists.openwrt.org
>> https://lists.openwrt.org/mailman/listinfo/openwrt-devel
>>
<html><head><meta http-equiv="content-type" content="text/html; charset=utf-8"></head><body dir="auto"><div><br><br>Sent from my iPad</div><div><br>On Aug 30, 2018, at 6:11 PM, Hauke Mehrtens &lt;<a href="mailto:hauke@hauke-m.de">hauke@hauke-m.de</a>&gt; wrote:<br><br></div><blockquote type="cite"><div><span>Hi,</span><br><span></span><br><span>On 08/30/2018 09:29 AM, Ayaka wrote:</span><br><blockquote type="cite"><span></span><br></blockquote><blockquote type="cite"><span></span><br></blockquote><blockquote type="cite"><span>Sent from my iPad</span><br></blockquote><blockquote type="cite"><span></span><br></blockquote><blockquote type="cite"><blockquote type="cite"><blockquote type="cite"><span>On Aug 30, 2018, at 2:26 PM, Jonas Gorski &lt;<a href="mailto:jonas.gorski@gmail.com">jonas.gorski@gmail.com</a>&gt; wrote:</span><br></blockquote></blockquote></blockquote><blockquote type="cite"><blockquote type="cite"><blockquote type="cite"><span></span><br></blockquote></blockquote></blockquote><blockquote type="cite"><blockquote type="cite"><blockquote type="cite"><span>On 30 August 2018 at 04:31, ayaka &lt;<a href="mailto:ayaka@soulik.info">ayaka@soulik.info</a>&gt; wrote:</span><br></blockquote></blockquote></blockquote><blockquote type="cite"><blockquote type="cite"><blockquote type="cite"><span>Both Marvell Armada 37x and 38x support NEON and VFPv3,</span><br></blockquote></blockquote></blockquote><blockquote type="cite"><blockquote type="cite"><blockquote type="cite"><span>so we enable the NEON FPU with the SIMD aliases.</span><br></blockquote></blockquote></blockquote><blockquote type="cite"><blockquote type="cite"><span></span><br></blockquote></blockquote><blockquote type="cite"><blockquote type="cite"><span>But the Armada XP doesn't, so this would break devices based on it</span><br></blockquote></blockquote><blockquote type="cite"><blockquote type="cite"><span>(like the WRT1900AC v1).</span><br></blockquote></blockquote><blockquote type="cite"><span>I was wonder whether Armada XP supports NEON. I am glad to know it doesn't.</span><br></blockquote><blockquote type="cite"><span>Anyway advice on separate the configure for WRT1900AC?</span><br></blockquote><blockquote type="cite"><span>With the help of neon I think we can get a better performance on crypt app</span><br></blockquote><blockquote type="cite"><span>locations such as OpenSSL and OpenVPN. It takes more benefit from the &nbsp;compatible.</span><br></blockquote><span></span><br><span>We can split this into two sub targets, but this needs additional</span><br><span>computation resources for our build bots.</span><br></div></blockquote>Maybe there would be three sub targets<div>I found ARMADA 370 only supports vfp-d16, but ARMADA 375 supports neon, I am not sure about VPS part. And the ARMADA 38x supports both neon and vfpv3 which we can use simd aliases simply.</div><div>The commit in the below links is not correct.</div><div><a href="https://github.com/lede-project/source/pull/1211#issuecomment-319286867">https://github.com/lede-project/source/pull/1211#issuecomment-319286867</a><br><blockquote type="cite"><div><span>Could you do some benchmarks on the performance differences with and</span><br><span>without this specific compiler optimization and share your results</span><br><span>please. This will allow us to judge if these performance improvements</span><br><span>are worth the extra load on the build bots.</span><br><span></span><br></div></blockquote>But I think you can still use the performance benchmark in the above links as an evidence.</div><div>I will try to write a simple make rules in the weekend.<br><blockquote type="cite"><div><span>You could try OpenSSL, OpenVPN and so on with the current build and then</span><br><span>with a build which activates ARM NEON and whatever this CPU supports in</span><br><span>addition.</span><br><span></span><br><span>Hauke</span><br><span></span><br><blockquote type="cite"><blockquote type="cite"><span></span><br></blockquote></blockquote><blockquote type="cite"><blockquote type="cite"><span>Regards</span><br></blockquote></blockquote><blockquote type="cite"><blockquote type="cite"><span>Jonas</span><br></blockquote></blockquote><blockquote type="cite"><blockquote type="cite"><span></span><br></blockquote></blockquote><blockquote type="cite"><blockquote type="cite"><blockquote type="cite"><span></span><br></blockquote></blockquote></blockquote><blockquote type="cite"><blockquote type="cite"><blockquote type="cite"><span>Signed-off-by: ayaka &lt;<a href="mailto:ayaka@soulik.info">ayaka@soulik.info</a>&gt;</span><br></blockquote></blockquote></blockquote><blockquote type="cite"><blockquote type="cite"><blockquote type="cite"><span>---</span><br></blockquote></blockquote></blockquote><blockquote type="cite"><blockquote type="cite"><blockquote type="cite"><span>include/target.mk &nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;| 1 +</span><br></blockquote></blockquote></blockquote><blockquote type="cite"><blockquote type="cite"><blockquote type="cite"><span>target/linux/mvebu/cortexa9/target.mk | 2 +-</span><br></blockquote></blockquote></blockquote><blockquote type="cite"><blockquote type="cite"><blockquote type="cite"><span>2 files changed, 2 insertions(+), 1 deletion(-)</span><br></blockquote></blockquote></blockquote><blockquote type="cite"><blockquote type="cite"><blockquote type="cite"><span></span><br></blockquote></blockquote></blockquote><blockquote type="cite"><blockquote type="cite"><blockquote type="cite"><span>diff --git a/include/target.mk b/include/target.mk</span><br></blockquote></blockquote></blockquote><blockquote type="cite"><blockquote type="cite"><blockquote type="cite"><span>index 53d7436311..330eb175cc 100644</span><br></blockquote></blockquote></blockquote><blockquote type="cite"><blockquote type="cite"><blockquote type="cite"><span>--- a/include/target.mk</span><br></blockquote></blockquote></blockquote><blockquote type="cite"><blockquote type="cite"><blockquote type="cite"><span>+++ b/include/target.mk</span><br></blockquote></blockquote></blockquote><blockquote type="cite"><blockquote type="cite"><blockquote type="cite"><span>@@ -201,6 +201,7 @@ ifeq ($(DUMP),1)</span><br></blockquote></blockquote></blockquote><blockquote type="cite"><blockquote type="cite"><blockquote type="cite"><span> &nbsp;&nbsp;&nbsp;&nbsp;&nbsp;CPU_CFLAGS_neon = -mfpu=neon</span><br></blockquote></blockquote></blockquote><blockquote type="cite"><blockquote type="cite"><blockquote type="cite"><span> &nbsp;&nbsp;&nbsp;&nbsp;&nbsp;CPU_CFLAGS_vfp = -mfpu=vfp</span><br></blockquote></blockquote></blockquote><blockquote type="cite"><blockquote type="cite"><blockquote type="cite"><span> &nbsp;&nbsp;&nbsp;&nbsp;&nbsp;CPU_CFLAGS_vfpv3 = -mfpu=vfpv3-d16</span><br></blockquote></blockquote></blockquote><blockquote type="cite"><blockquote type="cite"><blockquote type="cite"><span>+ &nbsp;&nbsp;&nbsp;&nbsp;&nbsp;CPU_CFLAGS_simd = -mfpu=neon-vfpv3</span><br></blockquote></blockquote></blockquote><blockquote type="cite"><blockquote type="cite"><blockquote type="cite"><span> &nbsp;&nbsp;&nbsp;&nbsp;&nbsp;CPU_CFLAGS_neon-vfpv4 = -mfpu=neon-vfpv4</span><br></blockquote></blockquote></blockquote><blockquote type="cite"><blockquote type="cite"><blockquote type="cite"><span> &nbsp;&nbsp;&nbsp;endif</span><br></blockquote></blockquote></blockquote><blockquote type="cite"><blockquote type="cite"><blockquote type="cite"><span> &nbsp;endif</span><br></blockquote></blockquote></blockquote><blockquote type="cite"><blockquote type="cite"><blockquote type="cite"><span>diff --git a/target/linux/mvebu/cortexa9/target.mk b/target/linux/mvebu/cortexa9/target.mk</span><br></blockquote></blockquote></blockquote><blockquote type="cite"><blockquote type="cite"><blockquote type="cite"><span>index 2a75599bc9..9e6119bf6b 100644</span><br></blockquote></blockquote></blockquote><blockquote type="cite"><blockquote type="cite"><blockquote type="cite"><span>--- a/target/linux/mvebu/cortexa9/target.mk</span><br></blockquote></blockquote></blockquote><blockquote type="cite"><blockquote type="cite"><blockquote type="cite"><span>+++ b/target/linux/mvebu/cortexa9/target.mk</span><br></blockquote></blockquote></blockquote><blockquote type="cite"><blockquote type="cite"><blockquote type="cite"><span>@@ -10,5 +10,5 @@ include $(TOPDIR)/rules.mk</span><br></blockquote></blockquote></blockquote><blockquote type="cite"><blockquote type="cite"><blockquote type="cite"><span>ARCH:=arm</span><br></blockquote></blockquote></blockquote><blockquote type="cite"><blockquote type="cite"><blockquote type="cite"><span>BOARDNAME:=Marvell Armada 37x/38x/XP</span><br></blockquote></blockquote></blockquote><blockquote type="cite"><blockquote type="cite"><blockquote type="cite"><span>CPU_TYPE:=cortex-a9</span><br></blockquote></blockquote></blockquote><blockquote type="cite"><blockquote type="cite"><blockquote type="cite"><span>-CPU_SUBTYPE:=vfpv3</span><br></blockquote></blockquote></blockquote><blockquote type="cite"><blockquote type="cite"><blockquote type="cite"><span>+CPU_SUBTYPE:=simd</span><br></blockquote></blockquote></blockquote><blockquote type="cite"><blockquote type="cite"><blockquote type="cite"><span>KERNELNAME:=zImage dtbs</span><br></blockquote></blockquote></blockquote><blockquote type="cite"><blockquote type="cite"><blockquote type="cite"><span>--</span><br></blockquote></blockquote></blockquote><blockquote type="cite"><blockquote type="cite"><blockquote type="cite"><span>2.14.4</span><br></blockquote></blockquote></blockquote><blockquote type="cite"><blockquote type="cite"><blockquote type="cite"><span></span><br></blockquote></blockquote></blockquote><blockquote type="cite"><blockquote type="cite"><blockquote type="cite"><span></span><br></blockquote></blockquote></blockquote><blockquote type="cite"><blockquote type="cite"><blockquote type="cite"><span>_______________________________________________</span><br></blockquote></blockquote></blockquote><blockquote type="cite"><blockquote type="cite"><blockquote type="cite"><span>openwrt-devel mailing list</span><br></blockquote></blockquote></blockquote><blockquote type="cite"><blockquote type="cite"><blockquote type="cite"><span><a href="mailto:openwrt-devel@lists.openwrt.org">openwrt-devel@lists.openwrt.org</a></span><br></blockquote></blockquote></blockquote><blockquote type="cite"><blockquote type="cite"><blockquote type="cite"><span><a href="https://lists.openwrt.org/mailman/listinfo/openwrt-devel">https://lists.openwrt.org/mailman/listinfo/openwrt-devel</a></span><br></blockquote></blockquote></blockquote><blockquote type="cite"><span></span><br></blockquote><blockquote type="cite"><span></span><br></blockquote><blockquote type="cite"><span>_______________________________________________</span><br></blockquote><blockquote type="cite"><span>openwrt-devel mailing list</span><br></blockquote><blockquote type="cite"><span><a href="mailto:openwrt-devel@lists.openwrt.org">openwrt-devel@lists.openwrt.org</a></span><br></blockquote><blockquote type="cite"><span><a href="https://lists.openwrt.org/mailman/listinfo/openwrt-devel">https://lists.openwrt.org/mailman/listinfo/openwrt-devel</a></span><br></blockquote><blockquote type="cite"><span></span><br></blockquote></div></blockquote></div></body></html>
diff mbox series

Patch

diff --git a/include/target.mk b/include/target.mk
index 53d7436311..330eb175cc 100644
--- a/include/target.mk
+++ b/include/target.mk
@@ -201,6 +201,7 @@  ifeq ($(DUMP),1)
       CPU_CFLAGS_neon = -mfpu=neon
       CPU_CFLAGS_vfp = -mfpu=vfp
       CPU_CFLAGS_vfpv3 = -mfpu=vfpv3-d16
+      CPU_CFLAGS_simd = -mfpu=neon-vfpv3
       CPU_CFLAGS_neon-vfpv4 = -mfpu=neon-vfpv4
     endif
   endif
diff --git a/target/linux/mvebu/cortexa9/target.mk b/target/linux/mvebu/cortexa9/target.mk
index 2a75599bc9..9e6119bf6b 100644
--- a/target/linux/mvebu/cortexa9/target.mk
+++ b/target/linux/mvebu/cortexa9/target.mk
@@ -10,5 +10,5 @@  include $(TOPDIR)/rules.mk
 ARCH:=arm
 BOARDNAME:=Marvell Armada 37x/38x/XP
 CPU_TYPE:=cortex-a9
-CPU_SUBTYPE:=vfpv3
+CPU_SUBTYPE:=simd
 KERNELNAME:=zImage dtbs