diff mbox series

[OpenWrt-Devel] ath79: fix SUPPORTED_DEVICES for TL-MR3020

Message ID 20180818120159.27671-1-mail@david-bauer.net
State Accepted
Delegated to: Mathias Kresin
Headers show
Series [OpenWrt-Devel] ath79: fix SUPPORTED_DEVICES for TL-MR3020 | expand

Commit Message

David Bauer Aug. 18, 2018, 12:01 p.m. UTC
Sysupgrading to ath79 from ar71xx currently fails because of mismatching
supported_devices. ar71xx is expecting "tl-mr3020" which is missing in
the ath79 image. Upgrading from ath79 is unaffected, as the image
contains the old string for ar71xx and the new one coming from the
device-tree.

Signed-off-by: David Bauer <mail@david-bauer.net>
---
 target/linux/ath79/image/tiny-tp-link.mk | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Karl Palsson Aug. 18, 2018, 10:13 p.m. UTC | #1
David Bauer <mail@david-bauer.net> wrote:
> Sysupgrading to ath79 from ar71xx currently fails because of
> mismatching supported_devices. ar71xx is expecting "tl-mr3020"
> which is missing in the ath79 image. Upgrading from ath79 is
> unaffected, as the image contains the old string for ar71xx and
> the new one coming from the device-tree.

These were removed as "it was intended to be required to force
when switching "architectures"" I disagreed then, but it got
railed through, so it's good to see I'm not the only one who
thought you should be able to upgrade from ar71xx to ath79 on the
same hardware....

See also https://github.com/openwrt/openwrt/pull/1222

Cheers,
Karl P

> 
> Signed-off-by: David Bauer <mail@david-bauer.net>
> ---
>  target/linux/ath79/image/tiny-tp-link.mk | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
> 
> diff --git a/target/linux/ath79/image/tiny-tp-link.mk
> b/target/linux/ath79/image/tiny-tp-link.mk index
> 6ccc9d7dba..dadcd24b42 100644
> --- a/target/linux/ath79/image/tiny-tp-link.mk
> +++ b/target/linux/ath79/image/tiny-tp-link.mk
> @@ -17,7 +17,7 @@ define Device/tplink_tl-mr3020-v1
>    DEVICE_TITLE := TP-LINK TL-MR3020 v1
>    DEVICE_PACKAGES := kmod-usb-core kmod-usb-chipidea2 kmod-usb-ledtrig-usbport
>    TPLINK_HWID := 0x30200001
> -  SUPPORTED_DEVICES += tl-mr3020-v1
> +  SUPPORTED_DEVICES += tl-mr3020
>  endef
>  TARGET_DEVICES += tplink_tl-mr3020-v1
>  
> -- 
> 2.18.0
> 
> 
> _______________________________________________
> openwrt-devel mailing list
> openwrt-devel@lists.openwrt.org
> https://lists.openwrt.org/mailman/listinfo/openwrt-devel
David Bauer Aug. 18, 2018, 10:38 p.m. UTC | #2
On 8/19/18 12:13 AM, Karl Palsson wrote:
> These were removed as "it was intended to be required to force
> when switching "architectures"" I disagreed then, but it got
> railed through, so it's good to see I'm not the only one who
> thought you should be able to upgrade from ar71xx to ath79 on the
> same hardware....> See also https://github.com/openwrt/openwrt/pull/1222

I understand the point of signaling people that things are most like
going to break with the target-switch. I was expecting the compatible
string to be there exactly for this reason as the compatible string for
ath79 is automatically added from the device-tree.

I'm not sure which approach is "better". On one hand, this makes
upgrading via LuCI (with settings not preserved) not possible. I would
expect people to read release nodes and follow the path accordingly, on
the other hand you could argue one who is reading release notes is also
capable of upgrading via CLI/SSH.

Middle ground would be (in my opinion) to allow forced sysupgrade via
LuCI, but I'm not sure how much effort this would be.

Best wishes
David
Rosen Penev Aug. 19, 2018, 1:45 a.m. UTC | #3
On Sat, Aug 18, 2018 at 5:04 AM David Bauer <mail@david-bauer.net> wrote:
>
> Sysupgrading to ath79 from ar71xx currently fails because of mismatching
> supported_devices. ar71xx is expecting "tl-mr3020" which is missing in
> the ath79 image. Upgrading from ath79 is unaffected, as the image
> contains the old string for ar71xx and the new one coming from the
> device-tree.
NAK from me.
>
> Signed-off-by: David Bauer <mail@david-bauer.net>
> ---
>  target/linux/ath79/image/tiny-tp-link.mk | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/target/linux/ath79/image/tiny-tp-link.mk b/target/linux/ath79/image/tiny-tp-link.mk
> index 6ccc9d7dba..dadcd24b42 100644
> --- a/target/linux/ath79/image/tiny-tp-link.mk
> +++ b/target/linux/ath79/image/tiny-tp-link.mk
> @@ -17,7 +17,7 @@ define Device/tplink_tl-mr3020-v1
>    DEVICE_TITLE := TP-LINK TL-MR3020 v1
>    DEVICE_PACKAGES := kmod-usb-core kmod-usb-chipidea2 kmod-usb-ledtrig-usbport
>    TPLINK_HWID := 0x30200001
> -  SUPPORTED_DEVICES += tl-mr3020-v1
> +  SUPPORTED_DEVICES += tl-mr3020
>  endef
>  TARGET_DEVICES += tplink_tl-mr3020-v1
>
> --
> 2.18.0
>
>
> _______________________________________________
> openwrt-devel mailing list
> openwrt-devel@lists.openwrt.org
> https://lists.openwrt.org/mailman/listinfo/openwrt-devel
Mathias Kresin Aug. 19, 2018, 9:22 a.m. UTC | #4
18.08.2018 14:01, David Bauer:
> Sysupgrading to ath79 from ar71xx currently fails because of mismatching
> supported_devices. ar71xx is expecting "tl-mr3020" which is missing in
> the ath79 image. Upgrading from ath79 is unaffected, as the image
> contains the old string for ar71xx and the new one coming from the
> device-tree.
> 
> Signed-off-by: David Bauer <mail@david-bauer.net>
> ---
>   target/linux/ath79/image/tiny-tp-link.mk | 2 +-
>   1 file changed, 1 insertion(+), 1 deletion(-)
> 
> diff --git a/target/linux/ath79/image/tiny-tp-link.mk b/target/linux/ath79/image/tiny-tp-link.mk
> index 6ccc9d7dba..dadcd24b42 100644
> --- a/target/linux/ath79/image/tiny-tp-link.mk
> +++ b/target/linux/ath79/image/tiny-tp-link.mk
> @@ -17,7 +17,7 @@ define Device/tplink_tl-mr3020-v1
>     DEVICE_TITLE := TP-LINK TL-MR3020 v1
>     DEVICE_PACKAGES := kmod-usb-core kmod-usb-chipidea2 kmod-usb-ledtrig-usbport
>     TPLINK_HWID := 0x30200001
> -  SUPPORTED_DEVICES += tl-mr3020-v1
> +  SUPPORTED_DEVICES += tl-mr3020
>   endef
>   TARGET_DEVICES += tplink_tl-mr3020-v1

I was the opinion it's the ar71xx boardname and it's added to allow an 
update from the ar71xx image. But lets do the obvious and ask the
author.

Dmitry, was the SUPPORTED_DEVICES added to allow an update from the 
ar71xx image?

Mathias
Karl Palsson Aug. 19, 2018, 11:17 a.m. UTC | #5
Rosen Penev <rosenp@gmail.com> wrote:
> On Sat, Aug 18, 2018 at 5:04 AM David Bauer
> <mail@david-bauer.net> wrote:
> >
> > Sysupgrading to ath79 from ar71xx currently fails because of mismatching
> > supported_devices. ar71xx is expecting "tl-mr3020" which is missing in
> > the ath79 image. Upgrading from ath79 is unaffected, as the image
> > contains the old string for ar71xx and the new one coming from the
> > device-tree.
> NAK from me.

No explanation?  Just NAK? That's helpful.

Sincerely,
Karl P
Dmitry Tunin Aug. 19, 2018, 11:29 a.m. UTC | #6
вс, 19 авг. 2018 г. в 12:28, Mathias Kresin <dev@kresin.me>:
>
> 18.08.2018 14:01, David Bauer:
> > Sysupgrading to ath79 from ar71xx currently fails because of mismatching
> > supported_devices. ar71xx is expecting "tl-mr3020" which is missing in
> > the ath79 image. Upgrading from ath79 is unaffected, as the image
> > contains the old string for ar71xx and the new one coming from the
> > device-tree.
> >
> > Signed-off-by: David Bauer <mail@david-bauer.net>
> > ---
> >   target/linux/ath79/image/tiny-tp-link.mk | 2 +-
> >   1 file changed, 1 insertion(+), 1 deletion(-)
> >
> > diff --git a/target/linux/ath79/image/tiny-tp-link.mk b/target/linux/ath79/image/tiny-tp-link.mk
> > index 6ccc9d7dba..dadcd24b42 100644
> > --- a/target/linux/ath79/image/tiny-tp-link.mk
> > +++ b/target/linux/ath79/image/tiny-tp-link.mk
> > @@ -17,7 +17,7 @@ define Device/tplink_tl-mr3020-v1
> >     DEVICE_TITLE := TP-LINK TL-MR3020 v1
> >     DEVICE_PACKAGES := kmod-usb-core kmod-usb-chipidea2 kmod-usb-ledtrig-usbport
> >     TPLINK_HWID := 0x30200001
> > -  SUPPORTED_DEVICES += tl-mr3020-v1
> > +  SUPPORTED_DEVICES += tl-mr3020
> >   endef
> >   TARGET_DEVICES += tplink_tl-mr3020-v1
>
> I was the opinion it's the ar71xx boardname and it's added to allow an
> update from the ar71xx image. But lets do the obvious and ask the
> author.
>
> Dmitry, was the SUPPORTED_DEVICES added to allow an update from the
> ar71xx image?
>
> Mathias

Exactly. The idea was to allow updates. We are moving to ath79 and I
don't think that this is nice to create problems in upgrade for users.
When we are ready to release with ath79 images, we'll need to add the
supported devices back.

Now only those who can build images themselves are using, si I see no
reason why don't we leave the easy upgrade path.
Dmitry Tunin Aug. 19, 2018, 11:33 a.m. UTC | #7
вс, 19 авг. 2018 г. в 14:29, Dmitry Tunin <hanipouspilot@gmail.com>:
>
> вс, 19 авг. 2018 г. в 12:28, Mathias Kresin <dev@kresin.me>:
> >
> > 18.08.2018 14:01, David Bauer:
> > > Sysupgrading to ath79 from ar71xx currently fails because of mismatching
> > > supported_devices. ar71xx is expecting "tl-mr3020" which is missing in
> > > the ath79 image. Upgrading from ath79 is unaffected, as the image
> > > contains the old string for ar71xx and the new one coming from the
> > > device-tree.
> > >
> > > Signed-off-by: David Bauer <mail@david-bauer.net>
> > > ---
> > >   target/linux/ath79/image/tiny-tp-link.mk | 2 +-
> > >   1 file changed, 1 insertion(+), 1 deletion(-)
> > >
> > > diff --git a/target/linux/ath79/image/tiny-tp-link.mk b/target/linux/ath79/image/tiny-tp-link.mk
> > > index 6ccc9d7dba..dadcd24b42 100644
> > > --- a/target/linux/ath79/image/tiny-tp-link.mk
> > > +++ b/target/linux/ath79/image/tiny-tp-link.mk
> > > @@ -17,7 +17,7 @@ define Device/tplink_tl-mr3020-v1
> > >     DEVICE_TITLE := TP-LINK TL-MR3020 v1
> > >     DEVICE_PACKAGES := kmod-usb-core kmod-usb-chipidea2 kmod-usb-ledtrig-usbport
> > >     TPLINK_HWID := 0x30200001
> > > -  SUPPORTED_DEVICES += tl-mr3020-v1
> > > +  SUPPORTED_DEVICES += tl-mr3020
> > >   endef
> > >   TARGET_DEVICES += tplink_tl-mr3020-v1
> >
> > I was the opinion it's the ar71xx boardname and it's added to allow an
> > update from the ar71xx image. But lets do the obvious and ask the
> > author.
> >
> > Dmitry, was the SUPPORTED_DEVICES added to allow an update from the
> > ar71xx image?
> >
> > Mathias
>
> Exactly. The idea was to allow updates. We are moving to ath79 and I
> don't think that this is nice to create problems in upgrade for users.
> When we are ready to release with ath79 images, we'll need to add the
> supported devices back.
>
> Now only those who can build images themselves are using, si I see no
> reason why don't we leave the easy upgrade path.

But I was no the author of MR3020, I added MR3040.
Chuanhong Guo Aug. 19, 2018, 12:52 p.m. UTC | #8
I've just noticed that Image metadata isn't required on ar71xx so at
least fot TP-LINK devices ar71xx accept factory firmware.

Dmitry Tunin <hanipouspilot@gmail.com> 于2018年8月19日周日 下午7:34写道:
>
> вс, 19 авг. 2018 г. в 14:29, Dmitry Tunin <hanipouspilot@gmail.com>:
> >
> > вс, 19 авг. 2018 г. в 12:28, Mathias Kresin <dev@kresin.me>:
> > >
> > > 18.08.2018 14:01, David Bauer:
> > > > Sysupgrading to ath79 from ar71xx currently fails because of mismatching
> > > > supported_devices. ar71xx is expecting "tl-mr3020" which is missing in
> > > > the ath79 image. Upgrading from ath79 is unaffected, as the image
> > > > contains the old string for ar71xx and the new one coming from the
> > > > device-tree.
> > > >
> > > > Signed-off-by: David Bauer <mail@david-bauer.net>
> > > > ---
> > > >   target/linux/ath79/image/tiny-tp-link.mk | 2 +-
> > > >   1 file changed, 1 insertion(+), 1 deletion(-)
> > > >
> > > > diff --git a/target/linux/ath79/image/tiny-tp-link.mk b/target/linux/ath79/image/tiny-tp-link.mk
> > > > index 6ccc9d7dba..dadcd24b42 100644
> > > > --- a/target/linux/ath79/image/tiny-tp-link.mk
> > > > +++ b/target/linux/ath79/image/tiny-tp-link.mk
> > > > @@ -17,7 +17,7 @@ define Device/tplink_tl-mr3020-v1
> > > >     DEVICE_TITLE := TP-LINK TL-MR3020 v1
> > > >     DEVICE_PACKAGES := kmod-usb-core kmod-usb-chipidea2 kmod-usb-ledtrig-usbport
> > > >     TPLINK_HWID := 0x30200001
> > > > -  SUPPORTED_DEVICES += tl-mr3020-v1
> > > > +  SUPPORTED_DEVICES += tl-mr3020
> > > >   endef
> > > >   TARGET_DEVICES += tplink_tl-mr3020-v1
> > >
> > > I was the opinion it's the ar71xx boardname and it's added to allow an
> > > update from the ar71xx image. But lets do the obvious and ask the
> > > author.
> > >
> > > Dmitry, was the SUPPORTED_DEVICES added to allow an update from the
> > > ar71xx image?
> > >
> > > Mathias
> >
> > Exactly. The idea was to allow updates. We are moving to ath79 and I
> > don't think that this is nice to create problems in upgrade for users.
> > When we are ready to release with ath79 images, we'll need to add the
> > supported devices back.
> >
> > Now only those who can build images themselves are using, si I see no
> > reason why don't we leave the easy upgrade path.
>
> But I was no the author of MR3020, I added MR3040.
>
> _______________________________________________
> openwrt-devel mailing list
> openwrt-devel@lists.openwrt.org
> https://lists.openwrt.org/mailman/listinfo/openwrt-devel
Mathias Kresin Aug. 19, 2018, 1:54 p.m. UTC | #9
2018-08-19 14:52 GMT+02:00 Chuanhong Guo <gch981213@gmail.com>:
> I've just noticed that Image metadata isn't required on ar71xx so at
> least fot TP-LINK devices ar71xx accept factory firmware.

Yes it isn't required (enforced) for ar71xx. But if present, the
metadata is validated. And all ath9 images should have image metadata.

Mathias
diff mbox series

Patch

diff --git a/target/linux/ath79/image/tiny-tp-link.mk b/target/linux/ath79/image/tiny-tp-link.mk
index 6ccc9d7dba..dadcd24b42 100644
--- a/target/linux/ath79/image/tiny-tp-link.mk
+++ b/target/linux/ath79/image/tiny-tp-link.mk
@@ -17,7 +17,7 @@  define Device/tplink_tl-mr3020-v1
   DEVICE_TITLE := TP-LINK TL-MR3020 v1
   DEVICE_PACKAGES := kmod-usb-core kmod-usb-chipidea2 kmod-usb-ledtrig-usbport
   TPLINK_HWID := 0x30200001
-  SUPPORTED_DEVICES += tl-mr3020-v1
+  SUPPORTED_DEVICES += tl-mr3020
 endef
 TARGET_DEVICES += tplink_tl-mr3020-v1