diff mbox series

[OpenWrt-Devel] brcm2708: cosmetic changes

Message ID 20180624200145.11094-1-christo.nedev@gmail.com
State Changes Requested
Delegated to: John Crispin
Headers show
Series [OpenWrt-Devel] brcm2708: cosmetic changes | expand

Commit Message

Christo Nedev June 24, 2018, 8:01 p.m. UTC
bcm2709: rename kernel.img to image7.img
  kernel8.img boot in 64 bit mode
  kernel8-32.img boot in 32 bit mode
  kernel7.img 32 bit mode
  kernel.img 32 bit mode

bcm2710: sort order

Signed-off-by: Christo Nedev <christo.nedev@gmail.com>
---
 target/linux/brcm2708/image/Makefile | 4 +++-
 1 file changed, 3 insertions(+), 1 deletion(-)

Comments

Karl Palsson June 25, 2018, 9:35 a.m. UTC | #1
Christo Nedev <christo.nedev@gmail.com> wrote:
> bcm2709: rename kernel.img to image7.img
>   kernel8.img boot in 64 bit mode
>   kernel8-32.img boot in 32 bit mode
>   kernel7.img 32 bit mode
>   kernel.img 32 bit mode
> 

Couldyou perhaps elaborate on the _why_ of your change? The what
of your change is visible in the diff itself.

Cheers,
Karl P

> bcm2710: sort order
> 
> Signed-off-by: Christo Nedev <christo.nedev@gmail.com>
> ---
>  target/linux/brcm2708/image/Makefile | 4 +++-
>  1 file changed, 3 insertions(+), 1 deletion(-)
> 
> diff --git a/target/linux/brcm2708/image/Makefile
> b/target/linux/brcm2708/image/Makefile index
> 80a019270d..8a94375600 100644
> --- a/target/linux/brcm2708/image/Makefile
> +++ b/target/linux/brcm2708/image/Makefile
> @@ -54,6 +54,7 @@ define Device/Default
>  endef
>  
>  define Device/rpi
> +  KERNEL_IMG := kernel.img
>    DEVICE_TITLE := Raspberry Pi B/B+/CM/Zero/ZeroW
>    DEVICE_DTS := bcm2708-rpi-b bcm2708-rpi-b-plus bcm2708-rpi-cm bcm2708-rpi-0-w
>    SUPPORTED_DEVICES := rpi-b rpi-b-plus rpi-cm rpi-zero rpi-zero-w raspberrypi,model-b raspberrypi,model-b-plus raspberrypi,compute-module-1 raspberrypi,model-b-rev2 raspberrypi,model-zero raspberrypi,model-zero-w
> @@ -64,6 +65,7 @@ ifeq ($(SUBTARGET),bcm2708)
>  endif
>  
>  define Device/rpi-2
> +  KERNEL_IMG := kernel7.img
>    DEVICE_TITLE := Raspberry Pi 2B/3B/3B+/3CM
>    DEVICE_DTS := bcm2709-rpi-2-b bcm2710-rpi-3-b bcm2710-rpi-3-b-plus bcm2710-rpi-cm3
>    SUPPORTED_DEVICES := rpi-2-b rpi-3-b rpi-3-b-plus rpi-cm raspberrypi,2-model-b raspberrypi,3-model-b raspberrypi,3-model-b-plus raspberrypi,compute-module-3
> @@ -78,7 +80,7 @@ define Device/rpi-3
>    DEVICE_TITLE := Raspberry Pi 3B/3B+
>    DEVICE_DTS := broadcom/bcm2710-rpi-3-b broadcom/bcm2710-rpi-3-b-plus
>    SUPPORTED_DEVICES := rpi-3-b rpi-3-b-plus raspberrypi,3-model-b raspberrypi,3-model-b-plus
> -  DEVICE_PACKAGES := brcmfmac-firmware-43430-sdio brcmfmac-board-rpi2 brcmfmac-firmware-43455-sdio brcmfmac-board-rpi3 kmod-brcmfmac wpad-mini
> +  DEVICE_PACKAGES := brcmfmac-firmware-43430-sdio brcmfmac-firmware-43455-sdio brcmfmac-board-rpi2 brcmfmac-board-rpi3 kmod-brcmfmac wpad-mini
>  endef
>  ifeq ($(SUBTARGET),bcm2710)
>    TARGET_DEVICES += rpi-3
> -- 
> 2.11.0
> 
> 
> _______________________________________________
> openwrt-devel mailing list
> openwrt-devel@lists.openwrt.org
> https://lists.openwrt.org/listinfo/openwrt-devel
diff mbox series

Patch

diff --git a/target/linux/brcm2708/image/Makefile b/target/linux/brcm2708/image/Makefile
index 80a019270d..8a94375600 100644
--- a/target/linux/brcm2708/image/Makefile
+++ b/target/linux/brcm2708/image/Makefile
@@ -54,6 +54,7 @@  define Device/Default
 endef
 
 define Device/rpi
+  KERNEL_IMG := kernel.img
   DEVICE_TITLE := Raspberry Pi B/B+/CM/Zero/ZeroW
   DEVICE_DTS := bcm2708-rpi-b bcm2708-rpi-b-plus bcm2708-rpi-cm bcm2708-rpi-0-w
   SUPPORTED_DEVICES := rpi-b rpi-b-plus rpi-cm rpi-zero rpi-zero-w raspberrypi,model-b raspberrypi,model-b-plus raspberrypi,compute-module-1 raspberrypi,model-b-rev2 raspberrypi,model-zero raspberrypi,model-zero-w
@@ -64,6 +65,7 @@  ifeq ($(SUBTARGET),bcm2708)
 endif
 
 define Device/rpi-2
+  KERNEL_IMG := kernel7.img
   DEVICE_TITLE := Raspberry Pi 2B/3B/3B+/3CM
   DEVICE_DTS := bcm2709-rpi-2-b bcm2710-rpi-3-b bcm2710-rpi-3-b-plus bcm2710-rpi-cm3
   SUPPORTED_DEVICES := rpi-2-b rpi-3-b rpi-3-b-plus rpi-cm raspberrypi,2-model-b raspberrypi,3-model-b raspberrypi,3-model-b-plus raspberrypi,compute-module-3
@@ -78,7 +80,7 @@  define Device/rpi-3
   DEVICE_TITLE := Raspberry Pi 3B/3B+
   DEVICE_DTS := broadcom/bcm2710-rpi-3-b broadcom/bcm2710-rpi-3-b-plus
   SUPPORTED_DEVICES := rpi-3-b rpi-3-b-plus raspberrypi,3-model-b raspberrypi,3-model-b-plus
-  DEVICE_PACKAGES := brcmfmac-firmware-43430-sdio brcmfmac-board-rpi2 brcmfmac-firmware-43455-sdio brcmfmac-board-rpi3 kmod-brcmfmac wpad-mini
+  DEVICE_PACKAGES := brcmfmac-firmware-43430-sdio brcmfmac-firmware-43455-sdio brcmfmac-board-rpi2 brcmfmac-board-rpi3 kmod-brcmfmac wpad-mini
 endef
 ifeq ($(SUBTARGET),bcm2710)
   TARGET_DEVICES += rpi-3