diff mbox series

[OpenWrt-Devel,3/3] package: ignore some new errors introduced by GCC 8

Message ID 20180621150812.3477-3-wong.syrone@gmail.com
State Superseded
Headers show
Series [OpenWrt-Devel,1/3] toolchain/gcc: add GCC 8.1.0 | expand

Commit Message

Syrone Wong June 21, 2018, 3:08 p.m. UTC
From: Syrone Wong <wong.syrone@gmail.com>

Signed-off-by: Syrone Wong <wong.syrone@gmail.com>
---
 package/network/config/firewall/Makefile | 2 +-
 package/system/procd/Makefile            | 2 ++
 2 files changed, 3 insertions(+), 1 deletion(-)

Comments

Mathias Kresin June 21, 2018, 7:15 p.m. UTC | #1
21.06.2018 17:08, wong.syrone@gmail.com:
> From: Syrone Wong <wong.syrone@gmail.com>
> 
> Signed-off-by: Syrone Wong <wong.syrone@gmail.com>
> ---
>   package/network/config/firewall/Makefile | 2 +-
>   package/system/procd/Makefile            | 2 ++
>   2 files changed, 3 insertions(+), 1 deletion(-)
> 
> diff --git a/package/network/config/firewall/Makefile b/package/network/config/firewall/Makefile
> index 01fea237f3..43673cf777 100644
> --- a/package/network/config/firewall/Makefile
> +++ b/package/network/config/firewall/Makefile
> @@ -40,7 +40,7 @@ define Package/firewall/conffiles
>   /etc/firewall.user
>   endef
>   
> -TARGET_CFLAGS += -ffunction-sections -fdata-sections
> +TARGET_CFLAGS += -ffunction-sections -fdata-sections -Wno-error=format-overflow
>   TARGET_LDFLAGS += -Wl,--gc-sections
>   CMAKE_OPTIONS += $(if $(CONFIG_IPV6),,-DDISABLE_IPV6=1)
>   
> diff --git a/package/system/procd/Makefile b/package/system/procd/Makefile
> index 5971e0293d..c47ff23352 100644
> --- a/package/system/procd/Makefile
> +++ b/package/system/procd/Makefile
> @@ -37,6 +37,8 @@ endif
>   CMAKE_OPTIONS += -DEARLY_PATH="$(TARGET_INIT_PATH)"
>   TARGET_LDFLAGS += $(if $(CONFIG_USE_GLIBC),-lrt)
>   
> +TARGET_CFLAGS += -Wno-error=format-truncation
> +
>   define Package/procd
>     SECTION:=base
>     CATEGORY:=Base system

NAK.

Please fix the errors instead of hiding the warning. Both packages are 
OpenWrt specific ones. Shouldn't be that difficult to get the fixes applied.

Mathias
Syrone Wong June 22, 2018, 12:13 a.m. UTC | #2
Hi,

I definitely agree we should fix errors, this commit is to bypass
warnings and see if other important components are working well, e.g.
no kernel panic,
busybox is functional, etc. Others can be fixed as the follow-up. It
makes sense to ignore this testing commit.


Best Regards,
Syrone Wong


On Fri, Jun 22, 2018 at 3:15 AM, Mathias Kresin <dev@kresin.me> wrote:
> 21.06.2018 17:08, wong.syrone@gmail.com:
>
>> From: Syrone Wong <wong.syrone@gmail.com>
>>
>> Signed-off-by: Syrone Wong <wong.syrone@gmail.com>
>> ---
>>   package/network/config/firewall/Makefile | 2 +-
>>   package/system/procd/Makefile            | 2 ++
>>   2 files changed, 3 insertions(+), 1 deletion(-)
>>
>> diff --git a/package/network/config/firewall/Makefile
>> b/package/network/config/firewall/Makefile
>> index 01fea237f3..43673cf777 100644
>> --- a/package/network/config/firewall/Makefile
>> +++ b/package/network/config/firewall/Makefile
>> @@ -40,7 +40,7 @@ define Package/firewall/conffiles
>>   /etc/firewall.user
>>   endef
>>   -TARGET_CFLAGS += -ffunction-sections -fdata-sections
>> +TARGET_CFLAGS += -ffunction-sections -fdata-sections
>> -Wno-error=format-overflow
>>   TARGET_LDFLAGS += -Wl,--gc-sections
>>   CMAKE_OPTIONS += $(if $(CONFIG_IPV6),,-DDISABLE_IPV6=1)
>>   diff --git a/package/system/procd/Makefile
>> b/package/system/procd/Makefile
>> index 5971e0293d..c47ff23352 100644
>> --- a/package/system/procd/Makefile
>> +++ b/package/system/procd/Makefile
>> @@ -37,6 +37,8 @@ endif
>>   CMAKE_OPTIONS += -DEARLY_PATH="$(TARGET_INIT_PATH)"
>>   TARGET_LDFLAGS += $(if $(CONFIG_USE_GLIBC),-lrt)
>>   +TARGET_CFLAGS += -Wno-error=format-truncation
>> +
>>   define Package/procd
>>     SECTION:=base
>>     CATEGORY:=Base system
>
>
> NAK.
>
> Please fix the errors instead of hiding the warning. Both packages are
> OpenWrt specific ones. Shouldn't be that difficult to get the fixes applied.
>
> Mathias
>
Rosen Penev June 22, 2018, 12:37 a.m. UTC | #3
On Thu, Jun 21, 2018 at 5:16 PM Syrone Wong <wong.syrone@gmail.com> wrote:
>
> Hi,
>
> I definitely agree we should fix errors, this commit is to bypass
> warnings and see if other important components are working well, e.g.
> no kernel panic,
> busybox is functional, etc. Others can be fixed as the follow-up. It
> makes sense to ignore this testing commit.
Patches have been posted FWIW.
>
>
> Best Regards,
> Syrone Wong
>
>
> On Fri, Jun 22, 2018 at 3:15 AM, Mathias Kresin <dev@kresin.me> wrote:
> > 21.06.2018 17:08, wong.syrone@gmail.com:
> >
> >> From: Syrone Wong <wong.syrone@gmail.com>
> >>
> >> Signed-off-by: Syrone Wong <wong.syrone@gmail.com>
> >> ---
> >>   package/network/config/firewall/Makefile | 2 +-
> >>   package/system/procd/Makefile            | 2 ++
> >>   2 files changed, 3 insertions(+), 1 deletion(-)
> >>
> >> diff --git a/package/network/config/firewall/Makefile
> >> b/package/network/config/firewall/Makefile
> >> index 01fea237f3..43673cf777 100644
> >> --- a/package/network/config/firewall/Makefile
> >> +++ b/package/network/config/firewall/Makefile
> >> @@ -40,7 +40,7 @@ define Package/firewall/conffiles
> >>   /etc/firewall.user
> >>   endef
> >>   -TARGET_CFLAGS += -ffunction-sections -fdata-sections
> >> +TARGET_CFLAGS += -ffunction-sections -fdata-sections
> >> -Wno-error=format-overflow
> >>   TARGET_LDFLAGS += -Wl,--gc-sections
> >>   CMAKE_OPTIONS += $(if $(CONFIG_IPV6),,-DDISABLE_IPV6=1)
> >>   diff --git a/package/system/procd/Makefile
> >> b/package/system/procd/Makefile
> >> index 5971e0293d..c47ff23352 100644
> >> --- a/package/system/procd/Makefile
> >> +++ b/package/system/procd/Makefile
> >> @@ -37,6 +37,8 @@ endif
> >>   CMAKE_OPTIONS += -DEARLY_PATH="$(TARGET_INIT_PATH)"
> >>   TARGET_LDFLAGS += $(if $(CONFIG_USE_GLIBC),-lrt)
> >>   +TARGET_CFLAGS += -Wno-error=format-truncation
> >> +
> >>   define Package/procd
> >>     SECTION:=base
> >>     CATEGORY:=Base system
> >
> >
> > NAK.
> >
> > Please fix the errors instead of hiding the warning. Both packages are
> > OpenWrt specific ones. Shouldn't be that difficult to get the fixes applied.
> >
> > Mathias
> >
>
> _______________________________________________
> openwrt-devel mailing list
> openwrt-devel@lists.openwrt.org
> https://lists.openwrt.org/listinfo/openwrt-devel
diff mbox series

Patch

diff --git a/package/network/config/firewall/Makefile b/package/network/config/firewall/Makefile
index 01fea237f3..43673cf777 100644
--- a/package/network/config/firewall/Makefile
+++ b/package/network/config/firewall/Makefile
@@ -40,7 +40,7 @@  define Package/firewall/conffiles
 /etc/firewall.user
 endef
 
-TARGET_CFLAGS += -ffunction-sections -fdata-sections
+TARGET_CFLAGS += -ffunction-sections -fdata-sections -Wno-error=format-overflow
 TARGET_LDFLAGS += -Wl,--gc-sections
 CMAKE_OPTIONS += $(if $(CONFIG_IPV6),,-DDISABLE_IPV6=1)
 
diff --git a/package/system/procd/Makefile b/package/system/procd/Makefile
index 5971e0293d..c47ff23352 100644
--- a/package/system/procd/Makefile
+++ b/package/system/procd/Makefile
@@ -37,6 +37,8 @@  endif
 CMAKE_OPTIONS += -DEARLY_PATH="$(TARGET_INIT_PATH)"
 TARGET_LDFLAGS += $(if $(CONFIG_USE_GLIBC),-lrt)
 
+TARGET_CFLAGS += -Wno-error=format-truncation
+
 define Package/procd
   SECTION:=base
   CATEGORY:=Base system