diff mbox series

[OpenWrt-Devel] brcm2708: Add support for CYW43455

Message ID 20180527222359.15985-1-christo.nedev@gmail.com
State Changes Requested
Delegated to: John Crispin
Headers show
Series [OpenWrt-Devel] brcm2708: Add support for CYW43455 | expand

Commit Message

Christo Nedev May 27, 2018, 10:23 p.m. UTC
New package brcmfmac-firmware-43455-sdio.

Content:
brcmfmac43455-sdio.bin
brcmfmac43455-sdio.clm_blob
brcmfmac43455-sdio.txt

Source:
https://github.com/RPi-Distro/firmware-nonfree.git

Bit newer from CYPRESS here:
https://community.cypress.com/servlet/JiveServlet/download/14837-1-34881/cypress-fmac-v4.14-2018_0321.zip

Signed-off-by: Christo Nedev <christo.nedev@gmail.com>
---
 package/firmware/firmware-nonfree/Makefile    | 28 +++++++++++++++++++++++++++
 package/firmware/firmware-nonfree/broadcom.mk | 10 ++++++++++
 target/linux/brcm2708/Makefile                |  2 +-
 3 files changed, 39 insertions(+), 1 deletion(-)
 create mode 100644 package/firmware/firmware-nonfree/Makefile
 create mode 100644 package/firmware/firmware-nonfree/broadcom.mk

Comments

John Crispin June 1, 2018, 6:34 a.m. UTC | #1
On 28/05/18 00:23, Christo Nedev wrote:
> New package brcmfmac-firmware-43455-sdio.
>
> Content:
> brcmfmac43455-sdio.bin
> brcmfmac43455-sdio.clm_blob
> brcmfmac43455-sdio.txt
>
> Source:
> https://github.com/RPi-Distro/firmware-nonfree.git
>
> Bit newer from CYPRESS here:
> https://community.cypress.com/servlet/JiveServlet/download/14837-1-34881/cypress-fmac-v4.14-2018_0321.zip
>
> Signed-off-by: Christo Nedev <christo.nedev@gmail.com>
> ---
>   package/firmware/firmware-nonfree/Makefile    | 28 +++++++++++++++++++++++++++
>   package/firmware/firmware-nonfree/broadcom.mk | 10 ++++++++++
Hi
firmware-nonfree is a bit of a weird name. Either use a proper upstream 
repo or call the package brcmfmac-firmware-nonfree
     John

>   target/linux/brcm2708/Makefile                |  2 +-
>   3 files changed, 39 insertions(+), 1 deletion(-)
>   create mode 100644 package/firmware/firmware-nonfree/Makefile
>   create mode 100644 package/firmware/firmware-nonfree/broadcom.mk
>
> diff --git a/package/firmware/firmware-nonfree/Makefile b/package/firmware/firmware-nonfree/Makefile
> new file mode 100644
> index 0000000000..86c9f7600b
> --- /dev/null
> +++ b/package/firmware/firmware-nonfree/Makefile
> @@ -0,0 +1,28 @@
> +include $(TOPDIR)/rules.mk
> +
> +PKG_NAME:=firmware-nonfree
> +PKG_RELEASE:=1
> +
> +PKG_SOURCE_PROTO:=git
> +PKG_SOURCE_URL:=https://github.com/RPi-Distro/firmware-nonfree.git
> +PKG_SOURCE_DATE:=2018-05-27
> +PKG_SOURCE_VERSION:=86e88fbf0345da49555d0ec34c80b4fbae7d0cd3
> +PKG_MIRROR_HASH:=bef9efe173b87e7afc37bb856f9727c4ff64a1ee1cbe6640d22bae79601553bb
> +
> +SCAN_DEPS = *.mk
> +
> +include $(INCLUDE_DIR)/package.mk
> +
> +define Package/firmware-default
> +  SECTION:=firmware
> +  CATEGORY:=Firmware
> +  URL:=https://github.com/RPi-Distro/firmware-nonfree.git
> +  TITLE:=$(1)
> +endef
> +
> +define Build/Compile
> +
> +endef
> +
> +include $(wildcard ./*.mk)
> +#$(eval $(call BuildPackage,firmware-nonfree))
> diff --git a/package/firmware/firmware-nonfree/broadcom.mk b/package/firmware/firmware-nonfree/broadcom.mk
> new file mode 100644
> index 0000000000..ef6bbbed2d
> --- /dev/null
> +++ b/package/firmware/firmware-nonfree/broadcom.mk
> @@ -0,0 +1,10 @@
> +Package/brcmfmac-firmware-43455-sdio = $(call Package/firmware-default,Broadcom BCM43455 FullMac SDIO firmware)
> +define Package/brcmfmac-firmware-43455-sdio/install
> +	$(INSTALL_DIR) $(1)/lib/firmware/brcm
> +	$(INSTALL_DATA) \
> +		$(PKG_BUILD_DIR)/brcm/brcmfmac43455-sdio.bin \
> +		$(PKG_BUILD_DIR)/brcm/brcmfmac43455-sdio.clm_blob \
> +		$(PKG_BUILD_DIR)/brcm/brcmfmac43455-sdio.txt \
> +		$(1)/lib/firmware/brcm/
> +endef
> +$(eval $(call BuildPackage,brcmfmac-firmware-43455-sdio))
> diff --git a/target/linux/brcm2708/Makefile b/target/linux/brcm2708/Makefile
> index 870029c4c8..274e101823 100644
> --- a/target/linux/brcm2708/Makefile
> +++ b/target/linux/brcm2708/Makefile
> @@ -27,7 +27,7 @@ DEFAULT_PACKAGES += \
>   	kmod-usb-hid \
>   	kmod-sound-core kmod-sound-arm-bcm2835 \
>   	kmod-fs-vfat kmod-nls-cp437 kmod-nls-iso8859-1 \
> -	brcmfmac-firmware-43430-sdio kmod-brcmfmac wpad-mini \
> +	brcmfmac-firmware-43430-sdio brcmfmac-firmware-43455-sdio kmod-brcmfmac wpad-mini \
>   	partx-utils mkf2fs e2fsprogs
>   
>   KERNELNAME:=Image dtbs
Christo Nedev June 1, 2018, 3:40 p.m. UTC | #2
Hello,
In my opinion the name is good. Similar to other packages:
package/firmware/linux-firmware/ <->  package/firmware/firmware-nonfree/ 
https://git.kernel.org/pub/scm/linux/kernel/git/firmware/linux-firmware.git <-> https://github.com/RPi-Distro/firmware-nonfree.git
Actually the repository name is firmware-nonfree or my be I'm wrong. In the raspberry pi and debian community this name is known I think.
It is possible in future to be added firmwares not from brcmfmac family. So brcmfmac-firmware-nonfree not be suitable.
Thanks!

Sent from iPhone!

> On 1 Jun 2018, at 16:27, Christo Nedev <christo.nedev@gmail.com> wrote:
> 
> Hello,
> In my opinion the name is good. Similar to other packages:
> package/firmware/linux-firmware/ <->  package/firmware/firmware-nonfree/ 
> https://git.kernel.org/pub/scm/linux/kernel/git/firmware/linux-firmware.git <-> https://github.com/RPi-Distro/firmware-nonfree.git
> Actually the repository name is firmware-nonfree or my be I'm wrong. In the raspberry pi and debian community this name is known I think.
> It is possible in future to be added firmwares not from brcmfmac family. So brcmfmac-firmware-nonfree not be suitable.
> Thanks!
<html><head><meta http-equiv="content-type" content="text/html; charset=utf-8"></head><body dir="auto"><span style="background-color: rgba(255, 255, 255, 0);">Hello,</span><div><span style="background-color: rgba(255, 255, 255, 0);">In my opinion the name is good. Similar to other packages:</span><div><font color="#000000"><span style="caret-color: rgb(0, 0, 0); background-color: rgba(255, 255, 255, 0);"><a title="package" href="https://git.openwrt.org/?p=openwrt/openwrt.git;a=tree;f=package;hb=HEAD" style="font-variant-ligatures: normal; font-weight: 700;"></a></span></font></div><div style="font-variant-ligatures: normal;"><div><span style="background-color: rgba(255, 255, 255, 0);">package/firmware/linux-firmware/ &lt;-&gt;&nbsp; package/firmware/firmware-nonfree/&nbsp;</span></div><div><font color="#000000"><span style="caret-color: rgb(0, 0, 0); background-color: rgba(255, 255, 255, 0);"><a href="https://git.kernel.org/pub/scm/linux/kernel/git/firmware/linux-firmware.git">https://git.kernel.org/pub/scm/linux/kernel/git/firmware/linux-firmware.git</a>&nbsp;&lt;-&gt;&nbsp;<a href="https://github.com/RPi-Distro/firmware-nonfree.git">https://github.com/RPi-Distro/firmware-nonfree.git</a></span></font></div></div><div><span style="background-color: rgba(255, 255, 255, 0);">Actually the&nbsp;repository name is&nbsp;<span style="font-variant-ligatures: normal;">firmware-nonfree or my be I'm wrong.&nbsp;In the raspberry pi and debian community this name is known I think.</span></span></div><div><span style="background-color: rgba(255, 255, 255, 0);">It is possible in future to be added firmwares not from&nbsp;<span style="font-variant-ligatures: normal;">brcmfmac family. So&nbsp;<span style="font-variant-ligatures: normal;">brcmfmac-firmware-nonfree not be suitable.</span></span></span></div><div><span style="font-variant-ligatures: normal;"><span style="font-variant-ligatures: normal; background-color: rgba(255, 255, 255, 0);">Thanks!</span></span></div></div><br><div id="AppleMailSignature">Sent from iPhone!</div><div><br>On 1 Jun 2018, at 16:27, Christo Nedev &lt;<a href="mailto:christo.nedev@gmail.com">christo.nedev@gmail.com</a>&gt; wrote:<br><br></div><blockquote type="cite"><div>Hello,<div>In my opinion the name is good. Similar to other packages:<div>

<a title="package" href="https://git.openwrt.org/?p=openwrt/openwrt.git;a=tree;f=package;hb=HEAD" style="color:rgb(136,0,0);font-family:sans-serif;font-size:small;font-style:normal;font-variant-ligatures:normal;font-variant-caps:normal;font-weight:700;letter-spacing:normal;text-align:start;text-indent:0px;text-transform:none;white-space:normal;word-spacing:0px;background-color:rgb(255,255,255)"></a></div><div style="color:rgb(34,34,34);font-family:arial,sans-serif;font-size:small;font-style:normal;font-variant-ligatures:normal;font-variant-caps:normal;font-weight:400;letter-spacing:normal;text-align:start;text-indent:0px;text-transform:none;white-space:normal;word-spacing:0px;text-decoration-style:initial;text-decoration-color:initial"><div>package/firmware/linux-firmware/ &lt;-&gt;&nbsp; package/firmware/firmware-nonfree/&nbsp;</div><div><a href="https://git.kernel.org/pub/scm/linux/kernel/git/firmware/linux-firmware.git">https://git.kernel.org/pub/scm/linux/kernel/git/firmware/linux-firmware.git</a> &lt;-&gt; <a href="https://github.com/RPi-Distro/firmware-nonfree.git">https://github.com/RPi-Distro/firmware-nonfree.git</a></div></div><div>Actually the&nbsp;repository name is&nbsp;<span style="color:rgb(34,34,34);font-family:arial,sans-serif;font-size:small;font-style:normal;font-variant-ligatures:normal;font-variant-caps:normal;font-weight:400;letter-spacing:normal;text-align:start;text-indent:0px;text-transform:none;white-space:normal;word-spacing:0px;background-color:rgb(255,255,255);text-decoration-style:initial;text-decoration-color:initial;float:none;display:inline">firmware-nonfree or my be I'm wrong.&nbsp;In the raspberry pi and debian community this name is known I think.</span></div><div>It is possible in future to be added firmwares not from&nbsp;<span style="color:rgb(34,34,34);font-family:arial,sans-serif;font-size:16px;font-style:normal;font-variant-ligatures:normal;font-variant-caps:normal;font-weight:400;letter-spacing:normal;text-align:start;text-indent:0px;text-transform:none;white-space:normal;word-spacing:0px;background-color:rgb(255,255,255);text-decoration-style:initial;text-decoration-color:initial;float:none;display:inline">brcmfmac family. So&nbsp;<span style="color:rgb(34,34,34);font-family:arial,sans-serif;font-size:16px;font-style:normal;font-variant-ligatures:normal;font-variant-caps:normal;font-weight:400;letter-spacing:normal;text-align:start;text-indent:0px;text-transform:none;white-space:normal;word-spacing:0px;background-color:rgb(255,255,255);text-decoration-style:initial;text-decoration-color:initial;float:none;display:inline">brcmfmac-firmware-nonfree not be suitable.</span></span></div><div><span style="color:rgb(34,34,34);font-family:arial,sans-serif;font-size:16px;font-style:normal;font-variant-ligatures:normal;font-variant-caps:normal;font-weight:400;letter-spacing:normal;text-align:start;text-indent:0px;text-transform:none;white-space:normal;word-spacing:0px;background-color:rgb(255,255,255);text-decoration-style:initial;text-decoration-color:initial;float:none;display:inline"><span style="color:rgb(34,34,34);font-family:arial,sans-serif;font-size:16px;font-style:normal;font-variant-ligatures:normal;font-variant-caps:normal;font-weight:400;letter-spacing:normal;text-align:start;text-indent:0px;text-transform:none;white-space:normal;word-spacing:0px;background-color:rgb(255,255,255);text-decoration-style:initial;text-decoration-color:initial;float:none;display:inline">Thanks!</span></span></div></div></div></blockquote></body></html>
diff mbox series

Patch

diff --git a/package/firmware/firmware-nonfree/Makefile b/package/firmware/firmware-nonfree/Makefile
new file mode 100644
index 0000000000..86c9f7600b
--- /dev/null
+++ b/package/firmware/firmware-nonfree/Makefile
@@ -0,0 +1,28 @@ 
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=firmware-nonfree
+PKG_RELEASE:=1
+
+PKG_SOURCE_PROTO:=git
+PKG_SOURCE_URL:=https://github.com/RPi-Distro/firmware-nonfree.git
+PKG_SOURCE_DATE:=2018-05-27
+PKG_SOURCE_VERSION:=86e88fbf0345da49555d0ec34c80b4fbae7d0cd3
+PKG_MIRROR_HASH:=bef9efe173b87e7afc37bb856f9727c4ff64a1ee1cbe6640d22bae79601553bb
+
+SCAN_DEPS = *.mk
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/firmware-default
+  SECTION:=firmware
+  CATEGORY:=Firmware
+  URL:=https://github.com/RPi-Distro/firmware-nonfree.git
+  TITLE:=$(1)
+endef
+
+define Build/Compile
+
+endef
+
+include $(wildcard ./*.mk)
+#$(eval $(call BuildPackage,firmware-nonfree))
diff --git a/package/firmware/firmware-nonfree/broadcom.mk b/package/firmware/firmware-nonfree/broadcom.mk
new file mode 100644
index 0000000000..ef6bbbed2d
--- /dev/null
+++ b/package/firmware/firmware-nonfree/broadcom.mk
@@ -0,0 +1,10 @@ 
+Package/brcmfmac-firmware-43455-sdio = $(call Package/firmware-default,Broadcom BCM43455 FullMac SDIO firmware)
+define Package/brcmfmac-firmware-43455-sdio/install
+	$(INSTALL_DIR) $(1)/lib/firmware/brcm
+	$(INSTALL_DATA) \
+		$(PKG_BUILD_DIR)/brcm/brcmfmac43455-sdio.bin \
+		$(PKG_BUILD_DIR)/brcm/brcmfmac43455-sdio.clm_blob \
+		$(PKG_BUILD_DIR)/brcm/brcmfmac43455-sdio.txt \
+		$(1)/lib/firmware/brcm/
+endef
+$(eval $(call BuildPackage,brcmfmac-firmware-43455-sdio))
diff --git a/target/linux/brcm2708/Makefile b/target/linux/brcm2708/Makefile
index 870029c4c8..274e101823 100644
--- a/target/linux/brcm2708/Makefile
+++ b/target/linux/brcm2708/Makefile
@@ -27,7 +27,7 @@  DEFAULT_PACKAGES += \
 	kmod-usb-hid \
 	kmod-sound-core kmod-sound-arm-bcm2835 \
 	kmod-fs-vfat kmod-nls-cp437 kmod-nls-iso8859-1 \
-	brcmfmac-firmware-43430-sdio kmod-brcmfmac wpad-mini \
+	brcmfmac-firmware-43430-sdio brcmfmac-firmware-43455-sdio kmod-brcmfmac wpad-mini \
 	partx-utils mkf2fs e2fsprogs
 
 KERNELNAME:=Image dtbs