diff mbox series

[OpenWrt-Devel,at91,v2,10/11] at91:sama5: create fit image

Message ID 1561158139-13473-11-git-send-email-sandeep.sheriker@microchip.com
State Superseded
Delegated to: Hauke Mehrtens
Headers show
Series at91 patch series | expand

Commit Message

Sandeep Sheriker M June 21, 2019, 11:02 p.m. UTC
create fit image & add it to sdcard image for sama5 target
device.

Signed-off-by: Sandeep Sheriker M <sandeep.sheriker@microchip.com>
---
 target/linux/at91/image/Makefile | 2 ++
 target/linux/at91/image/sama5.mk | 4 +++-
 2 files changed, 5 insertions(+), 1 deletion(-)
diff mbox series

Patch

diff --git a/target/linux/at91/image/Makefile b/target/linux/at91/image/Makefile
index 3b01d42..adb7c6d 100644
--- a/target/linux/at91/image/Makefile
+++ b/target/linux/at91/image/Makefile
@@ -63,6 +63,8 @@  define Device/evaluation-dtb
   $(Device/evaluation-zImage)
   IMAGES += dtb
   IMAGE/dtb := install-dtb
+  KERNEL_SUFFIX := -fit-zImage.itb
+  KERNEL := kernel-bin | gzip | fit gzip $$(DTS_DIR)/$$(DEVICE_DTS).dtb
 endef
 
 define Device/evaluation-fit
diff --git a/target/linux/at91/image/sama5.mk b/target/linux/at91/image/sama5.mk
index 08118bb..ac4540c 100644
--- a/target/linux/at91/image/sama5.mk
+++ b/target/linux/at91/image/sama5.mk
@@ -11,7 +11,9 @@  define Build/at91-sdcard
   rm -f $@.boot
   mkfs.fat -C $@.boot $(FAT32_BLOCKS)
 
-  mcopy -i $@.boot $(KDIR)/zImage ::zImage
+  mcopy -i $@.boot \
+	$(KDIR)/$(DEVICE_NAME)-fit-zImage.itb \
+	::$(DEVICE_NAME:at91-%=%)-fit.itb
 
   $(if $(findstring at91-sama5d27_som1_ek,$@), \
       mcopy -i $@.boot \