diff mbox series

[OpenWrt-Devel,v2,2/2] ath79: add support for ON Networks N150R

Message ID 1529504468-1797-2-git-send-email-wigyori@uid0.hu
State Accepted
Delegated to: John Crispin
Headers show
Series [OpenWrt-Devel,v2,1/2] ath79: add Netgear WNR612 v2 | expand

Commit Message

Zoltan HERPAI June 20, 2018, 2:21 p.m. UTC
This is a rebranded Netgear WNR612v2, specs are the same.

 - Atheros AR7240 (Python) @400MHz
 - flash 4MB
 - ram 32MB
 - ethernet 10/100: 1xwan + 2xlan (only two)
 - radio AR9285

Signed-off-by: Zoltan HERPAI <wigyori@uid0.hu>
---
 target/linux/ath79/base-files/etc/board.d/01_leds       |  3 ++-
 target/linux/ath79/base-files/etc/board.d/02_network    |  3 ++-
 .../base-files/etc/hotplug.d/firmware/10-ath9k-eeprom   |  1 +
 target/linux/ath79/dts/ar7240_on_n150r.dts              | 10 ++++++++++
 target/linux/ath79/image/tiny-netgear.mk                | 17 +++++++++++++++++
 5 files changed, 32 insertions(+), 2 deletions(-)
 create mode 100644 target/linux/ath79/dts/ar7240_on_n150r.dts
diff mbox series

Patch

diff --git a/target/linux/ath79/base-files/etc/board.d/01_leds b/target/linux/ath79/base-files/etc/board.d/01_leds
index 68f94ed..29416ad 100755
--- a/target/linux/ath79/base-files/etc/board.d/01_leds
+++ b/target/linux/ath79/base-files/etc/board.d/01_leds
@@ -22,7 +22,8 @@  case "$board" in
 	ucidef_set_led_oneshot "modbus" "Modbus" "$boardname:red:modbus" "100" "33"
 	ucidef_set_led_default "etactica" "etactica" "$boardname:red:etactica" "ignore"
 	;;
-"netgear,wnr612-v2")
+"netgear,wnr612-v2"|\
+"on,n150r")
 	ucidef_set_led_netdev "wan" "WAN" "netgear:green:wan" "eth0"
 	ucidef_set_led_switch "lan1" "LAN1" "netgear:green:lan1" "switch0" "0x02" "0x0f"
 	ucidef_set_led_switch "lan2" "LAN2" "netgear:green:lan2" "switch0" "0x04" "0x0f"
diff --git a/target/linux/ath79/base-files/etc/board.d/02_network b/target/linux/ath79/base-files/etc/board.d/02_network
index 2caf443..743b877 100755
--- a/target/linux/ath79/base-files/etc/board.d/02_network
+++ b/target/linux/ath79/base-files/etc/board.d/02_network
@@ -33,7 +33,8 @@  ath79_setup_interfaces()
 		ucidef_set_interfaces_lan_wan "eth1" "eth0"
 		;;
 
-	"netgear,wnr612-v2")
+	"netgear,wnr612-v2"|\
+	"on,n150r")
 		ucidef_set_interfaces_lan_wan "eth1.1" "eth0"
 		ucidef_add_switch "switch0" \
 		"0@eth1" "1:lan" "2:lan" "3:lan:3" "4:lan:4"
diff --git a/target/linux/ath79/base-files/etc/hotplug.d/firmware/10-ath9k-eeprom b/target/linux/ath79/base-files/etc/hotplug.d/firmware/10-ath9k-eeprom
index 1ed7460..5b22b15 100644
--- a/target/linux/ath79/base-files/etc/hotplug.d/firmware/10-ath9k-eeprom
+++ b/target/linux/ath79/base-files/etc/hotplug.d/firmware/10-ath9k-eeprom
@@ -55,6 +55,7 @@  case "$FIRMWARE" in
 		ath9k_eeprom_extract "art" 20480 1088
 		;;
 	"netgear,wnr612-v2"|\
+	"on,n150r"|\
 	"tplink,tl-wr740n-v2"|\
 	"ubnt,unifi")
 		ath9k_eeprom_extract "art" 4096 2048
diff --git a/target/linux/ath79/dts/ar7240_on_n150r.dts b/target/linux/ath79/dts/ar7240_on_n150r.dts
new file mode 100644
index 0000000..cb4cf92
--- /dev/null
+++ b/target/linux/ath79/dts/ar7240_on_n150r.dts
@@ -0,0 +1,10 @@ 
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+/dts-v1/;
+
+#include "ar7240_netgear_wnr612-v2.dtsi"
+
+/ {
+	model = "ON Network N150R";
+	compatible = "on,n150r";
+};
+
diff --git a/target/linux/ath79/image/tiny-netgear.mk b/target/linux/ath79/image/tiny-netgear.mk
index 81f83fd..48d14e9 100644
--- a/target/linux/ath79/image/tiny-netgear.mk
+++ b/target/linux/ath79/image/tiny-netgear.mk
@@ -17,3 +17,20 @@  define Device/netgear_wnr612-v2
   SUPPORTED_DEVICES := netgear,wnr612-v2 wnr612-v2
 endef
 TARGET_DEVICES += netgear_wnr612-v2
+
+define Device/n150r
+  ATH_SOC := ar7240
+  DEVICE_TITLE := ON Network N150R
+  DEVICE_DTS := ar7240_on_n150r
+  NETGEAR_KERNEL_MAGIC := 0x32303631
+  KERNEL := kernel-bin | append-dtb | lzma -d20 | netgear-uImage lzma
+  KERNEL_INITRAMFS := kernel-bin | append-dtb | lzma -d20 | netgear-uImage lzma
+  NETGEAR_BOARD_ID := N150R
+  IMAGE_SIZE := 3904k
+  IMAGES := sysupgrade.bin factory.img
+  IMAGE/default := append-kernel | pad-to $$$$(BLOCKSIZE) | netgear-squashfs | append-rootfs | pad-rootfs
+  IMAGE/sysupgrade.bin := $$(IMAGE/default) | append-metadata | check-size $$$$(IMAGE_SIZE)
+  IMAGE/factory.img := $$(IMAGE/default) | netgear-dni | check-size $$$$(IMAGE_SIZE)
+  SUPPORTED_DEVICES := on,n150r n150r
+endef
+TARGET_DEVICES += n150r