diff mbox series

[OpenWrt-Devel] kernel/modules/other: disable Nokia BT UART

Message ID 1516746669-30442-1-git-send-email-tharvey@gateworks.com
State Accepted
Delegated to: John Crispin
Headers show
Series [OpenWrt-Devel] kernel/modules/other: disable Nokia BT UART | expand

Commit Message

Tim Harvey Jan. 23, 2018, 10:31 p.m. UTC
disable the Nokia BT UART present on Nikia N9, N900 & N950 added in 4.12.

Signed-off-by: Tim Harvey <tharvey@gateworks.com>
---
 package/kernel/linux/modules/other.mk | 1 +
 1 file changed, 1 insertion(+)

Comments

txt.file Jan. 25, 2018, 3:18 a.m. UTC | #1
There is a typo in the company name in the description.

Also I would like to know why it is removed. And what changed between
Linux 4.11 and 4.12 regarding the Nokia N900.

kind regards
txt.file

Tim Harvey:
> disable the Nokia BT UART present on Nikia N9, N900 & N950 added in 4.12.
> 
> Signed-off-by: Tim Harvey <tharvey@gateworks.com>
> ---
>  package/kernel/linux/modules/other.mk | 1 +
>  1 file changed, 1 insertion(+)
> 
> diff --git a/package/kernel/linux/modules/other.mk b/package/kernel/linux/modules/other.mk
> index 1c7869e..1655c14 100644
> --- a/package/kernel/linux/modules/other.mk
> +++ b/package/kernel/linux/modules/other.mk
> @@ -55,6 +55,7 @@ define KernelPackage/bluetooth
>  	CONFIG_BT_HCIUART_BCM=n \
>  	CONFIG_BT_HCIUART_INTEL=n \
>  	CONFIG_BT_HCIUART_H4 \
> +	CONFIG_BT_HCIUART_NOKIA=n \
>  	CONFIG_BT_HIDP \
>  	CONFIG_HID_SUPPORT=y
>    $(call AddDepends/rfkill)
>
Tim Harvey Jan. 25, 2018, 4:22 a.m. UTC | #2
On Wed, Jan 24, 2018 at 7:18 PM, txt.file <txt.file@txtfile.eu> wrote:
> There is a typo in the company name in the description.
>

Oops - easy to fix. I can submit a followup.

> Also I would like to know why it is removed. And what changed between
> Linux 4.11 and 4.12 regarding the Nokia N900.
>

CONFIG_BT_HCIUART_NOKIA didn't exist prior to 4.12. It was added in
4.12 so if you are using a target with a 4.14 kernel (which OpenWrt
now supports) and enable bluetooth you get prompted for this kernel
option because its not set either way in the bluetooth package. I
disable it here simply because INTEL and BCM is also disabled.

Regards,

Tim
diff mbox series

Patch

diff --git a/package/kernel/linux/modules/other.mk b/package/kernel/linux/modules/other.mk
index 1c7869e..1655c14 100644
--- a/package/kernel/linux/modules/other.mk
+++ b/package/kernel/linux/modules/other.mk
@@ -55,6 +55,7 @@  define KernelPackage/bluetooth
 	CONFIG_BT_HCIUART_BCM=n \
 	CONFIG_BT_HCIUART_INTEL=n \
 	CONFIG_BT_HCIUART_H4 \
+	CONFIG_BT_HCIUART_NOKIA=n \
 	CONFIG_BT_HIDP \
 	CONFIG_HID_SUPPORT=y
   $(call AddDepends/rfkill)