diff mbox

[OpenWrt-Devel] kernel: crypto.mk: have crypto-aead depend on kmod-crypto-null for 4.3

Message ID 1450220266-17281-1-git-send-email-psidhu@gateworks.com
State Superseded
Headers show

Commit Message

Pushpal Sidhu Dec. 15, 2015, 10:57 p.m. UTC
Without this, the following error message occurs when building with the 4.3
kernel:

 Package kmod-crypto-aead is missing dependencies for the following libraries:
 crypto_null.ko

Signed-off-by: Pushpal Sidhu <psidhu@gateworks.com>
---
 package/kernel/linux/modules/crypto.mk | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
diff mbox

Patch

diff --git a/package/kernel/linux/modules/crypto.mk b/package/kernel/linux/modules/crypto.mk
index fe64db4..dc817ee 100644
--- a/package/kernel/linux/modules/crypto.mk
+++ b/package/kernel/linux/modules/crypto.mk
@@ -27,7 +27,7 @@  define KernelPackage/crypto-aead
 	CONFIG_CRYPTO_AEAD2
   FILES:=$(LINUX_DIR)/crypto/aead.ko
   AUTOLOAD:=$(call AutoLoad,09,aead,1)
-  $(call AddDepends/crypto, +LINUX_4_4:kmod-crypto-null)
+  $(call AddDepends/crypto, +LINUX_4_3:kmod-crypto-null +LINUX_4_4:kmod-crypto-null)
 endef
 
 $(eval $(call KernelPackage,crypto-aead))