diff mbox

[OpenWrt-Devel,2/2] uqmi: added _library suffix to lib variables

Message ID 1448001276-26245-3-git-send-email-dbachtin@init-ka.de
State Accepted
Headers show

Commit Message

Bachtin, Dmitri Nov. 20, 2015, 6:34 a.m. UTC
It is a convention under CMake to suffix variables in the FIND_LIBRARY
calls with _LIBRARY. Added _library suffix to json, blobmsg_json and
ubox variables.
---
 CMakeLists.txt | 14 +++++++-------
 1 file changed, 7 insertions(+), 7 deletions(-)
diff mbox

Patch

diff --git a/CMakeLists.txt b/CMakeLists.txt
index 4febbde..3bb0230 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -16,16 +16,16 @@  FIND_PATH(json_include_dir json-c/json.h json/json.h json.h)
 INCLUDE_DIRECTORIES(${ubox_include_dir} ${blobmsg_json_include_dir} ${json_include_dir})
 
 IF(BUILD_STATIC)
-  FIND_LIBRARY(json NAMES libjson.a libjson-c.a)
-  FIND_LIBRARY(blobmsg_json NAMES libblobmsg_json.a)
-  FIND_LIBRARY(ubox NAMES libubox.a)
+  FIND_LIBRARY(json_library NAMES libjson.a libjson-c.a)
+  FIND_LIBRARY(blobmsg_json_library NAMES libblobmsg_json.a)
+  FIND_LIBRARY(ubox_library NAMES libubox.a)
 ELSE(BUILD_STATIC)
-  FIND_LIBRARY(json NAMES json-c json)
-  FIND_LIBRARY(blobmsg_json NAMES blobmsg_json)
-  FIND_LIBRARY(ubox NAMES ubox)
+  FIND_LIBRARY(json_library NAMES json-c json)
+  FIND_LIBRARY(blobmsg_json_library NAMES blobmsg_json)
+  FIND_LIBRARY(ubox_library NAMES ubox)
 ENDIF(BUILD_STATIC)
 
-SET(LIBS ${ubox} ${blobmsg_json} ${json})
+SET(LIBS ${ubox_library} ${blobmsg_json_library} ${json_library})
 
 IF(DEBUG_PACKET)
   ADD_DEFINITIONS(-DDEBUG_PACKET)