diff mbox

[OpenWrt-Devel,1/2] uqmi: search for ubox, blobmsg_json and json include paths

Message ID 1448001276-26245-2-git-send-email-dbachtin@init-ka.de
State Accepted
Headers show

Commit Message

Bachtin, Dmitri Nov. 20, 2015, 6:34 a.m. UTC
CMake will search for include paths via FIND_PATH() of the following
libraries: libubox, blobmsg_json and json. This allows to build uqmi
when the dependencies are in non-standard locations by specifying
respective _include_dir variables.
---
 CMakeLists.txt | 5 +++++
 1 file changed, 5 insertions(+)
diff mbox

Patch

diff --git a/CMakeLists.txt b/CMakeLists.txt
index 2e03024..4febbde 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -10,6 +10,11 @@  SET(CMAKE_SHARED_LIBRARY_LINK_C_FLAGS "")
 
 SET(SOURCES main.c dev.c commands.c qmi-message.c)
 
+FIND_PATH(ubox_include_dir libubox/usock.h)
+FIND_PATH(blobmsg_json_include_dir libubox/blobmsg_json.h)
+FIND_PATH(json_include_dir json-c/json.h json/json.h json.h)
+INCLUDE_DIRECTORIES(${ubox_include_dir} ${blobmsg_json_include_dir} ${json_include_dir})
+
 IF(BUILD_STATIC)
   FIND_LIBRARY(json NAMES libjson.a libjson-c.a)
   FIND_LIBRARY(blobmsg_json NAMES libblobmsg_json.a)