diff mbox

[OpenWrt-Devel] x86: add generic profiles to x86_64, kvm_guest and xen_domu

Message ID 1446427135-25714-1-git-send-email-lynxis@fe80.eu
State Accepted
Headers show

Commit Message

Alexander 'lynxis' Couzens Nov. 2, 2015, 1:18 a.m. UTC
The imagebuilder requires a profile for every subtarget to work.

Signed-off-by: Alexander Couzens <lynxis@fe80.eu>
---
 target/linux/x86/64/profiles/000-Generic.mk        | 15 +++++++++++++++
 target/linux/x86/kvm_guest/profiles/000-Generic.mk | 15 +++++++++++++++
 target/linux/x86/xen_domu/profiles/000-Generic.mk  | 15 +++++++++++++++
 3 files changed, 45 insertions(+)
 create mode 100644 target/linux/x86/64/profiles/000-Generic.mk
 create mode 100644 target/linux/x86/kvm_guest/profiles/000-Generic.mk
 create mode 100644 target/linux/x86/xen_domu/profiles/000-Generic.mk
diff mbox

Patch

diff --git a/target/linux/x86/64/profiles/000-Generic.mk b/target/linux/x86/64/profiles/000-Generic.mk
new file mode 100644
index 0000000..ccd125a
--- /dev/null
+++ b/target/linux/x86/64/profiles/000-Generic.mk
@@ -0,0 +1,15 @@ 
+#
+# Copyright (C) 2006-2015 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Generic
+  NAME:=Generic
+endef
+
+define Profile/Generic/Description
+	Generic Profile
+endef
+$(eval $(call Profile,Generic))
diff --git a/target/linux/x86/kvm_guest/profiles/000-Generic.mk b/target/linux/x86/kvm_guest/profiles/000-Generic.mk
new file mode 100644
index 0000000..ccd125a
--- /dev/null
+++ b/target/linux/x86/kvm_guest/profiles/000-Generic.mk
@@ -0,0 +1,15 @@ 
+#
+# Copyright (C) 2006-2015 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Generic
+  NAME:=Generic
+endef
+
+define Profile/Generic/Description
+	Generic Profile
+endef
+$(eval $(call Profile,Generic))
diff --git a/target/linux/x86/xen_domu/profiles/000-Generic.mk b/target/linux/x86/xen_domu/profiles/000-Generic.mk
new file mode 100644
index 0000000..ccd125a
--- /dev/null
+++ b/target/linux/x86/xen_domu/profiles/000-Generic.mk
@@ -0,0 +1,15 @@ 
+#
+# Copyright (C) 2006-2015 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Generic
+  NAME:=Generic
+endef
+
+define Profile/Generic/Description
+	Generic Profile
+endef
+$(eval $(call Profile,Generic))