diff mbox

[OpenWrt-Devel,2/4] kernel: add ath3k module package

Message ID 1444425737-14270-3-git-send-email-psidhu@gateworks.com
State Superseded
Headers show

Commit Message

Pushpal Sidhu Oct. 9, 2015, 9:22 p.m. UTC
Adds a package for the ath3k kernel module, present in 3.18/4.0/4.1 kernels

Signed-off-by: Pushpal Sidhu <psidhu@gateworks.com>
---
 package/kernel/linux/modules/other.mk | 19 +++++++++++++++++++
 1 file changed, 19 insertions(+)

Comments

Roman Yeryomin Oct. 9, 2015, 9:44 p.m. UTC | #1
On 10 October 2015 at 00:22, Pushpal Sidhu <psidhu@gateworks.com> wrote:
> Adds a package for the ath3k kernel module, present in 3.18/4.0/4.1 kernels
>
> Signed-off-by: Pushpal Sidhu <psidhu@gateworks.com>
> ---
>  package/kernel/linux/modules/other.mk | 19 +++++++++++++++++++
>  1 file changed, 19 insertions(+)
>
> diff --git a/package/kernel/linux/modules/other.mk b/package/kernel/linux/modules/other.mk
> index d438fbe..8620bca 100644
> --- a/package/kernel/linux/modules/other.mk
> +++ b/package/kernel/linux/modules/other.mk
> @@ -78,6 +78,25 @@ endef
>
>  $(eval $(call KernelPackage,bluetooth))
>
> +define KernelPackage/ath3k
> +  SUBMENU:=$(OTHER_MENU)
> +  TITLE:=ATH3K Kernel Module support
> +  DEPENDS:=+kmod-bluetooth
> +  KCONFIG:= \
> +       CONFIG_BT_ATH3K \
> +       CONFIG_BT_HCIUART_ATH3K
> +  $(call AddDepends/bluetooth)
> +  FILES:= \
> +       $(LINUX_DIR)/drivers/bluetooth/ath3k.ko
> +  AUTOLOAD:=$(call AutoProbe,ath3k)
> +endef
> +
> +define KernelPackage/ath3k/description
> + Kernel support for ATH3K Module
> +endef
> +
> +$(eval $(call KernelPackage,ath3k))
> +

IMO this should depend on ar3k-firmware because it will not work
without that anyway

Regards,
Roman
Pushpal Sidhu Oct. 9, 2015, 9:48 p.m. UTC | #2
On Fri, Oct 9, 2015 at 2:44 PM, Roman Yeryomin <leroi.lists@gmail.com> wrote:
> On 10 October 2015 at 00:22, Pushpal Sidhu <psidhu@gateworks.com> wrote:
>> Adds a package for the ath3k kernel module, present in 3.18/4.0/4.1 kernels
>>
>> Signed-off-by: Pushpal Sidhu <psidhu@gateworks.com>
>> ---
>>  package/kernel/linux/modules/other.mk | 19 +++++++++++++++++++
>>  1 file changed, 19 insertions(+)
>>
>> diff --git a/package/kernel/linux/modules/other.mk b/package/kernel/linux/modules/other.mk
>> index d438fbe..8620bca 100644
>> --- a/package/kernel/linux/modules/other.mk
>> +++ b/package/kernel/linux/modules/other.mk
>> @@ -78,6 +78,25 @@ endef
>>
>>  $(eval $(call KernelPackage,bluetooth))
>>
>> +define KernelPackage/ath3k
>> +  SUBMENU:=$(OTHER_MENU)
>> +  TITLE:=ATH3K Kernel Module support
>> +  DEPENDS:=+kmod-bluetooth
>> +  KCONFIG:= \
>> +       CONFIG_BT_ATH3K \
>> +       CONFIG_BT_HCIUART_ATH3K
>> +  $(call AddDepends/bluetooth)
>> +  FILES:= \
>> +       $(LINUX_DIR)/drivers/bluetooth/ath3k.ko
>> +  AUTOLOAD:=$(call AutoProbe,ath3k)
>> +endef
>> +
>> +define KernelPackage/ath3k/description
>> + Kernel support for ATH3K Module
>> +endef
>> +
>> +$(eval $(call KernelPackage,ath3k))
>> +
>
> IMO this should depend on ar3k-firmware because it will not work
> without that anyway
>
> Regards,
> Roman

Totally agree. I'll send a v2 after I get some feedback on the rest of
the series/by monday.

- Pushpal
diff mbox

Patch

diff --git a/package/kernel/linux/modules/other.mk b/package/kernel/linux/modules/other.mk
index d438fbe..8620bca 100644
--- a/package/kernel/linux/modules/other.mk
+++ b/package/kernel/linux/modules/other.mk
@@ -78,6 +78,25 @@  endef
 
 $(eval $(call KernelPackage,bluetooth))
 
+define KernelPackage/ath3k
+  SUBMENU:=$(OTHER_MENU)
+  TITLE:=ATH3K Kernel Module support
+  DEPENDS:=+kmod-bluetooth
+  KCONFIG:= \
+	CONFIG_BT_ATH3K \
+	CONFIG_BT_HCIUART_ATH3K
+  $(call AddDepends/bluetooth)
+  FILES:= \
+	$(LINUX_DIR)/drivers/bluetooth/ath3k.ko
+  AUTOLOAD:=$(call AutoProbe,ath3k)
+endef
+
+define KernelPackage/ath3k/description
+ Kernel support for ATH3K Module
+endef
+
+$(eval $(call KernelPackage,ath3k))
+
 
 define KernelPackage/bluetooth_6lowpan
   SUBMENU:=$(OTHER_MENU)