diff mbox

[OpenWrt-Devel,2/4] brcm2708: switch device tree compilation to linux

Message ID 1443731780-13238-2-git-send-email-noltari@gmail.com
State Accepted
Delegated to: John Crispin
Headers show

Commit Message

Álvaro Fernández Rojas Oct. 1, 2015, 8:36 p.m. UTC
Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
---
 target/linux/brcm2708/Makefile       | 2 +-
 target/linux/brcm2708/image/Makefile | 8 ++------
 2 files changed, 3 insertions(+), 7 deletions(-)
diff mbox

Patch

diff --git a/target/linux/brcm2708/Makefile b/target/linux/brcm2708/Makefile
index 6d8aba0..f8c9347 100644
--- a/target/linux/brcm2708/Makefile
+++ b/target/linux/brcm2708/Makefile
@@ -26,6 +26,6 @@  define Target/Description
 	Currently produces SD Card image for Raspberry Pi.
 endef
 
-KERNELNAME:=Image
+KERNELNAME:=Image dtbs
 
 $(eval $(call BuildTarget))
diff --git a/target/linux/brcm2708/image/Makefile b/target/linux/brcm2708/image/Makefile
index de222f0..7a68c50 100644
--- a/target/linux/brcm2708/image/Makefile
+++ b/target/linux/brcm2708/image/Makefile
@@ -22,10 +22,6 @@  else
 endif
 
 ### Image scripts ###
-define Build/build-dtb
-	$(call Image/BuildDTB,$(DTS_DIR)/$(DEVICE_DTS).dts,$@.dtb)
-endef
-
 define Build/gen-cfg
 	cat config.txt > $@.config
 	echo -e "\ndevice_tree=$(DEVICE_DTS).dtb" >> $@.config
@@ -44,7 +40,7 @@  define Build/boot-img
 	mcopy -i $@.boot cmdline.txt ::
 	mcopy -i $@.boot $@.config ::config.txt
 	mcopy -i $@.boot $(word 1,$^) ::kernel.img
-	mcopy -i $@.boot $@.dtb ::$(DEVICE_DTS).dtb
+	mcopy -i $@.boot $(DTS_DIR)/$(DEVICE_DTS).dtb ::$(DEVICE_DTS).dtb
 endef
 
 define Build/sdcard-img
@@ -59,7 +55,7 @@  define Device/Default
   PROFILES = Default $$(DEVICE_PROFILE)
   KERNEL := kernel-bin
   IMAGES := sdcard.bin
-  IMAGE/sdcard.bin := build-dtb | gen-cfg | boot-img | sdcard-img
+  IMAGE/sdcard.bin := gen-cfg | boot-img | sdcard-img
   DEVICE_PROFILE :=
   DEVICE_DTS :=
 endef