diff mbox

[OpenWrt-Devel,1/1] Fix bridge-utils file offset handling

Message ID 1431395315-25301-1-git-send-email-mar.kolya@gmail.com
State Not Applicable
Headers show

Commit Message

Nikolay Martynov May 12, 2015, 1:48 a.m. UTC
Make sure brctl build uses appropriate defines (_FILE_OFFSET_BITS) that match uClibc settings.
Without this patch running brctl leads to 'unresolved alphasort symbol' message.

Signed-off-by: Nikolay Martynov <mar.kolya@gmail.com>
---
 net/bridge-utils/Makefile | 2 ++
 1 file changed, 2 insertions(+)

Comments

John Crispin May 22, 2015, 6:43 p.m. UTC | #1
Hi,

brigde-utils is part of the github feed. please file an issue there

	John

On 12/05/2015 03:48, Nikolay Martynov wrote:
> Make sure brctl build uses appropriate defines (_FILE_OFFSET_BITS) that match uClibc settings.
> Without this patch running brctl leads to 'unresolved alphasort symbol' message.
> 
> Signed-off-by: Nikolay Martynov <mar.kolya@gmail.com>
> ---
>  net/bridge-utils/Makefile | 2 ++
>  1 file changed, 2 insertions(+)
> 
> diff --git a/net/bridge-utils/Makefile b/net/bridge-utils/Makefile
> index ad95b87..10e44c5 100644
> --- a/net/bridge-utils/Makefile
> +++ b/net/bridge-utils/Makefile
> @@ -30,6 +30,8 @@ define Package/bridge/description
>   form a larger network.
>  endef
>  
> +TARGET_CPPFLAGS += -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64 -D_GNU_SOURCE
> +
>  CONFIGURE_ARGS += \
>  	--with-linux-headers="$(LINUX_DIR)" \
>  
>
Nikolay Martynov May 22, 2015, 9:01 p.m. UTC | #2
Hi.

  Thanks for you response!

  Please forgive my noobiness but I wasn't able to find brigde-utils
in https://github.com/openwrt/packages. Is it supposed to be somo
other feed? I would really appreciate if you could clarify.

Thanks.
Nikolay.

2015-05-22 14:43 GMT-04:00 John Crispin <blogic@openwrt.org>:
> Hi,
>
> brigde-utils is part of the github feed. please file an issue there
>
>         John
>
> On 12/05/2015 03:48, Nikolay Martynov wrote:
>> Make sure brctl build uses appropriate defines (_FILE_OFFSET_BITS) that match uClibc settings.
>> Without this patch running brctl leads to 'unresolved alphasort symbol' message.
>>
>> Signed-off-by: Nikolay Martynov <mar.kolya@gmail.com>
>> ---
>>  net/bridge-utils/Makefile | 2 ++
>>  1 file changed, 2 insertions(+)
>>
>> diff --git a/net/bridge-utils/Makefile b/net/bridge-utils/Makefile
>> index ad95b87..10e44c5 100644
>> --- a/net/bridge-utils/Makefile
>> +++ b/net/bridge-utils/Makefile
>> @@ -30,6 +30,8 @@ define Package/bridge/description
>>   form a larger network.
>>  endef
>>
>> +TARGET_CPPFLAGS += -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64 -D_GNU_SOURCE
>> +
>>  CONFIGURE_ARGS += \
>>       --with-linux-headers="$(LINUX_DIR)" \
>>
>>
> _______________________________________________
> openwrt-devel mailing list
> openwrt-devel@lists.openwrt.org
> https://lists.openwrt.org/cgi-bin/mailman/listinfo/openwrt-devel
Hauke Mehrtens May 23, 2015, 3:25 p.m. UTC | #3
On 05/22/2015 11:01 PM, Nikolay Martynov wrote:
> Hi.
> 
>   Thanks for you response!
> 
>   Please forgive my noobiness but I wasn't able to find brigde-utils
> in https://github.com/openwrt/packages. Is it supposed to be somo
> other feed? I would really appreciate if you could clarify.

brigde-utils was not moved from oldpackages to github. You can take over
the maintainership of that package and create a pull request on github
which adds it to the feed on github and also add your changes to it.
Then you have to take care of this package as it looks like nobody else
is interested in this package.

Hauke

> 
> 2015-05-22 14:43 GMT-04:00 John Crispin <blogic@openwrt.org>:
>> Hi,
>>
>> brigde-utils is part of the github feed. please file an issue there
>>
>>         John
>>
>> On 12/05/2015 03:48, Nikolay Martynov wrote:
>>> Make sure brctl build uses appropriate defines (_FILE_OFFSET_BITS) that match uClibc settings.
>>> Without this patch running brctl leads to 'unresolved alphasort symbol' message.
>>>
>>> Signed-off-by: Nikolay Martynov <mar.kolya@gmail.com>
>>> ---
>>>  net/bridge-utils/Makefile | 2 ++
>>>  1 file changed, 2 insertions(+)
>>>
>>> diff --git a/net/bridge-utils/Makefile b/net/bridge-utils/Makefile
>>> index ad95b87..10e44c5 100644
>>> --- a/net/bridge-utils/Makefile
>>> +++ b/net/bridge-utils/Makefile
>>> @@ -30,6 +30,8 @@ define Package/bridge/description
>>>   form a larger network.
>>>  endef
>>>
>>> +TARGET_CPPFLAGS += -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64 -D_GNU_SOURCE
>>> +
>>>  CONFIGURE_ARGS += \
>>>       --with-linux-headers="$(LINUX_DIR)" \
>>>
>>>
>> _______________________________________________
>> openwrt-devel mailing list
>> openwrt-devel@lists.openwrt.org
>> https://lists.openwrt.org/cgi-bin/mailman/listinfo/openwrt-devel
> 
> 
>
Russell Senior May 23, 2015, 4:41 p.m. UTC | #4
>>>>> "Nikolay" == Nikolay Martynov <mar.kolya@gmail.com> writes:

Nikolay> Hi.  Thanks for you response!

Nikolay>   Please forgive my noobiness but I wasn't able to find
Nikolay> brigde-utils in https://github.com/openwrt/packages. Is it
Nikolay> supposed to be somo other feed? I would really appreciate if
Nikolay> you could clarify.

John was wrong, afaict (as of the last time I sync'd up, which was a few
days ago).  In my tree, bridge-utils is in old-packages (unmaintained
stuff).  You can give it some CPR by moving it to the github packages
feed and becoming the maintainer!
diff mbox

Patch

diff --git a/net/bridge-utils/Makefile b/net/bridge-utils/Makefile
index ad95b87..10e44c5 100644
--- a/net/bridge-utils/Makefile
+++ b/net/bridge-utils/Makefile
@@ -30,6 +30,8 @@  define Package/bridge/description
  form a larger network.
 endef
 
+TARGET_CPPFLAGS += -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64 -D_GNU_SOURCE
+
 CONFIGURE_ARGS += \
 	--with-linux-headers="$(LINUX_DIR)" \