diff mbox

[OpenWrt-Devel] build: fix postinst generation for AutoProbe modules.

Message ID 1428670089-31756-1-git-send-email-yszhou4tech@gmail.com
State Accepted
Headers show

Commit Message

Yousong Zhou April 10, 2015, 12:48 p.m. UTC
Fixes ticket #19352.

Signed-off-by: Yousong Zhou <yszhou4tech@gmail.com>
---
This patch will help generate CONTROL/postinst file in the resulting .ipk file.
It was only compile tested and posted here just in case it can help CC rc1.

 include/kernel.mk |    2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

John Crispin April 11, 2015, 6:06 a.m. UTC | #1
Hi,

On 10/04/2015 14:48, Yousong Zhou wrote:
> Fixes ticket #19352.
> 
> Signed-off-by: Yousong Zhou <yszhou4tech@gmail.com>
> ---
> This patch will help generate CONTROL/postinst file in the resulting .ipk file.
> It was only compile tested and posted here just in case it can help CC rc1.
> 

thanks for pointing this out. r45367 hopefully fixes the problem

John
diff mbox

Patch

diff --git a/include/kernel.mk b/include/kernel.mk
index 700736f..cf8fb51 100644
--- a/include/kernel.mk
+++ b/include/kernel.mk
@@ -97,7 +97,7 @@  define ModuleAutoLoad
 				mkdir -p $(2)/etc/modules-boot.d; \
 				ln -s ../modules.d/$(1) $(2)/etc/modules-boot.d/; \
 			fi; \
-			modules="$$$$$$$${modules:+$$$$$$$$modules}"; \
+			modules="$$$$$$$${modules:+$$$$$$$$modules }$$$$$$$$mods"; \
 		fi; \
 	}; \
 	add_module() { \