diff mbox

[OpenWrt-Devel,1/4] kernel: enable AES-NI for x86

Message ID 1423663782-14771-2-git-send-email-uw@ocedo.com
State Superseded
Headers show

Commit Message

Ulrich Weber Feb. 11, 2015, 2:09 p.m. UTC
Signed-off-by: Ulrich Weber <uw@ocedo.com>
---
 package/kernel/linux/modules/crypto.mk | 13 ++++++++++---
 1 file changed, 10 insertions(+), 3 deletions(-)

Comments

Stijn Tintel Feb. 12, 2015, 3:15 p.m. UTC | #1
On 11-02-15 15:09, Ulrich Weber wrote:
> Signed-off-by: Ulrich Weber <uw@ocedo.com>
> ---
>  package/kernel/linux/modules/crypto.mk | 13 ++++++++++---
>  1 file changed, 10 insertions(+), 3 deletions(-)
>
> diff --git a/package/kernel/linux/modules/crypto.mk b/package/kernel/linux/modules/crypto.mk
> index 4df2d73..7fea3bf 100644
> --- a/package/kernel/linux/modules/crypto.mk
> +++ b/package/kernel/linux/modules/crypto.mk
> @@ -256,15 +256,22 @@ $(eval $(call KernelPackage,crypto-hw-omap))
>  
>  define KernelPackage/crypto-aes
>    TITLE:=AES cipher CryptoAPI module
> -  KCONFIG:=CONFIG_CRYPTO_AES CONFIG_CRYPTO_AES_586
> +  KCONFIG:=CONFIG_CRYPTO_AES CONFIG_CRYPTO_AES_586 CONFIG_CRYPTO_AES_NI_INTEL
>    FILES:=$(LINUX_DIR)/crypto/aes_generic.ko
>    AUTOLOAD:=$(call AutoLoad,09,aes_generic)
>    $(call AddDepends/crypto)
>  endef
>  
>  define KernelPackage/crypto-aes/x86
> -  FILES+=$(LINUX_DIR)/arch/x86/crypto/aes-i586.ko
> -  AUTOLOAD:=$(call AutoLoad,09,aes-i586)
> +  FILES+=$(LINUX_DIR)/arch/x86/crypto/aes-i586.ko \
> +	$(LINUX_DIR)/arch/x86/crypto/aesni-intel.ko \
> +	$(LINUX_DIR)/arch/x86/crypto/ablk_helper.ko \
> +	$(LINUX_DIR)/arch/x86/crypto/glue_helper.ko \
> +	$(LINUX_DIR)/crypto/cryptd.ko \
> +	$(LINUX_DIR)/crypto/gf128mul.ko \
> +	$(LINUX_DIR)/crypto/xts.ko \
gf128mul and xts are already packaged. Use DEPENDS instead.
Konsole output
> +	$(LINUX_DIR)/crypto/lrw.ko
> +  AUTOLOAD:=$(call AutoLoad,09,cryptd ablk_helper gf128mul xts lrw aes_generic aes-i586 aesni-intel)
>  endef
Remove them here as well.

Kind regards,
Stijn
diff mbox

Patch

diff --git a/package/kernel/linux/modules/crypto.mk b/package/kernel/linux/modules/crypto.mk
index 4df2d73..7fea3bf 100644
--- a/package/kernel/linux/modules/crypto.mk
+++ b/package/kernel/linux/modules/crypto.mk
@@ -256,15 +256,22 @@  $(eval $(call KernelPackage,crypto-hw-omap))
 
 define KernelPackage/crypto-aes
   TITLE:=AES cipher CryptoAPI module
-  KCONFIG:=CONFIG_CRYPTO_AES CONFIG_CRYPTO_AES_586
+  KCONFIG:=CONFIG_CRYPTO_AES CONFIG_CRYPTO_AES_586 CONFIG_CRYPTO_AES_NI_INTEL
   FILES:=$(LINUX_DIR)/crypto/aes_generic.ko
   AUTOLOAD:=$(call AutoLoad,09,aes_generic)
   $(call AddDepends/crypto)
 endef
 
 define KernelPackage/crypto-aes/x86
-  FILES+=$(LINUX_DIR)/arch/x86/crypto/aes-i586.ko
-  AUTOLOAD:=$(call AutoLoad,09,aes-i586)
+  FILES+=$(LINUX_DIR)/arch/x86/crypto/aes-i586.ko \
+	$(LINUX_DIR)/arch/x86/crypto/aesni-intel.ko \
+	$(LINUX_DIR)/arch/x86/crypto/ablk_helper.ko \
+	$(LINUX_DIR)/arch/x86/crypto/glue_helper.ko \
+	$(LINUX_DIR)/crypto/cryptd.ko \
+	$(LINUX_DIR)/crypto/gf128mul.ko \
+	$(LINUX_DIR)/crypto/xts.ko \
+	$(LINUX_DIR)/crypto/lrw.ko
+  AUTOLOAD:=$(call AutoLoad,09,cryptd ablk_helper gf128mul xts lrw aes_generic aes-i586 aesni-intel)
 endef
 
 $(eval $(call KernelPackage,crypto-aes))