diff mbox

[OpenWrt-Devel,8/9] mvebu: Add the Armada 385 Reference Design support

Message ID 1421164606-3222-9-git-send-email-maxime.ripard@free-electrons.com
State Not Applicable
Headers show

Commit Message

Maxime Ripard Jan. 13, 2015, 3:56 p.m. UTC
Signed-off-by: Maxime Ripard <maxime.ripard@free-electrons.com>
---
 target/linux/mvebu/image/Makefile                  |  1 +
 .../020-armada-385-rd-mtd-partitions.patch         | 24 ++++++++++++++++++++++
 2 files changed, 25 insertions(+)
 create mode 100644 target/linux/mvebu/patches-3.18/020-armada-385-rd-mtd-partitions.patch

Comments

Imre Kaloz Jan. 14, 2015, 11:50 a.m. UTC | #1
On Tue, 13 Jan 2015 16:56:45 +0100, Maxime Ripard
<maxime.ripard@free-electrons.com> wrote:

> ++					partition@2 {
> ++						label = "data";
> ++						reg = <0x600000 0xa00000>;
> ++					};
> + 				};
> + 			};
> +

This one should be called "rootfs". The image/Makefile change should be  
part of the UBI on NOR discussion/patch, so please make that one a  
separate.


Thanks,

Imre
Maxime Ripard Jan. 16, 2015, 3:23 p.m. UTC | #2
Hi Imre,

On Wed, Jan 14, 2015 at 12:50:55PM +0100, Imre Kaloz wrote:
> On Tue, 13 Jan 2015 16:56:45 +0100, Maxime Ripard
> <maxime.ripard@free-electrons.com> wrote:
> 
> >++					partition@2 {
> >++						label = "data";
> >++						reg = <0x600000 0xa00000>;
> >++					};
> >+ 				};
> >+ 			};
> >+
> 
> This one should be called "rootfs". The image/Makefile change should be part
> of the UBI on NOR discussion/patch, so please make that one a separate.

You mean a separate patch, right?

Separated from what? The rest of the serie? This patch is pretty
standalone by itself.

Maxime
Imre Kaloz Jan. 16, 2015, 3:38 p.m. UTC | #3
On Fri, 16 Jan 2015 16:23:43 +0100, Maxime Ripard  
<maxime.ripard@free-electrons.com> wrote:

> Hi Imre,
>
> On Wed, Jan 14, 2015 at 12:50:55PM +0100, Imre Kaloz wrote:
>> On Tue, 13 Jan 2015 16:56:45 +0100, Maxime Ripard
>> <maxime.ripard@free-electrons.com> wrote:
>>
>> >++					partition@2 {
>> >++						label = "data";
>> >++						reg = <0x600000 0xa00000>;
>> >++					};
>> >+ 				};
>> >+ 			};
>> >+
>>
>> This one should be called "rootfs". The image/Makefile change should be  
>> part
>> of the UBI on NOR discussion/patch, so please make that one a separate.
>
> You mean a separate patch, right?
>
> Separated from what? The rest of the serie? This patch is pretty
> standalone by itself.

Sorry, I wanted to say that one patch should add the partitions and  
another should be the image/Makefile change, given the first is likely to  
be upstreamed.


Imre
Maxime Ripard Jan. 16, 2015, 3:49 p.m. UTC | #4
On Fri, Jan 16, 2015 at 04:38:47PM +0100, Imre Kaloz wrote:
> On Fri, 16 Jan 2015 16:23:43 +0100, Maxime Ripard
> <maxime.ripard@free-electrons.com> wrote:
> 
> >Hi Imre,
> >
> >On Wed, Jan 14, 2015 at 12:50:55PM +0100, Imre Kaloz wrote:
> >>On Tue, 13 Jan 2015 16:56:45 +0100, Maxime Ripard
> >><maxime.ripard@free-electrons.com> wrote:
> >>
> >>>++					partition@2 {
> >>>++						label = "data";
> >>>++						reg = <0x600000 0xa00000>;
> >>>++					};
> >>>+ 				};
> >>>+ 			};
> >>>+
> >>
> >>This one should be called "rootfs". The image/Makefile change should be
> >>part
> >>of the UBI on NOR discussion/patch, so please make that one a separate.
> >
> >You mean a separate patch, right?
> >
> >Separated from what? The rest of the serie? This patch is pretty
> >standalone by itself.
> 
> Sorry, I wanted to say that one patch should add the partitions and another
> should be the image/Makefile change, given the first is likely to be
> upstreamed.

I don't really think it can. This kind of data is really setup
specific, and I'm not sure that the mainline kernel wants to enforce
any kind of policy there.

Maxime
Imre Kaloz Jan. 16, 2015, 3:56 p.m. UTC | #5
On Fri, 16 Jan 2015 16:52:05 +0100, Thomas Petazzoni  
<thomas.petazzoni@free-electrons.com> wrote:

> Dear Imre Kaloz,
>
> On Fri, 16 Jan 2015 16:38:47 +0100, Imre Kaloz wrote:
>
>> > Separated from what? The rest of the serie? This patch is pretty
>> > standalone by itself.
>>
>> Sorry, I wanted to say that one patch should add the partitions and
>> another should be the image/Makefile change, given the first is likely  
>> to
>> be upstreamed.
>
> I am not sure the specific partitioning used by OpenWRT is something we
> want to upstream in the mainline kernel. To me, the choice made by
> Maxime of having a separate kernel patch to do that is the right
> choice, since we're not sure we want to upstream specifically this
> partitioning in mainline.

Judging from the patch mainline has nothing defined, and if it ever will  
have, we'll end up patching that.. Anyways, if Maxime migrates this to the  
MTDSPLIT stuff, we'll have only "u-boot" and "firmware".


Imre
diff mbox

Patch

diff --git a/target/linux/mvebu/image/Makefile b/target/linux/mvebu/image/Makefile
index a10e1f052fbe..6d9b0afc0511 100644
--- a/target/linux/mvebu/image/Makefile
+++ b/target/linux/mvebu/image/Makefile
@@ -115,6 +115,7 @@  $(eval $(call NANDProfile,XP-GP,armada-xp-gp,512KiB,4096))
 $(eval $(call NANDProfile,Mamba,armada-xp-mamba,128KiB,2048,512))
 
 # Boards with NOR
+$(eval $(call NORProfile,385-RD,armada-385-rd,256KiB))
 $(eval $(call NORProfile,OpenBlocks-AX-3-4,armada-xp-openblocks-ax3-4,128KiB))
 
 define Image/Build/Profile/Mamba/squashfs
diff --git a/target/linux/mvebu/patches-3.18/020-armada-385-rd-mtd-partitions.patch b/target/linux/mvebu/patches-3.18/020-armada-385-rd-mtd-partitions.patch
new file mode 100644
index 000000000000..8a1eac449ffe
--- /dev/null
+++ b/target/linux/mvebu/patches-3.18/020-armada-385-rd-mtd-partitions.patch
@@ -0,0 +1,24 @@ 
+--- a/arch/arm/boot/dts/armada-385-rd.dts
++++ b/arch/arm/boot/dts/armada-385-rd.dts
+@@ -42,6 +42,21 @@
+ 					compatible = "st,m25p128";
+ 					reg = <0>; /* Chip select 0 */
+ 					spi-max-frequency = <108000000>;
++
++					partition@0 {
++						label = "uboot";
++						reg = <0 0x400000>;
++					};
++
++					partition@1 {
++						label = "kernel";
++						reg = <0x400000 0x200000>;
++					};
++
++					partition@2 {
++						label = "data";
++						reg = <0x600000 0xa00000>;
++					};
+ 				};
+ 			};
+