diff mbox series

[2/3] powerpc/ppc-opcode: Define and use PPC_RAW_TRAP() and PPC_RAW_TW()

Message ID 52c7e522e56a38e3ff0363906919445920005a8f.1657205708.git.christophe.leroy@csgroup.eu (mailing list archive)
State Accepted
Headers show
Series [1/3] powerpc/probes: Remove ppc_opcode_t | expand

Commit Message

Christophe Leroy July 7, 2022, 2:55 p.m. UTC
Add and use PPC_RAW_TRAP() instead of opencoding.

Signed-off-by: Christophe Leroy <christophe.leroy@csgroup.eu>
---
 arch/powerpc/include/asm/ppc-opcode.h | 2 ++
 arch/powerpc/include/asm/probes.h     | 3 ++-
 arch/powerpc/xmon/xmon.c              | 2 +-
 3 files changed, 5 insertions(+), 2 deletions(-)

Comments

Naveen N. Rao Aug. 3, 2022, 8:06 a.m. UTC | #1
Christophe Leroy wrote:
> Add and use PPC_RAW_TRAP() instead of opencoding.
> 
> Signed-off-by: Christophe Leroy <christophe.leroy@csgroup.eu>
> ---
>  arch/powerpc/include/asm/ppc-opcode.h | 2 ++
>  arch/powerpc/include/asm/probes.h     | 3 ++-
>  arch/powerpc/xmon/xmon.c              | 2 +-
>  3 files changed, 5 insertions(+), 2 deletions(-)
> 
> diff --git a/arch/powerpc/include/asm/ppc-opcode.h b/arch/powerpc/include/asm/ppc-opcode.h
> index 89beabf5325c..5527a955fb4a 100644
> --- a/arch/powerpc/include/asm/ppc-opcode.h
> +++ b/arch/powerpc/include/asm/ppc-opcode.h
> @@ -581,6 +581,8 @@
>  
>  #define PPC_RAW_BRANCH(offset)		(0x48000000 | PPC_LI(offset))
>  #define PPC_RAW_BL(offset)		(0x48000001 | PPC_LI(offset))
> +#define PPC_RAW_TW(t0, a, b)		(0x7f000008 | ___PPC_RS(t0) | ___PPC_RA(a) | ___PPC_RB(b))

Shouldn't that be 0x7c000008 ?

- Naveen


> +#define PPC_RAW_TRAP()			PPC_RAW_TW(31, 0, 0)
>  
>  /* Deal with instructions that older assemblers aren't aware of */
>  #define	PPC_BCCTR_FLUSH		stringify_in_c(.long PPC_INST_BCCTR_FLUSH)
> diff --git a/arch/powerpc/include/asm/probes.h b/arch/powerpc/include/asm/probes.h
> index 00634e3145e7..e77a2ed7d938 100644
> --- a/arch/powerpc/include/asm/probes.h
> +++ b/arch/powerpc/include/asm/probes.h
> @@ -9,8 +9,9 @@
>   */
>  #include <linux/types.h>
>  #include <asm/disassemble.h>
> +#include <asm/ppc-opcode.h>
>  
> -#define BREAKPOINT_INSTRUCTION	0x7fe00008	/* trap */
> +#define BREAKPOINT_INSTRUCTION	PPC_RAW_TRAP()	/* trap */
>  
>  /* Trap definitions per ISA */
>  #define IS_TW(instr)		(((instr) & 0xfc0007fe) == 0x7c000008)
> diff --git a/arch/powerpc/xmon/xmon.c b/arch/powerpc/xmon/xmon.c
> index f80c714f1d49..26ef3388c24c 100644
> --- a/arch/powerpc/xmon/xmon.c
> +++ b/arch/powerpc/xmon/xmon.c
> @@ -116,7 +116,7 @@ struct bpt {
>  static struct bpt bpts[NBPTS];
>  static struct bpt dabr[HBP_NUM_MAX];
>  static struct bpt *iabr;
> -static unsigned bpinstr = 0x7fe00008;	/* trap */
> +static unsigned int bpinstr = PPC_RAW_TRAP();
>  
>  #define BP_NUM(bp)	((bp) - bpts + 1)
>  
> -- 
> 2.36.1
> 
> 
>
Michael Ellerman Aug. 3, 2022, 10:38 a.m. UTC | #2
"Naveen N. Rao" <naveen.n.rao@linux.ibm.com> writes:
> Christophe Leroy wrote:
>> Add and use PPC_RAW_TRAP() instead of opencoding.
>> 
>> Signed-off-by: Christophe Leroy <christophe.leroy@csgroup.eu>
>> ---
>>  arch/powerpc/include/asm/ppc-opcode.h | 2 ++
>>  arch/powerpc/include/asm/probes.h     | 3 ++-
>>  arch/powerpc/xmon/xmon.c              | 2 +-
>>  3 files changed, 5 insertions(+), 2 deletions(-)
>> 
>> diff --git a/arch/powerpc/include/asm/ppc-opcode.h b/arch/powerpc/include/asm/ppc-opcode.h
>> index 89beabf5325c..5527a955fb4a 100644
>> --- a/arch/powerpc/include/asm/ppc-opcode.h
>> +++ b/arch/powerpc/include/asm/ppc-opcode.h
>> @@ -581,6 +581,8 @@
>>  
>>  #define PPC_RAW_BRANCH(offset)		(0x48000000 | PPC_LI(offset))
>>  #define PPC_RAW_BL(offset)		(0x48000001 | PPC_LI(offset))
>> +#define PPC_RAW_TW(t0, a, b)		(0x7f000008 | ___PPC_RS(t0) | ___PPC_RA(a) | ___PPC_RB(b))
>
> Shouldn't that be 0x7c000008 ?

Yes, my script agrees.

https://github.com/mpe/misc-scripts/blob/master/ppc/ppc-instruction-encode

$ ./ppc-instruction-encode 0:31 6:t0 11:ra 16:rb 21:4 31:
.long 0x7c000008
t0 << 21
ra << 16
rb << 11


I guess the only user is PPC_RAW_TRAP() which passes t0 = 31, so that's
why nothing has broken.

Send a fixup? :)

cheers
diff mbox series

Patch

diff --git a/arch/powerpc/include/asm/ppc-opcode.h b/arch/powerpc/include/asm/ppc-opcode.h
index 89beabf5325c..5527a955fb4a 100644
--- a/arch/powerpc/include/asm/ppc-opcode.h
+++ b/arch/powerpc/include/asm/ppc-opcode.h
@@ -581,6 +581,8 @@ 
 
 #define PPC_RAW_BRANCH(offset)		(0x48000000 | PPC_LI(offset))
 #define PPC_RAW_BL(offset)		(0x48000001 | PPC_LI(offset))
+#define PPC_RAW_TW(t0, a, b)		(0x7f000008 | ___PPC_RS(t0) | ___PPC_RA(a) | ___PPC_RB(b))
+#define PPC_RAW_TRAP()			PPC_RAW_TW(31, 0, 0)
 
 /* Deal with instructions that older assemblers aren't aware of */
 #define	PPC_BCCTR_FLUSH		stringify_in_c(.long PPC_INST_BCCTR_FLUSH)
diff --git a/arch/powerpc/include/asm/probes.h b/arch/powerpc/include/asm/probes.h
index 00634e3145e7..e77a2ed7d938 100644
--- a/arch/powerpc/include/asm/probes.h
+++ b/arch/powerpc/include/asm/probes.h
@@ -9,8 +9,9 @@ 
  */
 #include <linux/types.h>
 #include <asm/disassemble.h>
+#include <asm/ppc-opcode.h>
 
-#define BREAKPOINT_INSTRUCTION	0x7fe00008	/* trap */
+#define BREAKPOINT_INSTRUCTION	PPC_RAW_TRAP()	/* trap */
 
 /* Trap definitions per ISA */
 #define IS_TW(instr)		(((instr) & 0xfc0007fe) == 0x7c000008)
diff --git a/arch/powerpc/xmon/xmon.c b/arch/powerpc/xmon/xmon.c
index f80c714f1d49..26ef3388c24c 100644
--- a/arch/powerpc/xmon/xmon.c
+++ b/arch/powerpc/xmon/xmon.c
@@ -116,7 +116,7 @@  struct bpt {
 static struct bpt bpts[NBPTS];
 static struct bpt dabr[HBP_NUM_MAX];
 static struct bpt *iabr;
-static unsigned bpinstr = 0x7fe00008;	/* trap */
+static unsigned int bpinstr = PPC_RAW_TRAP();
 
 #define BP_NUM(bp)	((bp) - bpts + 1)