diff mbox series

i2c: mux: demux-pinctrl: use struct_size() in devm_kzalloc()

Message ID 20190104174327.GA30932@embeddedor
State Accepted
Delegated to: Peter Rosin
Headers show
Series i2c: mux: demux-pinctrl: use struct_size() in devm_kzalloc() | expand

Commit Message

Gustavo A. R. Silva Jan. 4, 2019, 5:43 p.m. UTC
One of the more common cases of allocation size calculations is finding
the size of a structure that has a zero-sized array at the end, along
with memory for some number of elements for that array. For example:

struct foo {
    int stuff;
    void *entry[];
};

instance = devm_kzalloc(dev, sizeof(struct foo) + sizeof(void *) * count, GFP_KERNEL);

Instead of leaving these open-coded and prone to type mistakes, we can
now use the new struct_size() helper:

instance = devm_kzalloc(dev, struct_size(instance, entry, count), GFP_KERNEL);

This code was detected with the help of Coccinelle.

Signed-off-by: Gustavo A. R. Silva <gustavo@embeddedor.com>
---
 drivers/i2c/muxes/i2c-demux-pinctrl.c | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

Comments

Wolfram Sang Jan. 4, 2019, 6:06 p.m. UTC | #1
> Instead of leaving these open-coded and prone to type mistakes, we can
> now use the new struct_size() helper:

I am okay with this patch in general. However, I think the name of the
helper 'struct_size' is a bit unfortunate. I really wondered on the
first read why it needs 3 arguments to find out a struct size. I only
understood on the second read. I think 'trailing_array_struct_size'
would be way more clearer what it does.
Peter Rosin April 21, 2019, 6:15 p.m. UTC | #2
On 2019-01-04 19:06, Wolfram Sang wrote:
> 
>> Instead of leaving these open-coded and prone to type mistakes, we can
>> now use the new struct_size() helper:
> 
> I am okay with this patch in general. However, I think the name of the
> helper 'struct_size' is a bit unfortunate. I really wondered on the
> first read why it needs 3 arguments to find out a struct size. I only
> understood on the second read. I think 'trailing_array_struct_size'
> would be way more clearer what it does.

I read that as an Acked-by... :-)

Cheers,
Peter
Wolfram Sang April 22, 2019, 7:20 a.m. UTC | #3
On Sun, Apr 21, 2019 at 06:15:21PM +0000, Peter Rosin wrote:
> On 2019-01-04 19:06, Wolfram Sang wrote:
> > 
> >> Instead of leaving these open-coded and prone to type mistakes, we can
> >> now use the new struct_size() helper:
> > 
> > I am okay with this patch in general. However, I think the name of the
> > helper 'struct_size' is a bit unfortunate. I really wondered on the
> > first read why it needs 3 arguments to find out a struct size. I only
> > understood on the second read. I think 'trailing_array_struct_size'
> > would be way more clearer what it does.
> 
> I read that as an Acked-by... :-)

For this patch, yes. Thanks!
diff mbox series

Patch

diff --git a/drivers/i2c/muxes/i2c-demux-pinctrl.c b/drivers/i2c/muxes/i2c-demux-pinctrl.c
index 035032e20327..012b45e447c3 100644
--- a/drivers/i2c/muxes/i2c-demux-pinctrl.c
+++ b/drivers/i2c/muxes/i2c-demux-pinctrl.c
@@ -219,8 +219,8 @@  static int i2c_demux_pinctrl_probe(struct platform_device *pdev)
 		return -EINVAL;
 	}
 
-	priv = devm_kzalloc(&pdev->dev, sizeof(*priv)
-			   + num_chan * sizeof(struct i2c_demux_pinctrl_chan), GFP_KERNEL);
+	priv = devm_kzalloc(&pdev->dev, struct_size(priv, chan, num_chan),
+			    GFP_KERNEL);
 
 	props = devm_kcalloc(&pdev->dev, num_chan, sizeof(*props), GFP_KERNEL);