diff mbox

uclibc: re-add uclibc-update-config target

Message ID ffb59038c33cd78676d8.1398885537@argentina
State Accepted
Commit be6a575d2c20a01cf3a6dbb569acfa886f0190f1
Headers show

Commit Message

Thomas De Schampheleire April 30, 2014, 7:18 p.m. UTC
Commit a5e92d92e7ee413157aae7cecf1f354e718731e1 converted uClibc to the
package infrastructure, but while doing so removed support for the
documented uclibc-update-config make target. This make target copies the
uclibc .config file back to the original (typically version-controlled)
configuration file.

As this was an unintentional removal, this patch re-adds the
uclibc-update-config target.

Reported-by: Dan Moulding <dan.moulding@rackwareinc.com>
Signed-off-by: Thomas De Schampheleire <thomas.de.schampheleire@gmail.com>

---
 package/uclibc/uclibc.mk |  5 ++++-
 1 files changed, 4 insertions(+), 1 deletions(-)


Note: while I was at it, I fixed a small typo in uclibc.mk

Comments

Peter Korsgaard May 1, 2014, 9:36 p.m. UTC | #1
>>>>> "Thomas" == Thomas De Schampheleire <patrickdepinguin@gmail.com> writes:

 > Commit a5e92d92e7ee413157aae7cecf1f354e718731e1 converted uClibc to the
 > package infrastructure, but while doing so removed support for the
 > documented uclibc-update-config make target. This make target copies the
 > uclibc .config file back to the original (typically version-controlled)
 > configuration file.

 > As this was an unintentional removal, this patch re-adds the
 > uclibc-update-config target.

 > Reported-by: Dan Moulding <dan.moulding@rackwareinc.com>
 > Signed-off-by: Thomas De Schampheleire <thomas.de.schampheleire@gmail.com>

Committed, thanks.
diff mbox

Patch

diff --git a/package/uclibc/uclibc.mk b/package/uclibc/uclibc.mk
--- a/package/uclibc/uclibc.mk
+++ b/package/uclibc/uclibc.mk
@@ -211,7 +211,7 @@  endef
 endif
 
 #
-# Endianess
+# Endianness
 #
 
 ifeq ($(call qstrip,$(BR2_ENDIAN)),BIG)
@@ -553,5 +553,8 @@  uclibc-menuconfig: uclibc-patch
 
 $(eval $(generic-package))
 
+uclibc-update-config: $(UCLIBC_DIR)/.stamp_configured
+	cp -f $(UCLIBC_DIR)/.config $(UCLIBC_CONFIG_FILE)
+
 # Before uClibc is built, we must have the second stage cross-compiler
 $(UCLIBC_TARGET_BUILD): | host-gcc-intermediate