diff mbox

Analysis of autobuild failures 18-19/11

Message ID e255545b-031a-486d-1203-5e4220ec9280@mind.be
State Not Applicable
Headers show

Commit Message

Arnout Vandecappelle Nov. 23, 2016, 12:06 p.m. UTC
On 23-11-16 12:37, Waldemar Brodkorb wrote:
> Hi Arnout,
> Arnout Vandecappelle wrote,
> 
>> On 21-11-16 12:21, Waldemar Brodkorb wrote:
[snip]
>>> With gcc -fno-dwarf2-cfi-asm we can disable the CFI generation and
>>> at least fix the compile errors for those packages.
>>>  
>>> Not sure if it will break some exception handling in C++ code or if
>>> it only disables the ability to debug the code.
>>
>>  If it doesn't break things (and you can do runtime test, right?), maybe we
>> should just pass -fno-dwarf2-cfi-asm in the wrapper for coldfire?
> 
> I don't know the internals of the wrapper, could you suggest a
> patch, then I can do some testing with either Qemu or some real
> board.

 First apply http://patchwork.ozlabs.org/patch/683830/, then try this
(completely untested, of course):


---

 Regards,
 Arnout

Comments

Waldemar Brodkorb Nov. 25, 2016, 12:26 a.m. UTC | #1
Hi Arnout,
Arnout Vandecappelle wrote,

> 
> 
> On 23-11-16 12:37, Waldemar Brodkorb wrote:
> > Hi Arnout,
> > Arnout Vandecappelle wrote,
> > 
> >> On 21-11-16 12:21, Waldemar Brodkorb wrote:
> [snip]
> >>> With gcc -fno-dwarf2-cfi-asm we can disable the CFI generation and
> >>> at least fix the compile errors for those packages.
> >>>  
> >>> Not sure if it will break some exception handling in C++ code or if
> >>> it only disables the ability to debug the code.
> >>
> >>  If it doesn't break things (and you can do runtime test, right?), maybe we
> >> should just pass -fno-dwarf2-cfi-asm in the wrapper for coldfire?
> > 
> > I don't know the internals of the wrapper, could you suggest a
> > patch, then I can do some testing with either Qemu or some real
> > board.
> 
>  First apply http://patchwork.ozlabs.org/patch/683830/, then try this
> (completely untested, of course):
> 
> 
> diff --git a/toolchain/toolchain-wrapper.mk b/toolchain/toolchain-wrapper.mk
> index 88f743e..5dd8fb7 100644
> --- a/toolchain/toolchain-wrapper.mk
> +++ b/toolchain/toolchain-wrapper.mk
> @@ -11,6 +11,11 @@ endif
> 
>  TARGET_FLAGS += $(call qstrip,$(BR2_TARGET_OPTIMIZATION))
> 
> +# Internal error, aborting at dw2gencfi.c:214 in emit_expr_encoded
> +ifeq ($(BR2_m68k_cf),y)
> +TARGET_FLAGS += -fno-dwarf2-cfi-asm
> +endif
> +
>  TOOLCHAIN_WRAPPER_ARGS = $($(PKG)_TOOLCHAIN_WRAPPER_ARGS)
>  TOOLCHAIN_WRAPPER_ARGS += -DBR_SYSROOT='"$(STAGING_SUBDIR)"'
> 

Tested with various C++ apps in Qemu/m68k and didn't find a problem.
This would fix all the remaining m68k/coldfire autobuild failures we
have seen so far.

best regards
 Waldemar
diff mbox

Patch

diff --git a/toolchain/toolchain-wrapper.mk b/toolchain/toolchain-wrapper.mk
index 88f743e..5dd8fb7 100644
--- a/toolchain/toolchain-wrapper.mk
+++ b/toolchain/toolchain-wrapper.mk
@@ -11,6 +11,11 @@  endif

 TARGET_FLAGS += $(call qstrip,$(BR2_TARGET_OPTIMIZATION))

+# Internal error, aborting at dw2gencfi.c:214 in emit_expr_encoded
+ifeq ($(BR2_m68k_cf),y)
+TARGET_FLAGS += -fno-dwarf2-cfi-asm
+endif
+
 TOOLCHAIN_WRAPPER_ARGS = $($(PKG)_TOOLCHAIN_WRAPPER_ARGS)
 TOOLCHAIN_WRAPPER_ARGS += -DBR_SYSROOT='"$(STAGING_SUBDIR)"'