diff mbox series

package/iperf3: bump to version 3.8.1

Message ID d3ba56c5fb5b641d8817ff90b19e575288fb5333.1591939941.git.baruch@tkos.co.il
State Accepted
Headers show
Series package/iperf3: bump to version 3.8.1 | expand

Commit Message

Baruch Siach June 12, 2020, 5:32 a.m. UTC
Don't pass --disable-profiling, profiling is now disabled by default.
For some reason adding --disable-profiling makes it enabled.

Update LICENSE hash; copyright year update.

Cc: Matt Weber <matthew.weber@rockwellcollins.com>
Signed-off-by: Baruch Siach <baruch@tkos.co.il>
---
 package/iperf3/iperf3.hash | 6 +++---
 package/iperf3/iperf3.mk   | 4 +---
 2 files changed, 4 insertions(+), 6 deletions(-)

Comments

Thomas Petazzoni June 18, 2020, 7:55 p.m. UTC | #1
On Fri, 12 Jun 2020 08:32:21 +0300
Baruch Siach <baruch@tkos.co.il> wrote:

> Don't pass --disable-profiling, profiling is now disabled by default.
> For some reason adding --disable-profiling makes it enabled.

That's because they don't use AC_ARG_ENABLE correctly:

# Check if enable profiling
AC_ARG_ENABLE([profiling],
    AS_HELP_STRING([--enable-profiling], [Enable iperf3 profiling binary]),
    [enable_profiling=yes],
    [:])
AM_CONDITIONAL([ENABLE_PROFILING], [test x$enable_profiling = xyes])

The [enable_profiling=yes] should be [enable_profiling=$enableval]

This is a common mistake. Many people think AC_ARG_ENABLE arguments are:

 - option name
 - option help
 - what gets executed if option is enabled
 - what gets executed if option is disabled

But in fact, the arguments of AC_ARG_ENABLE are:

 - option name
 - option help
 - what gets executed if option is passed, regardless of whether it is
   enabled or disabled. The value is in $enableval
 - what gets executed if no value is passed at all (i.e neither
   --enable nor --disable are passed)

So, I've slightly reworked the commit log and applied. Thanks!

Thomas
diff mbox series

Patch

diff --git a/package/iperf3/iperf3.hash b/package/iperf3/iperf3.hash
index 2e6cfd5ab93d..5f1c200f55db 100644
--- a/package/iperf3/iperf3.hash
+++ b/package/iperf3/iperf3.hash
@@ -1,4 +1,4 @@ 
-# From https://downloads.es.net/pub/iperf/iperf-3.7.tar.gz.sha256
-sha256	d846040224317caf2f75c843d309a950a7db23f9b44b94688ccbe557d6d1710c  iperf-3.7.tar.gz
+# From https://downloads.es.net/pub/iperf/iperf-3.8.1.tar.gz.sha256
+sha256	e5b080f3273a8a715a4100f13826ac2ca31cc7b1315925631b2ecf64957ded96  iperf-3.8.1.tar.gz
 # Locally computed
-sha256	ee58f1e69139d39cfb055df15fe84453a379936dd45e44dbebf26c78afa3f5d4  LICENSE
+sha256	9ef73096bdd5209dd979bfa1fec70aeb42a7255d2df3aec423642aa92d5e9f40  LICENSE
diff --git a/package/iperf3/iperf3.mk b/package/iperf3/iperf3.mk
index 3537b23824a8..7d5a10cdef46 100644
--- a/package/iperf3/iperf3.mk
+++ b/package/iperf3/iperf3.mk
@@ -4,7 +4,7 @@ 
 #
 ################################################################################
 
-IPERF3_VERSION = 3.7
+IPERF3_VERSION = 3.8.1
 IPERF3_SITE = https://downloads.es.net/pub/iperf
 IPERF3_SOURCE = iperf-$(IPERF3_VERSION).tar.gz
 IPERF3_LICENSE = BSD-3-Clause, BSD-2-Clause, MIT
@@ -12,8 +12,6 @@  IPERF3_LICENSE_FILES = LICENSE
 
 IPERF3_CONF_ENV += CFLAGS="$(TARGET_CFLAGS) -D_GNU_SOURCE"
 
-IPERF3_CONF_OPTS += --disable-profiling
-
 ifeq ($(BR2_PACKAGE_OPENSSL),y)
 # We intentionally don't pass --with-openssl, otherwise pkg-config is
 # not used, and indirect libraries are not picked up when static