diff mbox

[2,of,2] fs/tar: use qstrip to clean up build output

Message ID cda34eac2826e87dffc2.1400762141@argentina
State Accepted
Commit e5512dfc493817cdcb57ef2fe0c856c31fc5f847
Headers show

Commit Message

Thomas De Schampheleire May 22, 2014, 12:35 p.m. UTC
When using the tar filesystem method, the build output shows at the end:

echo " tar -c""f <br>/output/images/rootfs.tar -C <br>/output/target ." >>
                                    <br>/output/build/_fakeroot.fs

The inner set of quotes can be easily removed by properly stripping the tar
options (coming from the buildroot configuration).

Signed-off-by: Thomas De Schampheleire <thomas.de.schampheleire@gmail.com>

---
 fs/tar/tar.mk |  2 +-
 1 files changed, 1 insertions(+), 1 deletions(-)

Comments

Romain Naour May 22, 2014, 10:30 p.m. UTC | #1
Hi Thomas,

Le 22/05/2014 14:35, Thomas De Schampheleire a écrit :
> When using the tar filesystem method, the build output shows at the end:
> 
> echo " tar -c""f <br>/output/images/rootfs.tar -C <br>/output/target ." >>
>                                     <br>/output/build/_fakeroot.fs
> 
> The inner set of quotes can be easily removed by properly stripping the tar
> options (coming from the buildroot configuration).
> 
> Signed-off-by: Thomas De Schampheleire <thomas.de.schampheleire@gmail.com>

Acked-by: Romain Naour <romain.naour@openwide.fr>

Thanks
Romain

> 
> ---
>  fs/tar/tar.mk |  2 +-
>  1 files changed, 1 insertions(+), 1 deletions(-)
> 
> diff --git a/fs/tar/tar.mk b/fs/tar/tar.mk
> --- a/fs/tar/tar.mk
> +++ b/fs/tar/tar.mk
> @@ -4,7 +4,7 @@
>  #
>  ################################################################################
>  
> -TAR_OPTS := $(BR2_TARGET_ROOTFS_TAR_OPTIONS)
> +TAR_OPTS := $(call qstrip,$(BR2_TARGET_ROOTFS_TAR_OPTIONS))
>  
>  define ROOTFS_TAR_CMD
>   tar -c$(TAR_OPTS)f $@ -C $(TARGET_DIR) .
> _______________________________________________
> buildroot mailing list
> buildroot@busybox.net
> http://lists.busybox.net/mailman/listinfo/buildroot
>
Peter Korsgaard May 28, 2014, 8:04 p.m. UTC | #2
>>>>> "Thomas" == Thomas De Schampheleire <patrickdepinguin@gmail.com> writes:

 > When using the tar filesystem method, the build output shows at the end:
 > echo " tar -c""f <br>/output/images/rootfs.tar -C <br>/output/target ." >>
 >                                     <br>/output/build/_fakeroot.fs

 > The inner set of quotes can be easily removed by properly stripping the tar
 > options (coming from the buildroot configuration).

 > Signed-off-by: Thomas De Schampheleire <thomas.de.schampheleire@gmail.com>

Committed, thanks.
diff mbox

Patch

diff --git a/fs/tar/tar.mk b/fs/tar/tar.mk
--- a/fs/tar/tar.mk
+++ b/fs/tar/tar.mk
@@ -4,7 +4,7 @@ 
 #
 ################################################################################
 
-TAR_OPTS := $(BR2_TARGET_ROOTFS_TAR_OPTIONS)
+TAR_OPTS := $(call qstrip,$(BR2_TARGET_ROOTFS_TAR_OPTIONS))
 
 define ROOTFS_TAR_CMD
  tar -c$(TAR_OPTS)f $@ -C $(TARGET_DIR) .