diff mbox

libpcap: omit -rpath from pcap-config

Message ID c33c2710ceee7a99051fe39f96e8480b6440fa79.1414738768.git.baruch@tkos.co.il
State Accepted
Commit be995fbb403653336b5929adcd6e90b1ebbbe604
Headers show

Commit Message

Baruch Siach Oct. 31, 2014, 6:59 a.m. UTC
For target processes the libraries are always in their usual location under
/lib and /usr/lib. It doesn't make sense to add RPATH tag pointing to host
build directory to programs using libpcap. This commit changes V_RPATH_OPT in
pcap-config to remove -rpath from its output.

Signed-off-by: Baruch Siach <baruch@tkos.co.il>
---
 package/libpcap/libpcap.mk | 6 ++++++
 1 file changed, 6 insertions(+)

Comments

Peter Korsgaard Oct. 31, 2014, 3:20 p.m. UTC | #1
>>>>> "Baruch" == Baruch Siach <baruch@tkos.co.il> writes:

 > For target processes the libraries are always in their usual location under
 > /lib and /usr/lib. It doesn't make sense to add RPATH tag pointing to host
 > build directory to programs using libpcap. This commit changes V_RPATH_OPT in
 > pcap-config to remove -rpath from its output.

 > Signed-off-by: Baruch Siach <baruch@tkos.co.il>

Committed, thanks.
diff mbox

Patch

diff --git a/package/libpcap/libpcap.mk b/package/libpcap/libpcap.mk
index 6126a86a64e6..bcc83edf714e 100644
--- a/package/libpcap/libpcap.mk
+++ b/package/libpcap/libpcap.mk
@@ -20,6 +20,12 @@  LIBPCAP_CFLAGS = $(TARGET_CFLAGS)
 LIBPCAP_CONF_OPTS = --disable-yydebug --with-pcap=linux
 LIBPCAP_CONFIG_SCRIPTS = pcap-config
 
+# Omit -rpath from pcap-config output
+define LIBPCAP_CONFIG_REMOVE_RPATH
+	$(SED) 's/^V_RPATH_OPT=.*/V_RPATH_OPT=""/g' $(@D)/pcap-config
+endef
+LIBPCAP_POST_BUILD_HOOKS = LIBPCAP_CONFIG_REMOVE_RPATH
+
 # On purpose, not compatible with bluez5
 ifeq ($(BR2_PACKAGE_BLUEZ_UTILS),y)
 LIBPCAP_DEPENDENCIES += bluez_utils