diff mbox series

pulseaudio: remove the ConsoleKit module

Message ID b7568fe9d9659520356ec09c58908edd27656a03.1513696352.git.baruch@tkos.co.il
State Accepted
Commit 64dab3c67256e5373eaf4d5e5d6f3f29602b6587
Headers show
Series pulseaudio: remove the ConsoleKit module | expand

Commit Message

Baruch Siach Dec. 19, 2017, 3:12 p.m. UTC
The ConsoleKit module is loaded by default from the default.pa
configuration file, but its initialization fails because Buildroot has
no ConsoleKit package yet. This breaks per-user pulseaudio daemon.
The default.pa configuration load module-console-kit only when it
exists. Remove module-console-kit to fix pulseaudio per-user startup.

Signed-off-by: Baruch Siach <baruch@tkos.co.il>
---
 package/pulseaudio/pulseaudio.mk | 8 +++++++-
 1 file changed, 7 insertions(+), 1 deletion(-)

Comments

Peter Korsgaard Dec. 19, 2017, 8:46 p.m. UTC | #1
>>>>> "Baruch" == Baruch Siach <baruch@tkos.co.il> writes:

 > The ConsoleKit module is loaded by default from the default.pa
 > configuration file, but its initialization fails because Buildroot has
 > no ConsoleKit package yet. This breaks per-user pulseaudio daemon.
 > The default.pa configuration load module-console-kit only when it
 > exists. Remove module-console-kit to fix pulseaudio per-user startup.

 > Signed-off-by: Baruch Siach <baruch@tkos.co.il>

Committed, thanks.
Peter Korsgaard Dec. 27, 2017, 10:29 p.m. UTC | #2
>>>>> "Baruch" == Baruch Siach <baruch@tkos.co.il> writes:

 > The ConsoleKit module is loaded by default from the default.pa
 > configuration file, but its initialization fails because Buildroot has
 > no ConsoleKit package yet. This breaks per-user pulseaudio daemon.
 > The default.pa configuration load module-console-kit only when it
 > exists. Remove module-console-kit to fix pulseaudio per-user startup.

 > Signed-off-by: Baruch Siach <baruch@tkos.co.il>

Committed to 2017.11.x, thanks.
diff mbox series

Patch

diff --git a/package/pulseaudio/pulseaudio.mk b/package/pulseaudio/pulseaudio.mk
index b021fc93a4dd..a30d5401bae2 100644
--- a/package/pulseaudio/pulseaudio.mk
+++ b/package/pulseaudio/pulseaudio.mk
@@ -140,11 +140,17 @@  else
 PULSEAUDIO_CONF_OPTS += --disable-x11
 endif
 
+# ConsoleKit module init failure breaks user daemon startup
+define PULSEAUDIO_REMOVE_CONSOLE_KIT
+	rm -f $(TARGET_DIR)/usr/lib/pulse-$(PULSEAUDIO_VERSION)/modules/module-console-kit.so
+endef
+
 define PULSEAUDIO_REMOVE_VALA
 	rm -rf $(TARGET_DIR)/usr/share/vala
 endef
 
-PULSEAUDIO_POST_INSTALL_TARGET_HOOKS += PULSEAUDIO_REMOVE_VALA
+PULSEAUDIO_POST_INSTALL_TARGET_HOOKS += PULSEAUDIO_REMOVE_VALA \
+	PULSEAUDIO_REMOVE_CONSOLE_KIT
 
 ifeq ($(BR2_PACKAGE_PULSEAUDIO_DAEMON),y)
 define PULSEAUDIO_USERS