diff mbox series

[1/1] package/intel-socfpga-hwlib: add new package

Message ID abcd4153-41e2-45ce-a89a-e198e86ba337@clermont.in2p3.fr
State Superseded
Headers show
Series [1/1] package/intel-socfpga-hwlib: add new package | expand

Commit Message

David Picard Feb. 14, 2024, 9:32 a.m. UTC
Add a package for the Intel/Altera SoC FPGA hardware library. It is
used to let the HPS and the FPGA fabric communicate with each other.

Signed-off-by: David Picard <david.picard@clermont.in2p3.fr>
---
package/Config.in | 1 +
package/intel-socfpga-hwlib/Config.in | 12 ++++++
.../intel-socfpga-hwlib.hash | 2 +
.../intel-socfpga-hwlib.mk | 39 +++++++++++++++++++
4 files changed, 54 insertions(+)
create mode 100644 package/intel-socfpga-hwlib/Config.in
create mode 100644 package/intel-socfpga-hwlib/intel-socfpga-hwlib.hash
create mode 100644 package/intel-socfpga-hwlib/intel-socfpga-hwlib.mk

+
+$(eval $(generic-package))
diff mbox series

Patch

diff --git a/package/Config.in b/package/Config.in
index bf0fe078b9..cd6c6bcaba 100644
--- a/package/Config.in
+++ b/package/Config.in
@@ -1736,6 +1736,7 @@  menu "Hardware handling"
source "package/gnu-efi/Config.in"
source "package/hackrf/Config.in"
source "package/hidapi/Config.in"
+ source "package/intel-socfpga-hwlib/Config.in"
source "package/jitterentropy-library/Config.in"
source "package/lcdapi/Config.in"
source "package/let-me-create/Config.in"
diff --git a/package/intel-socfpga-hwlib/Config.in 
b/package/intel-socfpga-hwlib/Config.in
new file mode 100644
index 0000000000..ced6483a59
--- /dev/null
+++ b/package/intel-socfpga-hwlib/Config.in
@@ -0,0 +1,12 @@ 
+config BR2_PACKAGE_INTEL_SOCFPGA_HWLIB
+ bool "intel-socfpga-hwlib"
+ depends on BR2_arm
+ help
+ This package provides the Intel SoC FPGA HWLIB for
+ Intel/Altera SoC FPGA chips.
+ This library allows to communicate with the FPGA fabric from
+ Linux, running on the HPS device.
+ The source code is not compiled. Instead, a symlink is added
+ to $(STAGING_DIR)/lib.
+
+ https://github.com/altera-opensource/intel-socfpga-hwlib
diff --git a/package/intel-socfpga-hwlib/intel-socfpga-hwlib.hash 
b/package/intel-socfpga-hwlib/intel-socfpga-hwlib.hash
new file mode 100644
index 0000000000..60efe9013e
--- /dev/null
+++ b/package/intel-socfpga-hwlib/intel-socfpga-hwlib.hash
@@ -0,0 +1,2 @@ 
+sha256 bbf0767facfdf18ca3dbead66b1e98090c4e9731e2b87cf35c3bf13db0c315e4 
intel-socfpga-hwlib-23.12.02.tar.gz
+sha256 2ed04f9cc773f88c8d52c05c04bb3d28f376c082bf99b6a3cb5590b1627ad484 
License.txt
diff --git a/package/intel-socfpga-hwlib/intel-socfpga-hwlib.mk 
b/package/intel-socfpga-hwlib/intel-socfpga-hwlib.mk
new file mode 100644
index 0000000000..bf18c23560
--- /dev/null
+++ b/package/intel-socfpga-hwlib/intel-socfpga-hwlib.mk
@@ -0,0 +1,39 @@ 
+################################################################################
+#
+# intel-socfpga-hwlib
+#
+################################################################################
+
+INTEL_SOCFPGA_HWLIB_VERSION = 23.12.02
+INTEL_SOCFPGA_HWLIB_SITE = $(call 
github,altera-opensource,intel-socfpga-hwlib,rel_master_$(INTEL_SOCFPGA_HWLIB_VERSION)_pr)
+INTEL_SOCFPGA_HWLIB_LICENSE = PROPRIETARY
+INTEL_SOCFPGA_HWLIB_LICENSE_FILES = License.txt
+INTEL_SOCFPGA_HWLIB_REDISTRIBUTE = YES
+INTEL_SOCFPGA_HWLIB_INSTALL_STAGING = YES
+
+define INTEL_SOCFPGA_HWLIB_INSTALL_STAGING_CMDS
+ ln -s $(BUILD_DIR)/intel-socfpga-hwlib-$(INTEL_SOCFPGA_HWLIB_VERSION) 
$(STAGING_DIR)/lib/intel-socfpga-hwlib
+endef
+
+# define INTEL_SOCFPGA_HWLIB_INSTALL_IMAGES_CMDS
+# mkdir -p $(BINARIES_DIR)/intel-ucode
+# $(INSTALL) -m 0644 -t $(BINARIES_DIR)/intel-ucode \
+# $(@D)/intel-ucode/*
+# endef
+#
+# ifeq ($(BR2_PACKAGE_INTEL_SOCFPGA_HWLIB_INSTALL_TARGET),y)
+# define INTEL_SOCFPGA_HWLIB_INSTALL_TARGET_CMDS
+# mkdir -p $(TARGET_DIR)/lib/firmware/intel-ucode
+# $(INSTALL) -m 0644 -t $(TARGET_DIR)/lib/firmware/intel-ucode \
+# $(@D)/intel-ucode/*
+# endef
+# else
+# INTEL_SOCFPGA_HWLIB_INSTALL_TARGET = NO
+# endif
+
+# define INTEL_SOCFPGA_HWLIB_LINUX_CONFIG_FIXUPS
+# $(call KCONFIG_ENABLE_OPT,CONFIG_MICROCODE)
+# $(call KCONFIG_ENABLE_OPT,CONFIG_MICROCODE_INTEL)
+# endef