diff mbox series

package/qemu: update to 9.0.0

Message ID ZkDCDNPE1sawl6SP@waldemar-brodkorb.de
State Accepted
Headers show
Series package/qemu: update to 9.0.0 | expand

Commit Message

Waldemar Brodkorb May 12, 2024, 1:20 p.m. UTC
See here the changes:
https://wiki.qemu.org/ChangeLog/9.0

Disable plugins because of compile errors.
Patches 0002/0003 are Upstream.

Signed-off-by: Waldemar Brodkorb <wbx@openadk.org>
---
 ...comp.c-add-missing-header-for-CLONE_.patch | 42 -------------------
 ...-trace-events-file-only-if-necessary.patch | 30 -------------
 package/qemu/Config.in                        |  2 +-
 package/qemu/qemu.hash                        |  2 +-
 package/qemu/qemu.mk                          |  4 +-
 5 files changed, 5 insertions(+), 75 deletions(-)
 delete mode 100644 package/qemu/0002-softmmu-qemu-seccomp.c-add-missing-header-for-CLONE_.patch
 delete mode 100644 package/qemu/0003-tracing-install-trace-events-file-only-if-necessary.patch

Comments

Thomas Petazzoni May 13, 2024, 8:49 p.m. UTC | #1
Hello,

On Sun, 12 May 2024 15:20:12 +0200
Waldemar Brodkorb <wbx@openadk.org> wrote:

> diff --git a/package/qemu/0002-softmmu-qemu-seccomp.c-add-missing-header-for-CLONE_.patch b/package/qemu/0002-softmmu-qemu-seccomp.c-add-missing-header-for-CLONE_.patch
> deleted file mode 100644
> index 91506b14d9..0000000000
> --- a/package/qemu/0002-softmmu-qemu-seccomp.c-add-missing-header-for-CLONE_.patch
> +++ /dev/null

The removal of this patch needed a .checkpackageignore change, so I did that.

> diff --git a/package/qemu/Config.in b/package/qemu/Config.in
> index 8d53ced300..91e0de884f 100644
> --- a/package/qemu/Config.in
> +++ b/package/qemu/Config.in
> @@ -289,7 +289,7 @@ config BR2_PACKAGE_QEMU_TARGET_RISCV32
>  	bool "riscv32"
>  	select BR2_PACKAGE_QEMU_FDT if BR2_PACKAGE_QEMU_SYSTEM
>  	help
> -	  RISC-V 33-bit architecture.
> +	  RISC-V 32-bit architecture.

This typo fix was unrelated to the bump, so it should have been a
separate patch. Therefore I made a separate commit.

Applied with those changes, thanks!

Thomas
diff mbox series

Patch

diff --git a/package/qemu/0002-softmmu-qemu-seccomp.c-add-missing-header-for-CLONE_.patch b/package/qemu/0002-softmmu-qemu-seccomp.c-add-missing-header-for-CLONE_.patch
deleted file mode 100644
index 91506b14d9..0000000000
--- a/package/qemu/0002-softmmu-qemu-seccomp.c-add-missing-header-for-CLONE_.patch
+++ /dev/null
@@ -1,42 +0,0 @@ 
-From df07d3754bdf15e0efac244cfee290c9bac86352 Mon Sep 17 00:00:00 2001
-From: Romain Naour <romain.naour@gmail.com>
-Date: Mon, 2 May 2022 23:17:46 +0200
-Subject: [PATCH] softmmu/qemu-seccomp.c: add missing header for CLONE_NEWGROUP
-MIME-Version: 1.0
-Content-Type: text/plain; charset=UTF-8
-Content-Transfer-Encoding: 8bit
-
-With seccomp support enabled Qemu 7.0.0 fail to build with the
-following error:
-
-../softmmu/qemu-seccomp.c:116:19: error: ‘CLONE_NEWCGROUP’ undeclared here (not in a function)
-  116 | FORBID_CLONE_FLAG(CLONE_NEWCGROUP);
-      |                   ^~~~~~~~~~~~~~~
-../softmmu/qemu-seccomp.c:73:18: note: in definition of macro ‘FORBID_CLONE_FLAG’
-   73 |       .datum_a = flag, .datum_b = flag } }
-      |                  ^~~~
-
-CLONE_NEWCGROUP has been added in Qemu 7.0.0 by commit [1].
-
-[1] https://git.qemu.org/?p=qemu.git;a=commitdiff;h=5a2f693f07a1e93ada5277b2fb1530b2698be0fa
-
-Signed-off-by: Romain Naour <romain.naour@gmail.com>
----
- softmmu/qemu-seccomp.c | 1 +
- 1 file changed, 1 insertion(+)
-
-diff --git a/softmmu/qemu-seccomp.c b/softmmu/qemu-seccomp.c
-index deaf8a4ef5..96c83e121f 100644
---- a/softmmu/qemu-seccomp.c
-+++ b/softmmu/qemu-seccomp.c
-@@ -21,6 +21,7 @@
- #include <sys/prctl.h>
- #include <seccomp.h>
- #include "sysemu/seccomp.h"
-+#include <linux/sched.h>
- #include <linux/seccomp.h>
- 
- /* For some architectures (notably ARM) cacheflush is not supported until
--- 
-2.35.1
-
diff --git a/package/qemu/0003-tracing-install-trace-events-file-only-if-necessary.patch b/package/qemu/0003-tracing-install-trace-events-file-only-if-necessary.patch
deleted file mode 100644
index 36bdaa4978..0000000000
--- a/package/qemu/0003-tracing-install-trace-events-file-only-if-necessary.patch
+++ /dev/null
@@ -1,30 +0,0 @@ 
-From 5c43da1e4983cc3c209b325a5228b6149e0a0ccf Mon Sep 17 00:00:00 2001
-From: Carlos Santos <casantos@redhat.com>
-Date: Fri, 24 Mar 2023 21:40:22 -0300
-Subject: [PATCH] tracing: install trace events file only if necessary
-
-It is not useful when configuring with --enable-trace-backends=nop.
-
-Upstream: https://patchwork.kernel.org/project/qemu-devel/patch/20230408010410.281263-1-casantos@redhat.com/
-Signed-off-by: Carlos Santos <casantos@redhat.com>
-Signed-off-by: Carlos Santos <unixmania@gmail.com>
----
- trace/meson.build | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/trace/meson.build b/trace/meson.build
-index 8e80be895c..30b1d942eb 100644
---- a/trace/meson.build
-+++ b/trace/meson.build
-@@ -64,7 +64,7 @@ trace_events_all = custom_target('trace-events-all',
-                                  input: trace_events_files,
-                                  command: [ 'cat', '@INPUT@' ],
-                                  capture: true,
--                                 install: true,
-+                                 install: get_option('trace_backends') != [ 'nop' ],
-                                  install_dir: qemu_datadir)
- 
- if 'ust' in get_option('trace_backends')
--- 
-2.31.1
-
diff --git a/package/qemu/Config.in b/package/qemu/Config.in
index 8d53ced300..91e0de884f 100644
--- a/package/qemu/Config.in
+++ b/package/qemu/Config.in
@@ -289,7 +289,7 @@  config BR2_PACKAGE_QEMU_TARGET_RISCV32
 	bool "riscv32"
 	select BR2_PACKAGE_QEMU_FDT if BR2_PACKAGE_QEMU_SYSTEM
 	help
-	  RISC-V 33-bit architecture.
+	  RISC-V 32-bit architecture.
 
 config BR2_PACKAGE_QEMU_TARGET_RISCV64
 	bool "riscv64"
diff --git a/package/qemu/qemu.hash b/package/qemu/qemu.hash
index 61e51a923f..2c905d2e77 100644
--- a/package/qemu/qemu.hash
+++ b/package/qemu/qemu.hash
@@ -1,4 +1,4 @@ 
 # Locally computed, tarball verified with GPG signature
-sha256  37ce2ef5e500fb752f681117c68b45118303ea49a7e26bd54080ced54fab7def  qemu-8.1.1.tar.xz
+sha256  32708ac66c30d8c892633ea968c771c1c76d597d70ddead21a0d22ccf386da69  qemu-9.0.0.tar.xz
 sha256  6f04ae8364d0079a192b14635f4b1da294ce18724c034c39a6a41d1b09df6100  COPYING
 sha256  dc626520dcd53a22f727af3ee42c770e56c97a64fe3adb063799d8ab032fe551  COPYING.LIB
diff --git a/package/qemu/qemu.mk b/package/qemu/qemu.mk
index ef406dc8e9..8de803dd25 100644
--- a/package/qemu/qemu.mk
+++ b/package/qemu/qemu.mk
@@ -6,7 +6,7 @@ 
 
 # When updating the version, check whether the list of supported targets
 # needs to be updated.
-QEMU_VERSION = 8.1.1
+QEMU_VERSION = 9.0.0
 QEMU_SOURCE = qemu-$(QEMU_VERSION).tar.xz
 QEMU_SITE = https://download.qemu.org
 QEMU_SELINUX_MODULES = qemu virt
@@ -320,6 +320,7 @@  define QEMU_CONFIGURE_CMDS
 			--disable-opengl \
 			--disable-oss \
 			--disable-pa \
+			--disable-plugins \
 			--disable-rbd \
 			--disable-sanitizers \
 			--disable-selinux \
@@ -504,6 +505,7 @@  define HOST_QEMU_CONFIGURE_CMDS
 		--disable-vde \
 		--disable-vhost-user-blk-server \
 		--disable-vnc-jpeg \
+		--disable-plugins \
 		--disable-png \
 		--disable-vnc-sasl \
 		--enable-slirp \