diff mbox series

package/gmp: fix compile error for riscv

Message ID ZORnh9dzTr/VmBfa@waldemar-brodkorb.de
State Accepted
Headers show
Series package/gmp: fix compile error for riscv | expand

Commit Message

Waldemar Brodkorb Aug. 22, 2023, 7:45 a.m. UTC
In commit 87b2a30319394c2cc79efae1af7833cad8c62b32 gmp got updated
to 6.2.1, since then the compile error exist.

Compile error looks like this:
tmp-mul_1.s: Assembler messages:
tmp-mul_1.s:55: Error: unrecognized opcode `mul a5,a7,a3'
tmp-mul_1.s:57: Error: unrecognized opcode `mulhu a7,a7,a3'

Patch should be backported to stable branches.

Fixes:
 - http://autobuild.buildroot.net/results/2f2/2f2112bea73adbf49eabb62fe6cda6a9cd5d0567
 - http://autobuild.buildroot.net/results/566/566a4945555b781ed127997176f73b3c17ecab5d

Signed-off-by: Waldemar Brodkorb <wbx@openadk.org>
---
 package/gmp/gmp.mk | 5 +++++
 1 file changed, 5 insertions(+)

Comments

Thomas Petazzoni Aug. 22, 2023, 6:10 p.m. UTC | #1
On Tue, 22 Aug 2023 09:45:11 +0200
Waldemar Brodkorb <wbx@openadk.org> wrote:

> In commit 87b2a30319394c2cc79efae1af7833cad8c62b32 gmp got updated
> to 6.2.1, since then the compile error exist.
> 
> Compile error looks like this:
> tmp-mul_1.s: Assembler messages:
> tmp-mul_1.s:55: Error: unrecognized opcode `mul a5,a7,a3'
> tmp-mul_1.s:57: Error: unrecognized opcode `mulhu a7,a7,a3'
> 
> Patch should be backported to stable branches.
> 
> Fixes:
>  - http://autobuild.buildroot.net/results/2f2/2f2112bea73adbf49eabb62fe6cda6a9cd5d0567
>  - http://autobuild.buildroot.net/results/566/566a4945555b781ed127997176f73b3c17ecab5d
> 
> Signed-off-by: Waldemar Brodkorb <wbx@openadk.org>
> ---
>  package/gmp/gmp.mk | 5 +++++
>  1 file changed, 5 insertions(+)

Applied to master, thanks.

Yann, Peter: I have intentionally cherry-picked this patch into the
next branch as well, but it is slightly different due to the renaming
of the RISC-V option. I did it now because my thinking is that if I
don't do it now while merging the patch, we will forget about it when
we merge back next into master. At least here, there will be a very
easy to resolve merge conflict, and we will notice that we need to keep
the version coming from the next branch. Let me know if you find this
sensible or stupid, so that I know how to do better next time if needed :-)

Best regards,

Thomas
Peter Korsgaard Sept. 13, 2023, 3:53 p.m. UTC | #2
>>>>> "Waldemar" == Waldemar Brodkorb <wbx@openadk.org> writes:

 > In commit 87b2a30319394c2cc79efae1af7833cad8c62b32 gmp got updated
 > to 6.2.1, since then the compile error exist.

 > Compile error looks like this:
 > tmp-mul_1.s: Assembler messages:
 > tmp-mul_1.s:55: Error: unrecognized opcode `mul a5,a7,a3'
 > tmp-mul_1.s:57: Error: unrecognized opcode `mulhu a7,a7,a3'

 > Patch should be backported to stable branches.

 > Fixes:
 >  - http://autobuild.buildroot.net/results/2f2/2f2112bea73adbf49eabb62fe6cda6a9cd5d0567
 >  - http://autobuild.buildroot.net/results/566/566a4945555b781ed127997176f73b3c17ecab5d

 > Signed-off-by: Waldemar Brodkorb <wbx@openadk.org>

Committed to 2023.02.x and 2023.05.x, thanks.
diff mbox series

Patch

diff --git a/package/gmp/gmp.mk b/package/gmp/gmp.mk
index 9b402767fd..3b732dfa71 100644
--- a/package/gmp/gmp.mk
+++ b/package/gmp/gmp.mk
@@ -23,6 +23,11 @@  ifeq ($(BR2_m68k_cf)$(BR2_MIPS_CPU_MIPS32R6)$(BR2_MIPS_CPU_MIPS64R6)$(BR2_ARM_CP
 GMP_CONF_OPTS += --disable-assembly
 endif
 
+# GMP needs M extension for riscv assembly
+ifeq ($(BR2_RISCV_ISA_CUSTOM_RVM),)
+GMP_CONF_OPTS += --disable-assembly
+endif
+
 ifeq ($(BR2_INSTALL_LIBSTDCPP),y)
 GMP_CONF_OPTS += --enable-cxx
 else