diff mbox series

package/zlib-ng: handle power9 cpu, fix compile error

Message ID ZNonuEcvkO/N5PXe@waldemar-brodkorb.de
State Accepted
Headers show
Series package/zlib-ng: handle power9 cpu, fix compile error | expand

Commit Message

Waldemar Brodkorb Aug. 14, 2023, 1:10 p.m. UTC
Zlib-ng misdetects the powerpc cpu and the package fails to compile
for non-power9 cpu's.
Power9 support was added Upstream in commit:
02d10b252cc54159f7c33823048daec4b023fb22
So it was introduced in zlib-ng 2.1.3 and this was added to Buildroot
in commit 0df456ea6e05306fb077e96064adf68f3863eeea.

So there is no need to backport it to older Buildroot releases.

Fixes:
 - http://autobuild.buildroot.net/results/a9f/a9f45486664b2d5b23a2f330a63955a06ae8189d

Signed-off-by: Waldemar Brodkorb <wbx@openadk.org>
---
 package/zlib-ng/zlib-ng.mk | 6 ++++++
 1 file changed, 6 insertions(+)

Comments

Thomas Petazzoni Aug. 22, 2023, 7:22 p.m. UTC | #1
On Mon, 14 Aug 2023 15:10:16 +0200
Waldemar Brodkorb <wbx@openadk.org> wrote:

> Zlib-ng misdetects the powerpc cpu and the package fails to compile
> for non-power9 cpu's.
> Power9 support was added Upstream in commit:
> 02d10b252cc54159f7c33823048daec4b023fb22
> So it was introduced in zlib-ng 2.1.3 and this was added to Buildroot
> in commit 0df456ea6e05306fb077e96064adf68f3863eeea.
> 
> So there is no need to backport it to older Buildroot releases.
> 
> Fixes:
>  - http://autobuild.buildroot.net/results/a9f/a9f45486664b2d5b23a2f330a63955a06ae8189d
> 
> Signed-off-by: Waldemar Brodkorb <wbx@openadk.org>
> ---
>  package/zlib-ng/zlib-ng.mk | 6 ++++++
>  1 file changed, 6 insertions(+)

Applied to master, thanks.

Thomas
diff mbox series

Patch

diff --git a/package/zlib-ng/zlib-ng.mk b/package/zlib-ng/zlib-ng.mk
index 23f1bd2158..fbb906503a 100644
--- a/package/zlib-ng/zlib-ng.mk
+++ b/package/zlib-ng/zlib-ng.mk
@@ -35,4 +35,10 @@  else
 ZLIB_NG_CONF_OPTS += -DWITH_POWER8=OFF
 endif
 
+ifeq ($(BR2_powerpc_power9),y)
+ZLIB_NG_CONF_OPTS += -DWITH_POWER9=ON
+else
+ZLIB_NG_CONF_OPTS += -DWITH_POWER9=OFF
+endif
+
 $(eval $(cmake-package))