diff mbox series

[v2,1/2] package/xfsprogs: fix linking error when -O0 is used

Message ID ZNeDSjN9ON9dG18Q@waldemar-brodkorb.de
State Accepted
Headers show
Series [v2,1/2] package/xfsprogs: fix linking error when -O0 is used | expand

Commit Message

Waldemar Brodkorb Aug. 12, 2023, 1:04 p.m. UTC
Urcu does not like -O0 it needs gcc optimizations.
Force -O1 in this case. Inspired by package fwts.

The issue got introduced in commit 2f8f69012e0eee7f3e98212fb3da118c211f3c0b:
before this commit, xfsprogs builds fine at -O0, after this commit, it fails
to build at -O0. As this commit went into 2022.02, the fix needs to be
backported to stable branches.

Fixes:
 - http://autobuild.buildroot.net/results/3bd/3bd7de784953ab1fa70bf5572eccd7b10e4a0e17

Signed-off-by: Waldemar Brodkorb <wbx@openadk.org>
---
v1 -> v2:
  - add more information about when the problem was introduced
    from Thomas Petazzoni's review
---
 package/xfsprogs/xfsprogs.mk | 4 ++++
 1 file changed, 4 insertions(+)

Comments

Thomas Petazzoni Aug. 12, 2023, 7:39 p.m. UTC | #1
On Sat, 12 Aug 2023 15:04:10 +0200
Waldemar Brodkorb <wbx@openadk.org> wrote:

> Urcu does not like -O0 it needs gcc optimizations.
> Force -O1 in this case. Inspired by package fwts.
> 
> The issue got introduced in commit 2f8f69012e0eee7f3e98212fb3da118c211f3c0b:
> before this commit, xfsprogs builds fine at -O0, after this commit, it fails
> to build at -O0. As this commit went into 2022.02, the fix needs to be
> backported to stable branches.
> 
> Fixes:
>  - http://autobuild.buildroot.net/results/3bd/3bd7de784953ab1fa70bf5572eccd7b10e4a0e17
> 
> Signed-off-by: Waldemar Brodkorb <wbx@openadk.org>
> ---
> v1 -> v2:
>   - add more information about when the problem was introduced
>     from Thomas Petazzoni's review
> ---
>  package/xfsprogs/xfsprogs.mk | 4 ++++
>  1 file changed, 4 insertions(+)

Applied to master, thanks.

Thomas
Peter Korsgaard Sept. 12, 2023, 6:26 a.m. UTC | #2
>>>>> "Waldemar" == Waldemar Brodkorb <wbx@openadk.org> writes:

 > Urcu does not like -O0 it needs gcc optimizations.
 > Force -O1 in this case. Inspired by package fwts.

 > The issue got introduced in commit 2f8f69012e0eee7f3e98212fb3da118c211f3c0b:
 > before this commit, xfsprogs builds fine at -O0, after this commit, it fails
 > to build at -O0. As this commit went into 2022.02, the fix needs to be
 > backported to stable branches.

 > Fixes:
 >  - http://autobuild.buildroot.net/results/3bd/3bd7de784953ab1fa70bf5572eccd7b10e4a0e17

 > Signed-off-by: Waldemar Brodkorb <wbx@openadk.org>
 > ---
 > v1 -> v2:
 >   - add more information about when the problem was introduced
 >     from Thomas Petazzoni's review

Committed to 2023.02.x and 2023.05.x, thanks.
diff mbox series

Patch

diff --git a/package/xfsprogs/xfsprogs.mk b/package/xfsprogs/xfsprogs.mk
index 695471bddc..09f59a76f4 100644
--- a/package/xfsprogs/xfsprogs.mk
+++ b/package/xfsprogs/xfsprogs.mk
@@ -27,6 +27,10 @@  else
 XFSPROGS_CONF_OPTS += --disable-libicu
 endif
 
+ifeq ($(BR2_OPTIMIZE_0),y)
+XFSPROGS_CONF_ENV += CFLAGS="$(TARGET_CFLAGS) -O1"
+endif
+
 XFSPROGS_INSTALL_TARGET_OPTS = DIST_ROOT=$(TARGET_DIR) install
 
 $(eval $(autotools-package))