diff mbox series

package/libgpg-error: force cross compiling

Message ID VI1P190MB04936329051AD467C99376869FB59@VI1P190MB0493.EURP190.PROD.OUTLOOK.COM
State Accepted
Headers show
Series package/libgpg-error: force cross compiling | expand

Commit Message

Lang Daniel March 9, 2023, 7:15 a.m. UTC
By default autotools enters cross-compiling mode if --build and --host
differ [0]. This should normally be the case as buildroot sets itself as
vendor in the toolchain triplet.
For libgpg-error the --host flag has to be set to a generic triplet
because this information is used to lookup the syscfg.
When compiling on aarch64 for aarch64 build and host would be the same,
therefore cross-compiling isn't activated, which results in a build failure.

Fixes:
 - http://autobuild.buildroot.net/results/6d4/6d4bc520c12313508d0fadee11d5b88c35a3cba9/

[0]: https://www.gnu.org/savannah-checkouts/gnu/autoconf/manual/autoconf-2.71/html_node/Hosts-and-Cross_002dCompilation.html

Signed-off-by: Daniel Lang <d.lang@abatec.at>
---
 package/libgpg-error/libgpg-error.mk | 1 +
 1 file changed, 1 insertion(+)

Comments

Arnout Vandecappelle March 9, 2023, 7:40 p.m. UTC | #1
On 09/03/2023 08:15, Lang Daniel via buildroot wrote:
> By default autotools enters cross-compiling mode if --build and --host
> differ [0]. This should normally be the case as buildroot sets itself as
> vendor in the toolchain triplet.
> For libgpg-error the --host flag has to be set to a generic triplet
> because this information is used to lookup the syscfg.
> When compiling on aarch64 for aarch64 build and host would be the same,
> therefore cross-compiling isn't activated, which results in a build failure.
> 
> Fixes:
>   - http://autobuild.buildroot.net/results/6d4/6d4bc520c12313508d0fadee11d5b88c35a3cba9/
> 
> [0]: https://www.gnu.org/savannah-checkouts/gnu/autoconf/manual/autoconf-2.71/html_node/Hosts-and-Cross_002dCompilation.html
> 
> Signed-off-by: Daniel Lang <d.lang@abatec.at>

  Applied to master, thanks.

  Regards,
  Arnout

> ---
>   package/libgpg-error/libgpg-error.mk | 1 +
>   1 file changed, 1 insertion(+)
> 
> diff --git a/package/libgpg-error/libgpg-error.mk b/package/libgpg-error/libgpg-error.mk
> index 3f4a45a7e4..3ab8535a9c 100644
> --- a/package/libgpg-error/libgpg-error.mk
> +++ b/package/libgpg-error/libgpg-error.mk
> @@ -14,6 +14,7 @@ LIBGPG_ERROR_INSTALL_STAGING = YES
>   LIBGPG_ERROR_CONFIG_SCRIPTS = gpg-error-config
>   LIBGPG_ERROR_DEPENDENCIES = $(TARGET_NLS_DEPENDENCIES)
>   LIBGPG_ERROR_CONF_OPTS = \
> +	cross_compiling=yes \
>   	--host=$(BR2_PACKAGE_LIBGPG_ERROR_SYSCFG) \
>   	--enable-install-gpg-error-config \
>   	--disable-tests \
diff mbox series

Patch

diff --git a/package/libgpg-error/libgpg-error.mk b/package/libgpg-error/libgpg-error.mk
index 3f4a45a7e4..3ab8535a9c 100644
--- a/package/libgpg-error/libgpg-error.mk
+++ b/package/libgpg-error/libgpg-error.mk
@@ -14,6 +14,7 @@  LIBGPG_ERROR_INSTALL_STAGING = YES
 LIBGPG_ERROR_CONFIG_SCRIPTS = gpg-error-config
 LIBGPG_ERROR_DEPENDENCIES = $(TARGET_NLS_DEPENDENCIES)
 LIBGPG_ERROR_CONF_OPTS = \
+	cross_compiling=yes \
 	--host=$(BR2_PACKAGE_LIBGPG_ERROR_SYSCFG) \
 	--enable-install-gpg-error-config \
 	--disable-tests \