diff mbox series

[3/6] package/atkmm2_28: new package

Message ID VI1P190MB04934E635705A3395768AC0A9FA89@VI1P190MB0493.EURP190.PROD.OUTLOOK.COM
State Accepted
Headers show
Series package/gtkmm3: duplicate needed packages | expand

Commit Message

Lang Daniel Feb. 24, 2023, 8:42 a.m. UTC
This is the version needed for gtkmm3.

Signed-off-by: Daniel Lang <d.lang@abatec.at>
---
 DEVELOPERS                       |  2 ++
 package/Config.in                |  1 +
 package/atkmm/Config.in          |  2 +-
 package/atkmm2_28/Config.in      | 23 +++++++++++++++++++++++
 package/atkmm2_28/atkmm2_28.hash |  5 +++++
 package/atkmm2_28/atkmm2_28.mk   | 16 ++++++++++++++++
 6 files changed, 48 insertions(+), 1 deletion(-)
 create mode 100644 package/atkmm2_28/Config.in
 create mode 100644 package/atkmm2_28/atkmm2_28.hash
 create mode 100644 package/atkmm2_28/atkmm2_28.mk

Comments

Arnout Vandecappelle March 9, 2023, 8:58 p.m. UTC | #1
On 24/02/2023 09:42, Lang Daniel via buildroot wrote:
> |+ This is the last version before the API and ABI change + introduced in 2.36.0 
> which requires C++17.|

  This sounds like we could use 2.34.0 instead of 2.28.0. Why did you choose 2.28.0?

  Regards,
  Arnout
Arnout Vandecappelle March 9, 2023, 9:19 p.m. UTC | #2
On 09/03/2023 21:58, Arnout Vandecappelle wrote:
>
>
> On 24/02/2023 09:42, Lang Daniel via buildroot wrote:
>> |+ This is the last version before the API and ABI change + introduced in 
>> 2.36.0 which requires C++17.|
>
>  This sounds like we could use 2.34.0 instead of 2.28.0. Why did you choose 
> 2.28.0?

  A tiny bit of research shows that there never was a 2.30, 2.32 or 2.34 series. 
I don't know what kind of versioning scheme these people are using...


  Regards,
  Arnout
diff mbox series

Patch

diff --git a/DEVELOPERS b/DEVELOPERS
index 20ad528243..a1294addea 100644
--- a/DEVELOPERS
+++ b/DEVELOPERS
@@ -640,6 +640,8 @@  N:	Daniel J. Leach <dleach@belcan.com>
 F:	package/dacapo/
 
 N:	Daniel Lang <d.lang@abatec.at>
+F:	package/atkmm/
+F:	package/atkmm2_28/
 F:	package/dbus-cxx/
 F:	package/glibmm/
 F:	package/glibmm2_66/
diff --git a/package/Config.in b/package/Config.in
index f62b1f8b0b..03fcd9096c 100644
--- a/package/Config.in
+++ b/package/Config.in
@@ -1557,6 +1557,7 @@  menu "Graphics"
 	source "package/at-spi2-core/Config.in"
 	source "package/atk/Config.in"
 	source "package/atkmm/Config.in"
+	source "package/atkmm2_28/Config.in"
 	source "package/bayer2rgb-neon/Config.in"
 	source "package/bullet/Config.in"
 	source "package/cairo/Config.in"
diff --git a/package/atkmm/Config.in b/package/atkmm/Config.in
index aa58f8d593..1f370356ea 100644
--- a/package/atkmm/Config.in
+++ b/package/atkmm/Config.in
@@ -1,5 +1,5 @@ 
 config BR2_PACKAGE_ATKMM
-	bool "atkmm"
+	bool "atkmm (latest)"
 	depends on BR2_INSTALL_LIBSTDCPP # glibmm
 	depends on BR2_TOOLCHAIN_GCC_AT_LEAST_7 # libsigc
 	depends on BR2_TOOLCHAIN_HAS_THREADS # atk/glibmm -> libglib2
diff --git a/package/atkmm2_28/Config.in b/package/atkmm2_28/Config.in
new file mode 100644
index 0000000000..2340465b20
--- /dev/null
+++ b/package/atkmm2_28/Config.in
@@ -0,0 +1,23 @@ 
+config BR2_PACKAGE_ATKMM2_28
+	bool "atkmm (2.28.x)"
+	depends on BR2_INSTALL_LIBSTDCPP # glibmm
+	depends on BR2_TOOLCHAIN_GCC_AT_LEAST_4_9 # C++11
+	depends on BR2_TOOLCHAIN_HAS_THREADS # atk/glibmm -> libglib2
+	depends on BR2_USE_MMU # atk/glibmm -> libglib2
+	depends on BR2_USE_WCHAR # atk/glibmm -> libglib2
+	select BR2_PACKAGE_ATK
+	select BR2_PACKAGE_GLIBMM2_66
+	select BR2_PACKAGE_LIBSIGC2
+
+	help
+	  The atkmm package is a set of C++ bindings for Atk.
+
+	  This is the last version before the API and ABI change
+	  introduced in 2.36.0 which requires C++17.
+
+	  http://www.gtkmm.org/
+
+comment "atkmm (2.28.x) needs a toolchain w/ C++, wchar, threads, gcc >= 4.9"
+	depends on BR2_USE_MMU
+	depends on !BR2_TOOLCHAIN_GCC_AT_LEAST_4_9 || !BR2_USE_WCHAR \
+		|| !BR2_INSTALL_LIBSTDCPP || !BR2_TOOLCHAIN_HAS_THREADS
diff --git a/package/atkmm2_28/atkmm2_28.hash b/package/atkmm2_28/atkmm2_28.hash
new file mode 100644
index 0000000000..776c9851b8
--- /dev/null
+++ b/package/atkmm2_28/atkmm2_28.hash
@@ -0,0 +1,5 @@ 
+# From https://download.gnome.org/sources/atkmm/2.28/atkmm-2.28.3.sha256sum
+sha256  7c2088b486a909be8da2b18304e56c5f90884d1343c8da7367ea5cd3258b9969  atkmm-2.28.3.tar.xz
+# locally computed
+sha256  a9bdde5616ecdd1e980b44f360600ee8783b1f99b8cc83a2beb163a0a390e861  COPYING
+sha256  ab15fd526bd8dd18a9e77ebc139656bf4d33e97fc7238cd11bf60e2b9b8666c6  COPYING.tools
diff --git a/package/atkmm2_28/atkmm2_28.mk b/package/atkmm2_28/atkmm2_28.mk
new file mode 100644
index 0000000000..dc57363cf5
--- /dev/null
+++ b/package/atkmm2_28/atkmm2_28.mk
@@ -0,0 +1,16 @@ 
+################################################################################
+#
+# atkmm2_28
+#
+################################################################################
+
+ATKMM2_28_VERSION_MAJOR = 2.28
+ATKMM2_28_VERSION = $(ATKMM2_28_VERSION_MAJOR).3
+ATKMM2_28_SOURCE = atkmm-$(ATKMM2_28_VERSION).tar.xz
+ATKMM2_28_SITE = https://download.gnome.org/sources/atkmm/$(ATKMM2_28_VERSION_MAJOR)
+ATKMM2_28_LICENSE = LGPL-2.1+ (library), GPL-2.0+ (tools)
+ATKMM2_28_LICENSE_FILES = COPYING COPYING.tools
+ATKMM2_28_INSTALL_STAGING = YES
+ATKMM2_28_DEPENDENCIES = atk glibmm2_66 libsigc2 host-pkgconf
+
+$(eval $(meson-package))