diff mbox series

[2/2] package/bluez5_utils: fix SysV init script

Message ID VI1P190MB049333A9311E7A4ECAE13B7A9FBC9@VI1P190MB0493.EURP190.PROD.OUTLOOK.COM
State Accepted
Headers show
Series [1/2] package/bluez5_utils: fix media control profile | expand

Commit Message

Lang Daniel March 16, 2023, 1:53 p.m. UTC
- Use daemon name (bluetoothd) as file name.
- Script doesn't need to be executable.

Signed-off-by: Daniel Lang <d.lang@abatec.at>
---
 package/bluez5_utils/{S40bluetooth => S40bluetoothd} | 0
 package/bluez5_utils/bluez5_utils.mk                 | 4 ++--
 2 files changed, 2 insertions(+), 2 deletions(-)
 rename package/bluez5_utils/{S40bluetooth => S40bluetoothd} (100%)
 mode change 100755 => 100644

Comments

Thomas Petazzoni March 19, 2023, 1:51 p.m. UTC | #1
On Thu, 16 Mar 2023 13:53:14 +0000
Lang Daniel via buildroot <buildroot@buildroot.org> wrote:

> - Use daemon name (bluetoothd) as file name.
> - Script doesn't need to be executable.
> 
> Signed-off-by: Daniel Lang <d.lang@abatec.at>
> ---
>  package/bluez5_utils/{S40bluetooth => S40bluetoothd} | 0
>  package/bluez5_utils/bluez5_utils.mk                 | 4 ++--
>  2 files changed, 2 insertions(+), 2 deletions(-)
>  rename package/bluez5_utils/{S40bluetooth => S40bluetoothd} (100%)
>  mode change 100755 => 100644

Applied to master, thanks. I have also updated .checkpackageignore to
no longer ignore the warnings that were caused by S40bluetooth.

Thanks!

Thomas
Peter Korsgaard March 20, 2023, 9:04 a.m. UTC | #2
>>>>> "Lang" == Lang Daniel via buildroot <buildroot@buildroot.org> writes:

 > - Use daemon name (bluetoothd) as file name.
 > - Script doesn't need to be executable.

 > Signed-off-by: Daniel Lang <d.lang@abatec.at>

Committed to 2023.02.x, thanks.
diff mbox series

Patch

diff --git a/package/bluez5_utils/S40bluetooth b/package/bluez5_utils/S40bluetoothd
old mode 100755
new mode 100644
similarity index 100%
rename from package/bluez5_utils/S40bluetooth
rename to package/bluez5_utils/S40bluetoothd
diff --git a/package/bluez5_utils/bluez5_utils.mk b/package/bluez5_utils/bluez5_utils.mk
index 46ffda6019..54c78dce4d 100644
--- a/package/bluez5_utils/bluez5_utils.mk
+++ b/package/bluez5_utils/bluez5_utils.mk
@@ -194,8 +194,8 @@  BLUEZ5_UTILS_CONF_OPTS += --disable-systemd
 endif
 
 define BLUEZ5_UTILS_INSTALL_INIT_SYSV
-	$(INSTALL) -m 0755 -D package/bluez5_utils/S40bluetooth \
-		$(TARGET_DIR)/etc/init.d/S40bluetooth
+	$(INSTALL) -m 0755 -D package/bluez5_utils/S40bluetoothd \
+		$(TARGET_DIR)/etc/init.d/S40bluetoothd
 endef
 
 $(eval $(autotools-package))