diff mbox series

package/plymouth: new package

Message ID SN4P221MB06829C65329204195ED20B6FA0669@SN4P221MB0682.NAMP221.PROD.OUTLOOK.COM
State New
Headers show
Series package/plymouth: new package | expand

Commit Message

James Knight April 23, 2023, 5:48 a.m. UTC
Signed-off-by: James Knight <james.d.knight@live.com>
---
 package/Config.in              |  1 +
 package/plymouth/Config.in     | 59 +++++++++++++++++++++
 package/plymouth/plymouth.hash |  6 +++
 package/plymouth/plymouth.mk   | 95 ++++++++++++++++++++++++++++++++++
 4 files changed, 161 insertions(+)
 create mode 100644 package/plymouth/Config.in
 create mode 100644 package/plymouth/plymouth.hash
 create mode 100644 package/plymouth/plymouth.mk
diff mbox series

Patch

diff --git a/package/Config.in b/package/Config.in
index eaac32a01af363936edc8a0a8dd2450c458a38ae..cac5c0e388a7794e7e3ae65f58c439e2cfd1e816 100644
--- a/package/Config.in
+++ b/package/Config.in
@@ -353,6 +353,7 @@  comment "Graphic libraries"
 	source "package/mesa3d-headers/Config.in"
 	source "package/ocrad/Config.in"
 	source "package/ogre/Config.in"
+	source "package/plymouth/Config.in"
 	source "package/psplash/Config.in"
 	source "package/sdl/Config.in"
 	source "package/sdl_gfx/Config.in"
diff --git a/package/plymouth/Config.in b/package/plymouth/Config.in
new file mode 100644
index 0000000000000000000000000000000000000000..5046a2a0fc65a9aec10c23c5899375abda33e839
--- /dev/null
+++ b/package/plymouth/Config.in
@@ -0,0 +1,59 @@ 
+comment "plymouth needs a glibc/uClibc toolchain w/ wchar, dynamic library, threads"
+	depends on BR2_USE_MMU
+	depends on !BR2_USE_WCHAR || BR2_STATIC_LIBS || !BR2_TOOLCHAIN_HAS_THREADS \
+		|| BR2_TOOLCHAIN_USES_MUSL
+
+config BR2_PACKAGE_PLYMOUTH
+	bool "plymouth"
+	depends on BR2_USE_WCHAR # libglib2
+	depends on BR2_TOOLCHAIN_HAS_THREADS # libglib2
+	depends on BR2_USE_MMU # libglib2
+	depends on !BR2_STATIC_LIBS # dlfcn.h
+	depends on !BR2_TOOLCHAIN_USES_MUSL # rpmatch
+	select BR2_PACKAGE_CAIRO
+	select BR2_PACKAGE_CAIRO_PNG
+	select BR2_PACKAGE_LIBGLIB2
+	select BR2_PACKAGE_LIBPNG
+	help
+	  A graphical boot animation and logger.
+
+	  https://www.freedesktop.org/wiki/Software/Plymouth/
+
+if BR2_PACKAGE_PLYMOUTH
+
+config BR2_PACKAGE_PLYMOUTH_LOGO
+	string "logo"
+	help
+	  Logo used by boot splash plugins
+	  (default: $datadir/plymouth/bizcom.png).
+
+config BR2_PACKAGE_PLYMOUTH_BG_COLOR
+	string "background color"
+	help
+	  Background color used by boot splash plugins.
+
+	  Colors should be provided in the format "0xRRGGBB".
+
+config BR2_PACKAGE_PLYMOUTH_BG_COLORSCS
+	string "background color (gradient; first)"
+	help
+	  First color stop in background gradients used by boot splash
+	  plugins.
+
+config BR2_PACKAGE_PLYMOUTH_BG_COLORECS
+	string "background color (gradient; last)"
+	help
+	  Last color end in background gradients used by boot splash
+	  plugins.
+
+config BR2_PACKAGE_PLYMOUTH_TTY_BOOT
+	string "tty boot"
+	help
+	  Default TTY to use in boot mode (default: /dev/tty1).
+
+config BR2_PACKAGE_PLYMOUTH_TTY_SHUTDOWN
+	string "tty shutdown"
+	help
+	  Default TTY to use in shutdown mode (default: /dev/tty63).
+
+endif
diff --git a/package/plymouth/plymouth.hash b/package/plymouth/plymouth.hash
new file mode 100644
index 0000000000000000000000000000000000000000..bec4dd022f128bc4ea92a6f7dd4f515785a7b053
--- /dev/null
+++ b/package/plymouth/plymouth.hash
@@ -0,0 +1,6 @@ 
+# https://www.freedesktop.org/software/plymouth/releases/plymouth-22.02.122.tar.xz.sha1sum
+sha1  2a68a69b674b643cd50c48685669bb0523aeb68b  plymouth-22.02.122.tar.xz
+
+# Locally computed
+sha256  100551442221033ce868c447ad6c74d831d209c18ae232b98ae0207e34eadaeb  plymouth-22.02.122.tar.xz
+sha256  32b1062f7da84967e7019d01ab805935caa7ab7321a7ced0e30ebe75e5df1670  COPYING
diff --git a/package/plymouth/plymouth.mk b/package/plymouth/plymouth.mk
new file mode 100644
index 0000000000000000000000000000000000000000..20dce0d92b792e01e81a3513c2714d6ee993942c
--- /dev/null
+++ b/package/plymouth/plymouth.mk
@@ -0,0 +1,95 @@ 
+################################################################################
+#
+# plymouth
+#
+################################################################################
+
+PLYMOUTH_VERSION = 22.02.122
+PLYMOUTH_SITE = http://www.freedesktop.org/software/plymouth/releases
+PLYMOUTH_SOURCE = plymouth-$(PLYMOUTH_VERSION).tar.xz
+PLYMOUTH_LICENSE = GPL-2.0
+PLYMOUTH_LICENSE_FILES = COPYING
+
+PLYMOUTH_DEPENDENCIES = \
+	cairo \
+	libglib2 \
+	libpng
+
+PLYMOUTH_CONF_OPTS = \
+	--disable-dependency-tracking \
+	--disable-documentation \
+	--disable-rpath \
+	--disable-upstart-monitoring \
+	--with-release-file=/etc/os-release \
+	--without-rhgb-compat-link
+
+ifeq ($(BR2_PACKAGE_HAS_UDEV),y)
+PLYMOUTH_CONF_OPTS += --with-udev
+PLYMOUTH_DEPENDENCIES += udev
+else
+PLYMOUTH_CONF_OPTS += --without-udev
+endif
+
+ifeq ($(BR2_PACKAGE_LIBDRM),y)
+PLYMOUTH_CONF_OPTS += --enable-drm
+PLYMOUTH_DEPENDENCIES += libdrm
+else
+PLYMOUTH_CONF_OPTS += --disable-drm
+endif
+
+ifeq ($(BR2_PACKAGE_LIBGTK3_X11),y)
+PLYMOUTH_CONF_OPTS += --enable-gtk
+PLYMOUTH_DEPENDENCIES += libgtk3
+else
+PLYMOUTH_CONF_OPTS += --disable-gtk
+endif
+
+ifeq ($(BR2_PACKAGE_PANGO),y)
+PLYMOUTH_CONF_OPTS += --enable-pango
+PLYMOUTH_DEPENDENCIES += pango
+else
+PLYMOUTH_CONF_OPTS += --disable-pango
+endif
+
+ifeq ($(BR2_PACKAGE_SYSTEMD),y)
+PLYMOUTH_CONF_OPTS += --enable-systemd-integration
+PLYMOUTH_DEPENDENCIES += systemd
+else
+PLYMOUTH_CONF_OPTS += --disable-systemd-integration
+endif
+
+#
+# advanced customization
+#
+
+PLYMOUTH_BG_COLOR = $(call qstrip,$(BR2_PACKAGE_PLYMOUTH_BG_COLOR))
+ifneq ($(PLYMOUTH_BG_COLOR),)
+PLYMOUTH_CONF_OPTS += --with-background-color=$(PLYMOUTH_BG_COLOR)
+endif
+
+PLYMOUTH_BG_COLORSCS = $(call qstrip,$(BR2_PACKAGE_PLYMOUTH_BG_COLORSCS))
+ifneq ($(PLYMOUTH_BG_COLORSCS),)
+PLYMOUTH_CONF_OPTS += --with-background-start-color-stop=$(PLYMOUTH_BG_COLORSCS)
+endif
+
+PLYMOUTH_BG_COLORECS = $(call qstrip,$(BR2_PACKAGE_PLYMOUTH_BG_COLORECS))
+ifneq ($(PLYMOUTH_BG_COLORECS),)
+PLYMOUTH_CONF_OPTS += --with-background-end-color-stop=$(PLYMOUTH_BG_COLORECS)
+endif
+
+PLYMOUTH_LOGO = $(call qstrip,$(BR2_PACKAGE_PLYMOUTH_LOGO))
+ifneq ($(PLYMOUTH_LOGO),)
+PLYMOUTH_CONF_OPTS += --with-logo=$(PLYMOUTH_LOGO)
+endif
+
+PLYMOUTH_TTY_BOOT = $(call qstrip,$(BR2_PACKAGE_PLYMOUTH_TTY_BOOT))
+ifneq ($(PLYMOUTH_TTY_BOOT),)
+PLYMOUTH_CONF_OPTS += --with-boot-tty=$(PLYMOUTH_TTY_BOOT)
+endif
+
+PLYMOUTH_TTY_SHUTDOWN = $(call qstrip,$(BR2_PACKAGE_PLYMOUTH_TTY_SHUTDOWN))
+ifneq ($(PLYMOUTH_TTY_SHUTDOWN),)
+PLYMOUTH_CONF_OPTS += --with-shutdown-tty=$(PLYMOUTH_TTY_SHUTDOWN)
+endif
+
+$(eval $(autotools-package))