diff mbox series

[1/1] package/poco: bump version to 1.11.1

Message ID SJ0PR17MB54938C9DC46497D9C09DA979937C9@SJ0PR17MB5493.namprd17.prod.outlook.com
State Changes Requested
Headers show
Series [1/1] package/poco: bump version to 1.11.1 | expand

Commit Message

Tudor Barbu Dec. 21, 2021, 11:48 a.m. UTC
From 14cb284a085107a11c6d3636660e5a7ad5550a98 Mon Sep 17 00:00:00 2001
From: Tudor Barbu <tudor.barbu@keysight.com>
Date: Fri, 17 Dec 2021 14:51:20 +0200
Subject: [PATCH 1/1] package/poco: bump version to 1.11.1

This version contains multiple bug fixes and introduces ActiveRecord

Removed: 0001-poco-add-the-staging-path-to-search-path.patch

Selecting custom mysql lib and include is now supported via the
configure script

The following patches are integrated in upstream:
0002-Add-support-for-m68000-1856.patch
0003-Foundation-src-utils.h-backport-double-conversion-ch.patch

I have performed a test build for aarch64 with gcc10 without issues

Signed-off-by: Tudor Barbu <tudor.barbu@keysight.com>
---
...-add-the-staging-path-to-search-path.patch | 40 -------------------
.../0002-Add-support-for-m68000-1856.patch    | 32 ---------------
...tils.h-backport-double-conversion-ch.patch | 34 ----------------
package/poco/poco.hash                        |  2 +-
package/poco/poco.mk                          |  8 ++--
5 files changed, 5 insertions(+), 111 deletions(-)
delete mode 100644 package/poco/0001-poco-add-the-staging-path-to-search-path.patch
delete mode 100644 package/poco/0002-Add-support-for-m68000-1856.patch
delete mode 100644 package/poco/0003-Foundation-src-utils.h-backport-double-conversion-ch.patch

--
2.25.1

Comments

Thomas Petazzoni Dec. 24, 2021, 6:04 p.m. UTC | #1
Hello Tudor,

On Tue, 21 Dec 2021 11:48:05 +0000
Tudor Barbu via buildroot <buildroot@buildroot.org> wrote:

> From 14cb284a085107a11c6d3636660e5a7ad5550a98 Mon Sep 17 00:00:00 2001
> From: Tudor Barbu <tudor.barbu@keysight.com>
> Date: Fri, 17 Dec 2021 14:51:20 +0200
> Subject: [PATCH 1/1] package/poco: bump version to 1.11.1
> 
> This version contains multiple bug fixes and introduces ActiveRecord
> 
> Removed: 0001-poco-add-the-staging-path-to-search-path.patch
> 
> Selecting custom mysql lib and include is now supported via the
> configure script
> 
> The following patches are integrated in upstream:
> 0002-Add-support-for-m68000-1856.patch
> 0003-Foundation-src-utils.h-backport-double-conversion-ch.patch
> 
> I have performed a test build for aarch64 with gcc10 without issues
> 
> Signed-off-by: Tudor Barbu <tudor.barbu@keysight.com>

Thanks for your patch. However, it got damaged along the way, could you
try to use "git send-email" for future patch submissions?

Also, with your patch applied, the following defconfig which builds
poco in a very basic configuration, fails to build.

Example configuration:

BR2_arm=y
BR2_cortex_a9=y
BR2_ARM_ENABLE_VFP=y
BR2_TOOLCHAIN_EXTERNAL=y
BR2_TOOLCHAIN_EXTERNAL_BOOTLIN=y
BR2_INIT_NONE=y
BR2_SYSTEM_BIN_SH_NONE=y
# BR2_PACKAGE_BUSYBOX is not set
BR2_PACKAGE_POCO=y
# BR2_TARGET_ROOTFS_TAR is not set

Build failure:

In file included from include/Poco/SAX/SAXParser.h:23,
                 from include/Poco/DOM/DOMParser.h:22,
                 from src/DOMParser.cpp:15:
include/Poco/XML/ParserEngine.h:22:10: fatal error: expat.h: No such file or directory
   22 | #include <expat.h>
      |          ^~~~~~~~~
compilation terminated.

Could you have a look and submit an updated patch that addresses this
problem?

Thanks a lot!

Thomas Petazzoni
diff mbox series

Patch

diff --git a/package/poco/0001-poco-add-the-staging-path-to-search-path.patch b/package/poco/0001-poco-add-the-staging-path-to-search-path.patch
deleted file mode 100644
index fbabfc8f26..0000000000
--- a/package/poco/0001-poco-add-the-staging-path-to-search-path.patch
+++ /dev/null
@@ -1,40 +0,0 @@ 
-From a53f3fd64a0f36ec9bc1307d7e66cdc2dee4aeaa Mon Sep 17 00:00:00 2001
-From: Baruch Siach <baruch@tkos.co.il>
-Date: Tue, 4 Aug 2015 10:14:00 +0200
-Subject: [PATCH] poco: add the staging path to search path
-MIME-Version: 1.0
-Content-Type: text/plain; charset=UTF-8
-Content-Transfer-Encoding: 8bit
-
-Add the mysql headers and client libraries to the search path of the
-preprocessor and the linker. The $MYSQL_LIBDIR / $MYSQL_INCIDR variables
-must be set from the make command line.
-
-[Peter: Remove host dirs, add MYSQL_INCDIR]
-Signed-off-by: Baruch Siach <baruch@tkos.co.il>
-[Jörg: Update to version 1.6.1 from github]
-Signed-off-by: Jörg Krause <joerg.krause@embedded.rocks>
-[Julien: Rebased on version 1.10.1]
-Signed-off-by: Julien Olivain <juju@cotds.org>
----
- Data/MySQL/Makefile | 4 ++--
- 1 file changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/Data/MySQL/Makefile b/Data/MySQL/Makefile
-index 64a7d3f82..955fee2d4 100644
---- a/Data/MySQL/Makefile
-+++ b/Data/MySQL/Makefile
-@@ -6,8 +6,8 @@
-
- include $(POCO_BASE)/build/rules/global
-
--SYSLIBS += -L/usr/local/lib -L/usr/local/lib$(LIB64SUFFIX)/mysql -L/usr/lib$(LIB64SUFFIX)/mysql -L/usr/mysql/lib$(LIB64SUFFIX) -L/usr/mysql/lib$(LIB64SUFFIX)/mysql -L/usr/local/mysql/lib$(LIB64SUFFIX) -lmysqlclient
--INCLUDE += -I/usr/local/include/mysql/ -I/usr/include/mysql/ -I/usr/mysql/include/mysql -I/usr/local/mysql/include
-+SYSLIBS += -L$(MYSQL_LIBDIR) -lmysqlclient
-+INCLUDE += -I$(MYSQL_INCDIR)
- SYSFLAGS += -DTHREADSAFE -DNO_TCL
-
- objects = Binder Extractor SessionImpl Connector \
---
-2.26.2
-
diff --git a/package/poco/0002-Add-support-for-m68000-1856.patch b/package/poco/0002-Add-support-for-m68000-1856.patch
deleted file mode 100644
index bc04a9bf69..0000000000
--- a/package/poco/0002-Add-support-for-m68000-1856.patch
+++ /dev/null
@@ -1,32 +0,0 @@ 
-From 221e308ad452035f4c1dc25e194f817a30f38f7b Mon Sep 17 00:00:00 2001
-From: Jochen Sprickerhof <github@jochen.sprickerhof.de>
-Date: Wed, 23 Aug 2017 16:50:51 +0200
-Subject: [PATCH] Add support for m68000 (#1856)
-
-Originally taken from
-
-https://github.com/google/double-conversion/commit/da11179623145f53b204105a93b8bbca431141da
-
-Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
-[Julien: rebased on version 1.10.1]
-Signed-off-by: Julien Olivain <juju@cotds.org>
----
- Foundation/src/utils.h | 2 ++
- 1 file changed, 2 insertions(+)
-
-diff --git a/Foundation/src/utils.h b/Foundation/src/utils.h
-index c87cee13c..e891c0f10 100644
---- a/Foundation/src/utils.h
-+++ b/Foundation/src/utils.h
-@@ -66,6 +66,8 @@
-              defined(__AARCH64EL__) || \
-     defined(nios2) || defined(__nios2) || defined(__nios2__)
- #define DOUBLE_CONVERSION_CORRECT_DOUBLE_OPERATIONS 1
-+#elif defined(__mc68000__)
-+#undef DOUBLE_CONVERSION_CORRECT_DOUBLE_OPERATIONS
- #elif defined(_M_IX86) || defined(__i386__) || defined(__i386)
- #if defined(_WIN32)
- // Windows uses a 64bit wide floating point stack.
---
-2.26.2
-
diff --git a/package/poco/0003-Foundation-src-utils.h-backport-double-conversion-ch.patch b/package/poco/0003-Foundation-src-utils.h-backport-double-conversion-ch.patch
deleted file mode 100644
index c06eebe8b0..0000000000
--- a/package/poco/0003-Foundation-src-utils.h-backport-double-conversion-ch.patch
+++ /dev/null
@@ -1,34 +0,0 @@ 
-From fe7d230da03a35725ef768c07ce064324f941863 Mon Sep 17 00:00:00 2001
-From: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
-Date: Sun, 1 Jul 2018 15:37:47 +0200
-Subject: [PATCH] Foundation/src/utils.h: backport double-conversion change for
- AArch64 BE support
-
-This commit, identical to upstream double-conversion commit
-https://github.com/google/double-conversion/commit/cb2beeb6771025377c665d1c3ea08388bc6e619a
-allows Poco to build on AArch64 big-endian.
-
-Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
-Upstream: https://github.com/pocoproject/poco/pull/2378
-[Julien: rebased on version 1.10.1]
-Signed-off-by: Julien Olivain <juju@cotds.org>
----
- Foundation/src/utils.h | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/Foundation/src/utils.h b/Foundation/src/utils.h
-index e891c0f10..892f7db18 100644
---- a/Foundation/src/utils.h
-+++ b/Foundation/src/utils.h
-@@ -63,7 +63,7 @@
-     defined(__SH4__) || defined(__alpha__) || \
-     defined(_MIPS_ARCH_MIPS32R2) || \
-     defined(__riscv) || \
--             defined(__AARCH64EL__) || \
-+            defined(__AARCH64EL__) || defined(__aarch64__) || \
-     defined(nios2) || defined(__nios2) || defined(__nios2__)
- #define DOUBLE_CONVERSION_CORRECT_DOUBLE_OPERATIONS 1
- #elif defined(__mc68000__)
---
-2.26.2
-
diff --git a/package/poco/poco.hash b/package/poco/poco.hash
index 2a2629733d..78d7d0b96e 100644
--- a/package/poco/poco.hash
+++ b/package/poco/poco.hash
@@ -1,3 +1,3 @@ 
# Locally computed
-sha256  44592a488d2830c0b4f3bfe4ae41f0c46abbfad49828d938714444e858a00818  poco-1.10.1.tar.gz
+sha256  2412a5819a239ff2ee58f81033bcc39c40460d7a8b330013a687c8c0bd2b4ac0  poco-1.11.1.tar.gz
sha256  c4b1e1e5f36d8331737231fefcc30f5714326aec7c387ad59a8115eb0ba7d6b5  LICENSE
diff --git a/package/poco/poco.mk b/package/poco/poco.mk
index 857f215e3a..814f6704da 100644
--- a/package/poco/poco.mk
+++ b/package/poco/poco.mk
@@ -4,7 +4,7 @@ 
#
################################################################################

-POCO_VERSION = 1.10.1
+POCO_VERSION = 1.11.1
POCO_SITE = $(call github,pocoproject,poco,poco-$(POCO_VERSION)-release)
POCO_LICENSE = BSL-1.0
POCO_LICENSE_FILES = LICENSE
@@ -66,14 +66,14 @@  define POCO_CONFIGURE_CMDS
                               $(POCO_CONF_OPTS) \
                               --unbundled \
                               --no-tests \
-                              --no-samples)
+                             --no-samples \
+                             --mysql-lib=$(STAGING_DIR)/usr/lib/mysql \
+                             --mysql-include=$(STAGING_DIR)/usr/include/mysql)
endef

 # Use $(MAKE1) to avoid failures on heavilly parallel machines (e.g. -j25)
define POCO_BUILD_CMDS
               $(TARGET_MAKE_ENV) $(MAKE1) POCO_TARGET_OSARCH=$(ARCH) CROSS_COMPILE=$(TARGET_CROSS) \
-                              MYSQL_LIBDIR=$(STAGING_DIR)/usr/lib/mysql \
-                              MYSQL_INCDIR=$(STAGING_DIR)/usr/include/mysql \
                               DEFAULT_TARGET=$(POCO_MAKE_TARGET) -C $(@D)
endef